summaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2017-03-08 11:49:40 +0000
committerLars Engels <lme@FreeBSD.org>2017-03-08 11:49:40 +0000
commit5b616787057d7e634c69f0c7ba3119a472c933c3 (patch)
tree54af2512897acebef6c686fbebf9bf37eb94eca3 /net-mgmt
parent0239e18ae0475359ba92e04376c6d29e1f21309e (diff)
downloadfreebsd-ports-5b616787057d7e634c69f0c7ba3119a472c933c3.zip
Add net-mgmt/icingaweb2-module-generictts
Generic TTS implements Icinga Web 2's ticket hook for replacing ticket patterns with links to your trouble ticket system (TTS). Icinga Web 2's core module monitoring for example uses the ticket hook for acknowledgements, downtimes and comments. Other modules may use the ticket hook for all kinds of text too. WWW: https://github.com/Icinga/icingaweb2-module-generictts
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/icingaweb2-module-generictts/Makefile29
-rw-r--r--net-mgmt/icingaweb2-module-generictts/distinfo3
-rw-r--r--net-mgmt/icingaweb2-module-generictts/pkg-descr6
-rw-r--r--net-mgmt/icingaweb2-module-generictts/pkg-plist15
5 files changed, 54 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 22a3a1f27a02..aa1b7ace6a9d 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -83,6 +83,7 @@
SUBDIR += icinga-core
SUBDIR += icinga2
SUBDIR += icingaweb2
+ SUBDIR += icingaweb2-module-generictts
SUBDIR += icli
SUBDIR += icmpmonitor
SUBDIR += icmpquery
diff --git a/net-mgmt/icingaweb2-module-generictts/Makefile b/net-mgmt/icingaweb2-module-generictts/Makefile
new file mode 100644
index 000000000000..a7c141914b4a
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-generictts/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= icingaweb2-module-generictts
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.0.0
+CATEGORIES= net-mgmt www
+
+MAINTAINER= lme@FreeBSD.org
+COMMENT= Generic ticket system integration into Icinga web 2
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= icingaweb2>=2.4.1:net-mgmt/icingaweb2
+
+USE_GITHUB= yes
+GH_ACCOUNT= icinga
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+WWWDIR?= ${PREFIX}/www/icingaweb2/modules/${PORTNAME:C/^.*-//}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC} && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/icingaweb2-module-generictts/distinfo b/net-mgmt/icingaweb2-module-generictts/distinfo
new file mode 100644
index 000000000000..d21aac82dae2
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-generictts/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1488972109
+SHA256 (icinga-icingaweb2-module-generictts-v2.0.0_GH0.tar.gz) = 7fcffc7125a89e9ea7a029fdb61ee341912b9b827a4aa373b4e39d7073102d02
+SIZE (icinga-icingaweb2-module-generictts-v2.0.0_GH0.tar.gz) = 11741
diff --git a/net-mgmt/icingaweb2-module-generictts/pkg-descr b/net-mgmt/icingaweb2-module-generictts/pkg-descr
new file mode 100644
index 000000000000..cb2adb4257eb
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-generictts/pkg-descr
@@ -0,0 +1,6 @@
+Generic TTS implements Icinga Web 2's ticket hook for replacing ticket patterns
+with links to your trouble ticket system (TTS). Icinga Web 2's core module
+monitoring for example uses the ticket hook for acknowledgements, downtimes and
+comments. Other modules may use the ticket hook for all kinds of text too.
+
+WWW: https://github.com/Icinga/icingaweb2-module-generictts
diff --git a/net-mgmt/icingaweb2-module-generictts/pkg-plist b/net-mgmt/icingaweb2-module-generictts/pkg-plist
new file mode 100644
index 000000000000..e64c219d667a
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-generictts/pkg-plist
@@ -0,0 +1,15 @@
+%%WWWDIR%%/.mailmap
+%%WWWDIR%%/AUTHORS
+%%WWWDIR%%/COPYING
+%%WWWDIR%%/README.md
+%%WWWDIR%%/application/controllers/IntegrationsController.php
+%%WWWDIR%%/application/forms/Config/TtsIntegrationConfigForm.php
+%%WWWDIR%%/application/views/scripts/integrations/index.phtml
+%%WWWDIR%%/application/views/scripts/integrations/new.phtml
+%%WWWDIR%%/application/views/scripts/integrations/remove.phtml
+%%WWWDIR%%/application/views/scripts/integrations/update.phtml
+%%WWWDIR%%/configuration.php
+%%WWWDIR%%/library/Generictts/Ticket.php
+%%WWWDIR%%/module.info
+%%WWWDIR%%/public/css/module.less
+%%WWWDIR%%/run.php