summaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-01-14 10:04:27 -0800
committerYuri Victorovich <yuri@FreeBSD.org>2022-01-14 10:06:01 -0800
commit391fef9e9f2a873effd31feabbe50ecbf4ec4811 (patch)
treec69810b33a2f0c76de34633b2f050859571305d8 /multimedia
parent0e46cdf18498118d3309812946e1df0245d62cb0 (diff)
downloadfreebsd-ports-391fef9e9f2a873effd31feabbe50ecbf4ec4811.zip
multimedia/obs-ndi: Fix lookup path for libndi.so and add it as dependency
PR: 258694 Reported by: mario felicioni <marietto2008@gmail.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/obs-ndi/Makefile3
-rw-r--r--multimedia/obs-ndi/files/patch-src_obs-ndi.cpp11
2 files changed, 13 insertions, 1 deletions
diff --git a/multimedia/obs-ndi/Makefile b/multimedia/obs-ndi/Makefile
index 97304ff52748..a456aaab3c0c 100644
--- a/multimedia/obs-ndi/Makefile
+++ b/multimedia/obs-ndi/Makefile
@@ -1,6 +1,6 @@
PORTNAME= obs-ndi
DISTVERSION= 4.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MAINTAINER= yuri@FreeBSD.org
@@ -10,6 +10,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libobs.so:multimedia/obs-studio
+RUN_DEPENDS= ${LOCALBASE}/lib/libndi.so:multimedia/libndi
USES= cmake compiler:c++11-lang localbase:ldflags qt:5
USE_GITHUB= yes
diff --git a/multimedia/obs-ndi/files/patch-src_obs-ndi.cpp b/multimedia/obs-ndi/files/patch-src_obs-ndi.cpp
new file mode 100644
index 000000000000..f8eb273db537
--- /dev/null
+++ b/multimedia/obs-ndi/files/patch-src_obs-ndi.cpp
@@ -0,0 +1,11 @@
+--- src/obs-ndi.cpp.orig 2022-01-14 17:54:22 UTC
++++ src/obs-ndi.cpp
+@@ -198,7 +198,7 @@ const NDIlib_v4* load_ndilib()
+ {
+ QStringList locations;
+ locations << QString(qgetenv(NDILIB_REDIST_FOLDER));
+-#if defined(__linux__) || defined(__APPLE__)
++#if defined(__linux__) || defined(__APPLE__) || defined(__FreeBSD__)
+ locations << "/usr/lib";
+ locations << "/usr/local/lib";
+ #endif