summaryrefslogtreecommitdiff
path: root/misc/konq-plugins-kde4/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-03-09 13:11:15 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-03-09 13:11:15 +0000
commitf76a4031d5cf0e1312fe4f150747b543cb8851d0 (patch)
tree0108c076a56e78d4c3bd4bb3ff16d3ee31201c48 /misc/konq-plugins-kde4/Makefile
parent7b004551c152365aa338d1e0e5ae04bfdfe3ccdc (diff)
downloadfreebsd-ports-f76a4031d5cf0e1312fe4f150747b543cb8851d0.zip
Add konq-plugins, additional features and plugins for Konqueror (part of
kdebase) in webbrowser mode.
Diffstat (limited to 'misc/konq-plugins-kde4/Makefile')
-rw-r--r--misc/konq-plugins-kde4/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/misc/konq-plugins-kde4/Makefile b/misc/konq-plugins-kde4/Makefile
new file mode 100644
index 000000000000..5b6231510fbf
--- /dev/null
+++ b/misc/konq-plugins-kde4/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: konq-plugins
+# Date created: 11 February 2004
+# Whom: Michael Nottebrock <lofi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${KONQPLUGINS_PORTNAME}
+PORTVERSION= ${KONQPLUGINS_PORTVERSION}
+PORTREVISION= ${KONQPLUGINS_PORTREVISION}
+CATEGORIES= misc kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Additonal plugins and features for Konqueror
+
+IGNORE= This port is part of KDE 3.2.1 and is not yet ready
+
+KDE_SPLIT= ${KONQPLUGINS_PORTNAME:S/${KDE_SPLIT_DIST}-//}
+USE_KDEBASE_VER=3
+USE_KDELIBS_VER=3
+
+USE_BZIP2= yes
+PREFIX= ${KDE_PREFIX}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS+= %%PREFIX%%/lib/kde3
+
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include "${.CURDIR}/../../misc/kdeaddons3/Makefile.split"
+.include <bsd.port.mk>