summaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-03-13 00:02:57 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-03-13 00:02:57 +0000
commit559697321a6c96a8a5aca779fc97fa8d292d61f1 (patch)
tree0e9960546283884e2b70d3501bc16a817169b883 /math
parent8d14ec26dde8ca012fb34a2b065d651d90ac5fc5 (diff)
downloadfreebsd-ports-559697321a6c96a8a5aca779fc97fa8d292d61f1.zip
math/the-algorithms-c++: fix build without libomp
CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage CMake Error at /usr/local/share/cmake/Modules/FindOpenMP.cmake:261 (try_compile): Failed to configure test project build system. Call Stack (most recent call first): /usr/local/share/cmake/Modules/FindOpenMP.cmake:537 (_OPENMP_GET_FLAGS) CMakeLists.txt:21 (find_package)
Diffstat (limited to 'math')
-rw-r--r--math/the-algorithms-c++/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/math/the-algorithms-c++/Makefile b/math/the-algorithms-c++/Makefile
index 6422d51c9e00..f8856b89f2c3 100644
--- a/math/the-algorithms-c++/Makefile
+++ b/math/the-algorithms-c++/Makefile
@@ -10,6 +10,9 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake gl localbase:ldflags
+.if !exists(/usr/include/omp.h)
+CMAKE_OFF= USE_OPENMP
+.endif
USE_GL= gl glut
USE_GITHUB= yes