summaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2021-06-04 05:53:21 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2021-06-04 05:53:21 +0000
commitd09ed096c44ca516f3e4922e292b4afabd03ff11 (patch)
tree8472e59ca02578120ca7b8bc5e2af50d2954440e /math
parent31a195fb72446a7d02336b8fa1b9c1e0032f95cb (diff)
downloadfreebsd-ports-d09ed096c44ca516f3e4922e292b4afabd03ff11.zip
*/*: Replace USE_GCC=any with USE_GCC=yes
USE_GCC=any has been equivalent to USE_GCC=yes in most cases (such as i386 and amd64 since 12.x and depending on configuration 11.x, most newer installations on other platforms, and 13.x across the board). Since commit 96c17633d90386b5bcf8 Mk/bsd.gcc.mk is treating them as different spellings of the same, so continue the deorbiting of the USE_GCC=any form and simply replace it with USE_GCC=yes. This should not make any functional difference at all. Discussed with: mat, linimon, pkubaj
Diffstat (limited to 'math')
-rw-r--r--math/cvc3/Makefile2
-rw-r--r--math/lidia/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/math/cvc3/Makefile b/math/cvc3/Makefile
index 4f23e01e39ff..5581e7c38ddd 100644
--- a/math/cvc3/Makefile
+++ b/math/cvc3/Makefile
@@ -21,7 +21,7 @@ GNU_CONFIGURE= yes
USES= bison gmake pathfix perl5
PATHFIX_MAKEFILEIN= Makefile
USE_CXXSTD= gnu++98
-USE_GCC= any
+USE_GCC= yes
USE_LDCONFIG= yes
post-patch:
diff --git a/math/lidia/Makefile b/math/lidia/Makefile
index c8c8da6b5113..5d73c637e7b6 100644
--- a/math/lidia/Makefile
+++ b/math/lidia/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libgmp.so:math/gmp
USES= gmake localbase:ldflags tar:bz2 libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static --enable-shared --with-extra-libs=${LOCALBASE}/lib
-USE_GCC= any # doesn't build with clang, no active developers to fix this: https://github.com/mkoeppe/LiDIA/issues/6
+USE_GCC= yes # doesn't build with clang, no active developers to fix this: https://github.com/mkoeppe/LiDIA/issues/6
USE_LDCONFIG= yes
.include <bsd.port.mk>