summaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-07-02 19:49:09 -0700
committerYuri Victorovich <yuri@FreeBSD.org>2023-07-02 22:49:50 -0700
commitb994e5f35904996d1d65bc5229e9fce99005d0f4 (patch)
tree92aee6a9591f85f723face4597ea32c0389ec3f2 /mail
parentb391a577c3ee9876b553344db224431c9de2c424 (diff)
downloadfreebsd-ports-b994e5f35904996d1d65bc5229e9fce99005d0f4.zip
mail/py-pyisemail: New port: Simple, robust email validation
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/py-pyisemail/Makefile23
-rw-r--r--mail/py-pyisemail/distinfo3
-rw-r--r--mail/py-pyisemail/pkg-descr2
4 files changed, 29 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 19e518a9ffd7..65f3f4bef08b 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -519,6 +519,7 @@
SUBDIR += py-offlineimap3
SUBDIR += py-postfix-mta-sts-resolver
SUBDIR += py-premailer
+ SUBDIR += py-pyisemail
SUBDIR += py-pymailq
SUBDIR += py-pysasl
SUBDIR += py-pyspf
diff --git a/mail/py-pyisemail/Makefile b/mail/py-pyisemail/Makefile
new file mode 100644
index 000000000000..fe5dbe3f1477
--- /dev/null
+++ b/mail/py-pyisemail/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= pyisemail
+DISTVERSION= 2.0.1
+CATEGORIES= mail python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Simple, robust email validation
+WWW= http://michaelherold.github.io/pyIsEmail/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatch>0:devel/py-hatch@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}hatchling>0:devel/py-hatchling@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>=2.0.0:dns/py-dnspython@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/mail/py-pyisemail/distinfo b/mail/py-pyisemail/distinfo
new file mode 100644
index 000000000000..4c4afc9a5064
--- /dev/null
+++ b/mail/py-pyisemail/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1688351383
+SHA256 (pyisemail-2.0.1.tar.gz) = daf4b3fb2150a38f406b0aaba729e19fcd638a6d1c0549c25ff54c7b804618f8
+SIZE (pyisemail-2.0.1.tar.gz) = 22121
diff --git a/mail/py-pyisemail/pkg-descr b/mail/py-pyisemail/pkg-descr
new file mode 100644
index 000000000000..cf2819fb171f
--- /dev/null
+++ b/mail/py-pyisemail/pkg-descr
@@ -0,0 +1,2 @@
+pyIsEmail is a no-nonsense approach for checking whether that user-supplied
+email address could be real.