summaryrefslogtreecommitdiff
path: root/mail/neomutt
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2020-04-29 07:12:15 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2020-04-29 07:12:15 +0000
commit1e7fcaf34f326a76d163e4d7e3b709825ac9cdd2 (patch)
tree1b720e718c160e86b47010b6d5c4b6cd02ae7100 /mail/neomutt
parentea810d4ebf046a90a3b90535e3601c7ca188ab0d (diff)
downloadfreebsd-ports-1e7fcaf34f326a76d163e4d7e3b709825ac9cdd2.zip
Update to 20200424
Add an upstream patch to fix a regression in the display of the sidebar
Diffstat (limited to 'mail/neomutt')
-rw-r--r--mail/neomutt/Makefile4
-rw-r--r--mail/neomutt/distinfo6
-rw-r--r--mail/neomutt/files/0001-fix-sidebar-use-abbreviated-path-if-possible.patch41
3 files changed, 46 insertions, 5 deletions
diff --git a/mail/neomutt/Makefile b/mail/neomutt/Makefile
index a1675cef08e4..506e714b5298 100644
--- a/mail/neomutt/Makefile
+++ b/mail/neomutt/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= neomutt
-PORTVERSION= 20200417
+PORTVERSION= 20200424
CATEGORIES= mail
MAINTAINER= bapt@FreeBSD.org
@@ -24,7 +24,7 @@ HAS_CONFIGURE= yes
OPTIONS_SUB= yes
SHEBANG_FILES= contrib/smime_keys
-EXTRA_PATCHES= ${FILESDIR}/indent-sidebar.patch:-p1
+EXTRA_PATCHES= ${FILESDIR}/0001-fix-sidebar-use-abbreviated-path-if-possible.patch:-p1
OPTIONS_DEFINE= NLS DOCS SASL IDN FLOCK GPGME NOTMUCH
OPTIONS_DEFAULT=SASL TOKYOCABINET NOTMUCH GPGME LMDB NCURSES GSSAPI_BASE
diff --git a/mail/neomutt/distinfo b/mail/neomutt/distinfo
index 7ac5f230ca9e..0b28e01813cb 100644
--- a/mail/neomutt/distinfo
+++ b/mail/neomutt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1587368728
-SHA256 (neomutt-neomutt-20200417_GH0.tar.gz) = 6ed358053ae17694b580f3b5b13eec9f00f5a7320e76fae6fba767607c40cc48
-SIZE (neomutt-neomutt-20200417_GH0.tar.gz) = 3322435
+TIMESTAMP = 1588144159
+SHA256 (neomutt-neomutt-20200424_GH0.tar.gz) = e708d04f057a788041acaced765861bcfbab50f287f8e83620447ec8eb5145df
+SIZE (neomutt-neomutt-20200424_GH0.tar.gz) = 3323821
diff --git a/mail/neomutt/files/0001-fix-sidebar-use-abbreviated-path-if-possible.patch b/mail/neomutt/files/0001-fix-sidebar-use-abbreviated-path-if-possible.patch
new file mode 100644
index 000000000000..6e665b590aba
--- /dev/null
+++ b/mail/neomutt/files/0001-fix-sidebar-use-abbreviated-path-if-possible.patch
@@ -0,0 +1,41 @@
+From 96af299e8c8aff16f4c5e400f79d6edc3792eef5 Mon Sep 17 00:00:00 2001
+From: Austin Ray <austin@austinray.io>
+Date: Tue, 28 Apr 2020 21:00:57 -0400
+Subject: [PATCH] fix(sidebar): use abbreviated path if possible
+
+After the refactor in commit d77c704ceb85f34061e1333ab9c8eb5a264a0685,
+the sidebar only displays a mailbox's full path/URI except in the case
+of 'sidebar_short_path'. The full path/URI is not preferable for end
+users.
+
+What broke during the refactor is how the variable 'display' is updated.
+It's initialized to a mailbox's full path/URI and only updated if using
+'sidebar_short_path'. However, after initialization, an abbreviation is
+calculated to remove the 'folder' or protocol.
+
+To resolve this issue, if there's an abbreviation, store it in the
+'display' variable.
+
+Fixes #2293
+---
+ sidebar.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/sidebar.c b/sidebar.c
+index 810146e66..bc680000d 100644
+--- a/sidebar.c
++++ b/sidebar.c
+@@ -1101,6 +1101,10 @@ static void draw_sidebar(struct MuttWindow *win, int num_rows, int num_cols, int
+ if (!abbr)
+ abbr = abbrev_url(display, m->type);
+
++ // Use the abbreviation if we have one. The full path is not preferable.
++ if (abbr)
++ display = abbr;
++
+ const char *last_part = abbr;
+ int depth = calc_path_depth(abbr, C_SidebarDelimChars, &last_part);
+
+--
+2.26.2
+