summaryrefslogtreecommitdiff
path: root/mail/neomutt
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-11-04 17:37:13 +0100
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-11-04 17:38:33 +0100
commit1c73e88d577ca0bee1edb1e93036cd59ff704119 (patch)
tree531fc17491256eb1e1d72e47237067db5aeb9d5c /mail/neomutt
parentbfb64865610ab98c0bfdb30a7cef4e8f3f8d3b84 (diff)
downloadfreebsd-ports-1c73e88d577ca0bee1edb1e93036cd59ff704119.zip
mail/neomutt: enforce pcre2
pcre2 is much faster than our internal regex engine, which makes neomutt slow because some part of the mail headers are parsed using regexp Reported by: gahr
Diffstat (limited to 'mail/neomutt')
-rw-r--r--mail/neomutt/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/mail/neomutt/Makefile b/mail/neomutt/Makefile
index c405f6c0d6b5..8d2337c8872c 100644
--- a/mail/neomutt/Makefile
+++ b/mail/neomutt/Makefile
@@ -1,5 +1,6 @@
PORTNAME= neomutt
PORTVERSION= 20211029
+PORTREVISION= 1
CATEGORIES= mail
MAINTAINER= bapt@FreeBSD.org
@@ -10,6 +11,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:misc/mime-support \
urlview:textproc/urlview
+LIB_DEPENDS= libpcre2-posix.so:devel/pcre2
USES= cpe iconv:translit localbase ncurses perl5 shebangfix ssl
@@ -42,6 +44,7 @@ SCREEN_DESC= Screen options
CONFIGURE_ARGS= --with-ssl="${OPENSSLBASE}" \
--locales-fix \
--fmemopen \
+ --pcre2 \
--mandir=${PREFIX}/man \
${ICONV_CONFIGURE_ARGS}