summaryrefslogtreecommitdiff
path: root/mail/fetchmail
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-02-14 21:23:19 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-02-14 21:23:19 +0000
commit32e15489c34a93191366d595d2163a8eabfd2572 (patch)
tree3ddfa2252fa5d4e3d271b6d743a0d07510ab7135 /mail/fetchmail
parentf32ae9add90a95bc8ed239b1cc313228a733a6d9 (diff)
downloadfreebsd-ports-32e15489c34a93191366d595d2163a8eabfd2572.zip
mail/fetchmail: update for new caroot infrastructure in base
PR: 243613 Submitted by: Helge Oldach <freebsd@oldach.net> Approved by: Corey Halpin <chalpin@cs.wisc.edu> (maintainer)
Diffstat (limited to 'mail/fetchmail')
-rw-r--r--mail/fetchmail/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index 665eca1fd304..1831d4ae3630 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2 LGPL21
LICENSE_COMB= dual
.if empty(MASTERDIR)
-RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
+CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
USES= cpe gmake tar:xz ssl
@@ -36,12 +36,14 @@ CONFIGURE_ARGS= --enable-opie --enable-RPA --enable-SDPS \
# for instance, libcom_err.so on GSSAPI_NONE builds:
LDFLAGS+= -L${LOCALBASE}/lib -Wl,--as-needed
-OPTIONS_DEFINE= NLS DOCS
+OPTIONS_DEFINE= CA_BUNDLE NLS DOCS
OPTIONS_SINGLE= GSSAPI
OPTIONS_SINGLE_GSSAPI= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT GSSAPI_NONE
-OPTIONS_DEFAULT= GSSAPI_BASE
+OPTIONS_DEFAULT= CA_BUNDLE GSSAPI_BASE
OPTIONS_SUB= yes
+CA_BUNDLE_DESC= Install CA bundle for OpenSSL
+
GSSAPI_BASE_USES= gssapi
GSSAPI_BASE_CONFIGURE_ON= --with-gssapi=${GSSAPIBASEDIR} ${GSSAPI_CONFIGURE_ARGS}
GSSAPI_HEIMDAL_USES= gssapi:heimdal