summaryrefslogtreecommitdiff
path: root/mail/fetchmail
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-11-20 23:51:01 +0100
committerMatthias Andree <mandree@FreeBSD.org>2021-11-20 23:51:30 +0100
commit1b50e97082ad95373cf08f07a5e4194a9f89336c (patch)
treec71ca7dc4d86191028ee185b9ef4d5e47ad18c06 /mail/fetchmail
parent30e97245f9dd9ddef1bffd874a9035a6fe9b6817 (diff)
downloadfreebsd-ports-1b50e97082ad95373cf08f07a5e4194a9f89336c.zip
Revert "mail/fetchmail: update to 6.4.24 and block LibreSSL."
This reverts commit 30e97245f9dd9ddef1bffd874a9035a6fe9b6817. That wasn't the approved patch, but a later WIP one. Fixing up.
Diffstat (limited to 'mail/fetchmail')
-rw-r--r--mail/fetchmail/Makefile78
-rw-r--r--mail/fetchmail/distinfo6
-rw-r--r--mail/fetchmail/files/patch-LibreSSL14
3 files changed, 48 insertions, 50 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index 186cebe7492d..21a0b7561e00 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -1,8 +1,8 @@
# Created by: Ville Eerola <ve@sci.fi>
PORTNAME?= fetchmail
-DISTVERSION= 6.4.25
-PORTREVISION?= 0
+DISTVERSION= 6.4.22
+PORTREVISION= 1
CATEGORIES= mail
# The next line is inherited by the fetchmailconf dependent port,
# do NOT replace fetchmail by ${PORTNAME}
@@ -11,73 +11,55 @@ MASTER_SITES= SF/fetchmail/branch_6.4/
MAINTAINER= chalpin@cs.wisc.edu
COMMENT?= Batch mail retrieval utility for IMAP/POP3/ETRN/ODMR
-LICENSE= GPLv2+
+LICENSE= GPLv2 LGPL21
+LICENSE_COMB= dual
.if empty(MASTERDIR)
-USES= cpe gmake tar:xz
-IGNORE_SSL= libressl libressl-devel
-IGNORE_SSL_REASON=incompatible license/no GPLv2 clause 2b exception for LibreSSL
-# The Free Software Foundation asserts that a GPL v2 clause 2b exception is
-# required even for dynamically linked binaries. See
-# https://www.gnu.org/licenses/gpl-faq.en.html#GPLStaticVsDynamic
+CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
+
+USES= cpe gmake tar:xz ssl
+
+USERS= ${PORTNAME}
+GROUPS= ${USERS}
USE_RC_SUBR= fetchmail
+SUB_FILES= pkg-message
GNU_CONFIGURE= yes
# the added PYTHON=: suppresses python builds,
# see ../../mail/fetchmailconf/ for the configuration tool
-CONFIGURE_ARGS= --enable-fallback=no \
- --enable-opie \
- --enable-RPA \
- --enable-SDPS \
- --without-hesiod \
- PYTHON=:
+CONFIGURE_ARGS= --enable-opie --enable-RPA --enable-SDPS \
+ --without-hesiod --enable-fallback=no \
+ --with-ssl=${OPENSSLBASE} PYTHON=:
# -Wl,--as-needed suppresses unneeded library references,
# for instance, libcom_err.so on GSSAPI_NONE builds:
LDFLAGS+= -L${LOCALBASE}/lib -Wl,--as-needed
-PATCH_STRIP= -p1
-SUB_FILES= pkg-message
-USERS= ${PORTNAME}
-GROUPS= ${USERS}
-
-OPTIONS_DEFINE= CA_BUNDLE DOCS NLS
-OPTIONS_DEFAULT= CA_BUNDLE GSSAPI_BASE OPENSSL
-OPTIONS_SINGLE= GSSAPI TLS
+OPTIONS_DEFINE= CA_BUNDLE NLS DOCS
+OPTIONS_SINGLE= GSSAPI
OPTIONS_SINGLE_GSSAPI= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT GSSAPI_NONE
-OPTIONS_SINGLE_TLS= OPENSSL WOLFSSL
-
-OPTIONS_SUB= yes
+OPTIONS_DEFAULT= CA_BUNDLE GSSAPI_BASE
+OPTIONS_SUB= yes
CA_BUNDLE_DESC= Install CA bundle for OpenSSL
-CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
-GSSAPI_BASE_USES= gssapi
-GSSAPI_BASE_CONFIGURE_ON= ${GSSAPI_CONFIGURE_ARGS} \
- --with-gssapi=${GSSAPIBASEDIR}
-GSSAPI_HEIMDAL_USES= gssapi:heimdal
-GSSAPI_HEIMDAL_CONFIGURE_ON= ${GSSAPI_CONFIGURE_ARGS} \
- --with-gssapi=${GSSAPIBASEDIR}
-GSSAPI_MIT_USES= gssapi:mit
-GSSAPI_MIT_CONFIGURE_ON= ${GSSAPI_CONFIGURE_ARGS} \
- --with-kerberos5=${GSSAPIBASEDIR}
+GSSAPI_BASE_USES= gssapi
+GSSAPI_BASE_CONFIGURE_ON= --with-gssapi=${GSSAPIBASEDIR} ${GSSAPI_CONFIGURE_ARGS}
+GSSAPI_HEIMDAL_USES= gssapi:heimdal
+GSSAPI_HEIMDAL_CONFIGURE_ON= --with-gssapi=${GSSAPIBASEDIR} ${GSSAPI_CONFIGURE_ARGS}
+GSSAPI_MIT_USES= gssapi:mit
+GSSAPI_MIT_CONFIGURE_ON= --with-kerberos5=${GSSAPIBASEDIR} ${GSSAPI_CONFIGURE_ARGS}
GSSAPI_NONE_CONFIGURE_ON= --without-gssapi
-NLS_USES= gettext
+NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-OPENSSL_CONFIGURE_WITH= ssl=${OPENSSLBASE}
-
-WOLFSSL_LIB_DEPENDS= libwolfssl.so:security/wolfssl
-WOLFSSL_CONFIGURE_WITH= wolfssl=${LOCALBASE}
-WOLFSSL_CONFIGURE_ON= WOLFSSL_TRUST_FILE=${LOCALBASE}/share/certs/ca-root-nss.crt
-WOLFSSL_USES_OFF= ssl
-
-PORTDOCS= FAQ FEATURES NEWS NOTES OLDNEWS README README.SSL \
- README.SSL-SERVER design-notes.html esrs-design-notes.html \
- fetchmail-FAQ.html fetchmail-features.html todo.html
+PORTDOCS= FAQ FEATURES NEWS NOTES OLDNEWS \
+ README README.SSL README.SSL-SERVER \
+ design-notes.html fetchmail-FAQ.html fetchmail-features.html \
+ esrs-design-notes.html todo.html
post-patch:
.if !exists(/usr/lib/libcom_err.so)
@@ -86,6 +68,8 @@ post-patch:
.endif
+PATCH_STRIP= -p1
+
.if empty(MASTERDIR)
post-build:
${MAKE_CMD} -C ${WRKSRC} check ; { r=$$? ; ( set -x ; ${CAT} "${WRKSRC}/test-suite.log" ) ; exit $$r ; }
diff --git a/mail/fetchmail/distinfo b/mail/fetchmail/distinfo
index 0d489a50c74e..fb8a0db605b6 100644
--- a/mail/fetchmail/distinfo
+++ b/mail/fetchmail/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1637433525
-SHA256 (fetchmail-6.4.25.tar.xz) = e661a3f46e967d3a01735f530563d3e1392de9e322301a1ea958d3f7a8e41f15
-SIZE (fetchmail-6.4.25.tar.xz) = 1334484
+TIMESTAMP = 1631567945
+SHA256 (fetchmail-6.4.22.tar.xz) = cc6818bd59435602169fa292d6d163d56b21c7f53112829470a3aceabe612c84
+SIZE (fetchmail-6.4.22.tar.xz) = 1330176
diff --git a/mail/fetchmail/files/patch-LibreSSL b/mail/fetchmail/files/patch-LibreSSL
new file mode 100644
index 000000000000..15bb350256f2
--- /dev/null
+++ b/mail/fetchmail/files/patch-LibreSSL
@@ -0,0 +1,14 @@
+$OpenBSD: patch-tls-aux_h,v 1.1 2021/07/29 10:44:07 sthen Exp $
+
+Index: tls-aux.h
+--- tls-aux.h.orig
++++ tls-aux.h
+@@ -8,7 +8,7 @@
+ #ifdef SSL_ENABLE
+ #include <openssl/opensslv.h>
+
+-# if defined(LIBRESSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x1010000fL
++# if OPENSSL_VERSION_NUMBER < 0x1010000fL
+ # undef OSSL110_API
+ # else
+ # define OSSL110_API 1