summaryrefslogtreecommitdiff
path: root/mail/exmh2/scripts
diff options
context:
space:
mode:
authorPeter Wemm <peter@FreeBSD.org>1997-07-02 04:59:54 +0000
committerPeter Wemm <peter@FreeBSD.org>1997-07-02 04:59:54 +0000
commite78c6755b35b67a0ef85e370e5e4a356e2fcff12 (patch)
treebceecd5f69879eafb732ed634bafcb9e4746a447 /mail/exmh2/scripts
parent0ce87a956739ab765ba0e6fddfed27bb8e3be21a (diff)
downloadfreebsd-ports-e78c6755b35b67a0ef85e370e5e4a356e2fcff12.zip
Update exmh-2.0gamma to 2.0delta. There's lots of bug fixes, as well as
things like koi8-r recognition, background news (nntp) processing, ispell support. Note that there's a horrible hack here to work around a weakness in bsd.port.mk. The distributed patches are relative to a subdir of ${WRKSRC} and bsd.port.mk doesn't seem to allow clean overriding of that to patch. I appended a second "-d dir" arg to PATCH_DIST_ARGS after the .include that set up the string with +=. patch seems to use the last instance of "-d dir" when there are several online (it's a simple parse-time chdir). Prompted by: pst (who also sent a partial update)
Diffstat (limited to 'mail/exmh2/scripts')
-rw-r--r--mail/exmh2/scripts/build6
1 files changed, 5 insertions, 1 deletions
diff --git a/mail/exmh2/scripts/build b/mail/exmh2/scripts/build
index 9a1f98158e98..5315b344193e 100644
--- a/mail/exmh2/scripts/build
+++ b/mail/exmh2/scripts/build
@@ -1,6 +1,6 @@
#! /bin/sh
#
-# $Id: build,v 1.1.1.1 1996/10/10 15:00:53 peter Exp $
+# $Id: build,v 1.2 1996/12/31 21:27:02 peter Exp $
#
VERSION="`sed -ne 's/^set vers \(.*\)/\1/p' ${WRKSRC}/exmh.install`"
@@ -18,6 +18,9 @@ PLAY="{}"
if [ -f ${PREFIX}/bin/expect ]; then
EXPECT=${PREFIX}/bin/expect #executable
fi
+if [ -f ${PREFIX}/bin/expectk ]; then
+ EXPECTK=${PREFIX}/bin/expectk #executable
+fi
if [ -d ${PREFIX}/share/faces ]; then
FACES=${PREFIX}/share/faces #dir
@@ -50,6 +53,7 @@ sed <${FILESDIR}/config \
-e "s+!!PREFIX!!+${PREFIX}+g" \
-e "s+!!WISH!!+${WISH}+g" \
-e "s+!!EXPECT!!+${EXPECT}+g" \
+ -e "s+!!EXPECTK!!+${EXPECTK}+g" \
-e "s+!!FACES!!+${FACES}+g" \
-e "s+!!DOMAIN!!+${DOMAIN}+g" \
-e "s+!!PGP!!+${PGP}+g" \