summaryrefslogtreecommitdiff
path: root/mail/claws-mail/Makefile
diff options
context:
space:
mode:
authorMilan Obuch <bsd@dino.sk>2022-10-31 22:14:18 +0100
committerJuraj Lutter <otis@FreeBSD.org>2022-10-31 22:57:46 +0100
commit362d1c601c4ce43ad6463dec09e2a7b99b8f170d (patch)
treecd87d7f76ca54fa304e2f25ec32c566012869a7f /mail/claws-mail/Makefile
parent1441b8233d6bb1e1cc095ac52d7fb3b735712d33 (diff)
downloadfreebsd-ports-362d1c601c4ce43ad6463dec09e2a7b99b8f170d.zip
mail/claws-mail: Allow for GTK2 or GTK3 variants
Claws Mail team released GTK3 version for some time along with older GTK2. Development focus slowly shifts to GTK3. Add the option to select GTK2 and GTK3 version, keeping GTK2 as default for now. PR: 267043 Approved by: Chris Hutchinson (maintainer)
Diffstat (limited to 'mail/claws-mail/Makefile')
-rw-r--r--mail/claws-mail/Makefile22
1 files changed, 20 insertions, 2 deletions
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 972a6d89f345..e6eea73f94f5 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -23,17 +23,21 @@ RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss \
USES= autoreconf compiler:c++11-lang cpe desktop-file-utils gettext \
gettext-tools gnome pathfix pkgconfig python:3.5+ shebangfix \
ssl xorg
-USE_GNOME= cairo gtk20 librsvg2
+USE_GNOME= cairo librsvg2
USE_XORG= ice sm
SHEBANG_FILES= tools/*.pl tools/*.py tools/tb2claws-mail
OPTIONS_DEFINE= COMPFACE DEBUG DOCS ENCHANT IPV6 LDAP NLS STARTUP \
THEMES
-OPTIONS_DEFAULT= COMPFACE ENCHANT STARTUP THEMES
+OPTIONS_DEFAULT= COMPFACE ENCHANT GTK2 STARTUP THEMES
+OPTIONS_RADIO= BRANCH
+OPTIONS_RADIO_BRANCH= GTK2 GTK3
OPTIONS_SUB= yes
COMPFACE_DESC= X-Face support
ENCHANT_DESC= Spell checking support
+GTK2_DESC= Build GTK2+ release
+GTK3_DESC= Build GTK3+ release
STARTUP_DESC= Startup notification support
THEMES_DESC= Additional themes
@@ -58,8 +62,22 @@ STARTUP_CONFIGURE_ENABLE= startup-notification
THEMES_RUN_DEPENDS= claws-mail-themes>0:x11-themes/claws-mail-themes
+.include <bsd.port.options.mk>
+MASTER_OPTIONS= ${PORT_OPTIONS}
.include "Makefile.claws"
+.if ${PORT_OPTIONS:MGTK2}
+USE_GNOME+= gtk20
+
+PLIST_SUB+= GTK2=""
+.else
+PLIST_SUB+= GTK2="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MGTK3}
+USE_GNOME+= gtk30
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/src/common/ssl.c