summaryrefslogtreecommitdiff
path: root/lang/php4
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-31 23:00:21 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-31 23:00:21 +0000
commit6bd407bcb28be2c7e1b7d43f1e42ce56a2987e31 (patch)
treee8003e288b2d932ecbe7735ef2d7e89c6cbbaae3 /lang/php4
parentd1735b853f799f19085da4327b342b0130b3dc6b (diff)
downloadfreebsd-ports-6bd407bcb28be2c7e1b7d43f1e42ce56a2987e31.zip
- Add a php extension pfpro (PayFlow Pro).
PR: ports/82843 Submitted by: Mike Durian <durian@shadetreesoftware.com> Approved by: maintainer timeout (1 month)
Diffstat (limited to 'lang/php4')
-rw-r--r--lang/php4/Makefile.ext5
1 files changed, 5 insertions, 0 deletions
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index fe616c381db6..830e33195f37 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -262,6 +262,11 @@ CONFIGURE_ARGS+=--with-pcre-regex=yes
PHP_HEADER_DIRS=pcrelib
.endif
+.if ${PHP_MODNAME} == "pfpro"
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libpfpro.so:${PORTSDIR}/finance/pfpro
+CONFIGURE_ARGS+=--with-pfpro
+.endif
+
.if ${PHP_MODNAME} == "pgsql"
USE_PGSQL= YES