summaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2002-11-11 21:22:05 +0000
committerGreg Lewis <glewis@FreeBSD.org>2002-11-11 21:22:05 +0000
commit636fcbf7ab379d69335584d00be283dc6b35679c (patch)
tree0e59b53a9721303502299639b6f5192c579c82c7 /java
parent76378afefc22709c1cb4e67cfff8e6528b562a21 (diff)
downloadfreebsd-ports-636fcbf7ab379d69335584d00be283dc6b35679c.zip
Fix user and group ownership of the installed files when they have been
built by someone other than root. Instead of moving the files with tar, move them with cpio and set up ownership. PR: 36411 (more ports still to go) Submitted by: alane
Diffstat (limited to 'java')
-rw-r--r--java/jre/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/java/jre/Makefile b/java/jre/Makefile
index 3a32046bcc5c..39465b74def4 100644
--- a/java/jre/Makefile
+++ b/java/jre/Makefile
@@ -37,6 +37,8 @@ STRIPFILES= bin/i386/green_threads/jre \
lib/i386/green_threads/libsysresource.so \
lib/i386/green_threads/libzip.so
+CPIO?= /usr/bin/cpio
+
.include <bsd.port.pre.mk>
.if ${PORTOBJFORMAT} == "aout"
@@ -55,8 +57,8 @@ do-install:
${MKDIR} ${PREFIX}/jre${JRE_VERSION}
${MKDIR} ${PREFIX}/share/java/classes
${MKDIR} ${PREFIX}/share/doc/java
- (cd ${WRKSRC} && ${TAR} -c -f - .) \
- | (cd ${PREFIX}/jre${JRE_VERSION} && ${TAR} --unlink -x -f -)
+ cd ${WRKSRC} && ${FIND} . \
+ | ${CPIO} -pdmu -R ${LIBOWN}:${LIBGRP} ${PREFIX}/jre${JRE_VERSION}
cd ${PREFIX}/jre${JRE_VERSION}/bin && \
${LN} -sf .java_wrapper java && \
cd i386/green_threads && \