summaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-11-09 16:31:19 +0000
committerJohn Marino <marino@FreeBSD.org>2014-11-09 16:31:19 +0000
commitb6fb83656db887ae78c72aa69fb599352eb5b4b7 (patch)
tree8c7e930b3e96a19bdf1148fb61bd4c2458148bbf /japanese
parent60f69213be5f4a9ce094d192a77f23673cb728e6 (diff)
downloadfreebsd-ports-b6fb83656db887ae78c72aa69fb599352eb5b4b7.zip
japanese/nethack34: Fix segfault on amd64 among other things
PR: 194611 Submitted by: WATANABE Kazuhiro
Diffstat (limited to 'japanese')
-rw-r--r--japanese/nethack34/Makefile4
-rw-r--r--japanese/nethack34/files/patch-include-config.h13
-rw-r--r--japanese/nethack34/files/patch-include__xwindow.h12
-rw-r--r--japanese/nethack34/files/patch-sys-unix-Makefile.top7
-rw-r--r--japanese/nethack34/files/patch-win__X11__JNetHack.ad61
-rw-r--r--japanese/nethack34/pkg-plist8
6 files changed, 93 insertions, 12 deletions
diff --git a/japanese/nethack34/Makefile b/japanese/nethack34/Makefile
index 97711e6bebc5..40eafa18f637 100644
--- a/japanese/nethack34/Makefile
+++ b/japanese/nethack34/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nethack
PORTVERSION= 3.4.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= japanese games
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}-src
@@ -68,6 +68,8 @@ do-configure:
post-install:
(cd ${WRKSRC}/doc && \
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} manpages)
+ ${INSTALL_DATA} ${WRKSRC}/win/X11/JNetHack.ad \
+ ${STAGEDIR}${PREFIX}/lib/X11/app-defaults/JNetHack
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} README.j ChangeLog.j INSTALL.j \
diff --git a/japanese/nethack34/files/patch-include-config.h b/japanese/nethack34/files/patch-include-config.h
index ea08b4c0aea9..c2fe112297b8 100644
--- a/japanese/nethack34/files/patch-include-config.h
+++ b/japanese/nethack34/files/patch-include-config.h
@@ -1,5 +1,14 @@
---- include/config.h.orig 2014-08-28 15:09:32.000000000 +0900
-+++ include/config.h 2014-08-28 15:10:15.000000000 +0900
+--- include/config.h.orig 2014-10-18 21:39:21.000000000 +0900
++++ include/config.h 2014-10-18 21:48:34.000000000 +0900
+@@ -133,7 +133,7 @@
+ * would allow:
+ * xpmtoppm <x11tiles.xpm | pnmscale 1.25 | ppmquant 90 >x11tiles_big.xpm
+ */
+-/*# define USE_XPM*/ /* Disable if you do not have the XPM library */
++# define USE_XPM /* Disable if you do not have the XPM library */
+ # ifdef USE_XPM
+ # define GRAPHIC_TOMBSTONE /* Use graphical tombstone (rip.xpm) */
+ # define X11LARGETILE /* Large tile for X11 */
@@ -219,7 +219,7 @@
* otherwise it will be the current directory.
*/
diff --git a/japanese/nethack34/files/patch-include__xwindow.h b/japanese/nethack34/files/patch-include__xwindow.h
new file mode 100644
index 000000000000..af933c4eb06c
--- /dev/null
+++ b/japanese/nethack34/files/patch-include__xwindow.h
@@ -0,0 +1,12 @@
+--- include/xwindow.h.orig 2003-12-08 08:39:13.000000000 +0900
++++ include/xwindow.h 2014-10-17 22:46:12.000000000 +0900
+@@ -78,6 +78,9 @@
+
+ extern XFontStruct *WindowFontStruct(/* Widget */);
+ extern Font WindowFont(/* Widget */);
++#ifdef XI18N
++extern XFontSet WindowFontSet(/* Widget */);
++#endif
+
+ #define XtCWindowResource "WindowResource"
+ #define XtCRows "Rows"
diff --git a/japanese/nethack34/files/patch-sys-unix-Makefile.top b/japanese/nethack34/files/patch-sys-unix-Makefile.top
index 8ba7b99028ba..af9c6d206d45 100644
--- a/japanese/nethack34/files/patch-sys-unix-Makefile.top
+++ b/japanese/nethack34/files/patch-sys-unix-Makefile.top
@@ -1,5 +1,5 @@
---- sys/unix/Makefile.top.orig 2014-09-01 22:34:32.000000000 +0900
-+++ sys/unix/Makefile.top 2014-09-01 22:36:34.000000000 +0900
+--- sys/unix/Makefile.top.orig 2014-10-22 13:50:35.000000000 +0900
++++ sys/unix/Makefile.top 2014-10-22 13:52:56.000000000 +0900
@@ -14,7 +14,6 @@
# MAKE = make
@@ -112,7 +112,7 @@
touch $(VARDIR)/perm $(VARDIR)/record
# and a reminder
@echo You may also want to install the man pages via the doc Makefile.
-@@ -241,20 +223,15 @@
+@@ -241,20 +223,14 @@
install: $(GAME) recover $(VARDAT) dungeon spec_levs
# set up the directories
# not all mkdirs have -p; those that don't will create a -p directory
@@ -126,7 +126,6 @@
- -$(CHOWN) $(GAMEUID) $(GAMEDIR) $(VARDIR) $(VARDIR)/save
- $(CHGRP) $(GAMEGRP) $(GAMEDIR) $(VARDIR) $(VARDIR)/save
- chmod $(DIRPERM) $(GAMEDIR) $(VARDIR) $(VARDIR)/save
-+ -chmod $(DIRPERM) ${DESTDIR}$(GAMEDIR) ${DESTDIR}$(VARDIR) ${DESTDIR}$(VARDIR)/save
# set up the game files
( $(MAKE) dofiles )
# set up some additional files
diff --git a/japanese/nethack34/files/patch-win__X11__JNetHack.ad b/japanese/nethack34/files/patch-win__X11__JNetHack.ad
new file mode 100644
index 000000000000..a529aec3bba5
--- /dev/null
+++ b/japanese/nethack34/files/patch-win__X11__JNetHack.ad
@@ -0,0 +1,61 @@
+--- win/X11/JNetHack.ad.orig 2014-10-18 21:32:38.000000000 +0900
++++ win/X11/JNetHack.ad 2014-10-18 21:36:57.000000000 +0900
+@@ -22,11 +22,10 @@
+ ! the custom format - to enlarge an XPM file, use processing tools
+ ! such as XV or preferably PBMplus.
+ !
+-!JNetHack.tile_file: x11tiles32j
+-JNetHack.tile_file: t32-1024.xpm
+-JNetHack.tile_width: 32
+-JNetHack.tile_height: 32
+-!JNetHack.double_tile_size: True
++!JNetHack.tile_file: x11tiles
++!JNetHack.tile_width: 16
++!JNetHack.tile_height: 16
++!!JNetHack.double_tile_size: True
+ !
+ ! The annotation of pets.
+ JNetHack.pet_mark_bitmap: pet_mark.xbm
+@@ -132,6 +131,42 @@
+ JNetHack*player_selection*quit.accelerators: #override\n\
+ <Key>Escape: set() notify() unset()
+
++JNetHack*race_selection*random.borderColor: blue
++JNetHack*race_selection*random.borderWidth: 2
++JNetHack*race_selection*random.foreground: blue
++JNetHack*race_selection*random.accelerators: #override\n\
++ <Key>Return: set() notify() unset()
++JNetHack*race_selection*quit.borderColor: blue
++JNetHack*race_selection*quit.foreground: blue
++JNetHack*race_selection*Command.borderColor: red
++JNetHack*race_selection*Command.foreground: red
++JNetHack*race_selection*quit.accelerators: #override\n\
++ <Key>Escape: set() notify() unset()
++
++JNetHack*gender_selection*random.borderColor: blue
++JNetHack*gender_selection*random.borderWidth: 2
++JNetHack*gender_selection*random.foreground: blue
++JNetHack*gender_selection*random.accelerators: #override\n\
++ <Key>Return: set() notify() unset()
++JNetHack*gender_selection*quit.borderColor: blue
++JNetHack*gender_selection*quit.foreground: blue
++JNetHack*gender_selection*Command.borderColor: red
++JNetHack*gender_selection*Command.foreground: red
++JNetHack*gender_selection*quit.accelerators: #override\n\
++ <Key>Escape: set() notify() unset()
++
++JNetHack*alignment_selection*random.borderColor: blue
++JNetHack*alignment_selection*random.borderWidth: 2
++JNetHack*alignment_selection*random.foreground: blue
++JNetHack*alignment_selection*random.accelerators: #override\n\
++ <Key>Return: set() notify() unset()
++JNetHack*alignment_selection*quit.borderColor: blue
++JNetHack*alignment_selection*quit.foreground: blue
++JNetHack*alignment_selection*Command.borderColor: red
++JNetHack*alignment_selection*Command.foreground: red
++JNetHack*alignment_selection*quit.accelerators: #override\n\
++ <Key>Escape: set() notify() unset()
++
+ JNetHack*extended_commands*dismiss.borderColor: blue
+ JNetHack*extended_commands*dismiss.foreground: blue
+ JNetHack*extended_commands*help.borderColor: blue
diff --git a/japanese/nethack34/pkg-plist b/japanese/nethack34/pkg-plist
index b3b6adf35f5e..9c816c35610b 100644
--- a/japanese/nethack34/pkg-plist
+++ b/japanese/nethack34/pkg-plist
@@ -148,6 +148,7 @@ bin/%%HACKNAME%%
@mode
@owner
@group
+lib/X11/app-defaults/JNetHack
man/man6/dgn_comp.6.gz
man/man6/dlb.6.gz
man/man6/lev_comp.6.gz
@@ -158,8 +159,5 @@ man/man6/recover.6.gz
%%PORTDOCS%%%%DOCSDIR%%/INSTALL.j
%%PORTDOCS%%%%DOCSDIR%%/README.j
%%PORTDOCS%%%%DOCSDIR%%/jGuidebook.txt
-@exec chown games:games %D/%%DATADIR%%/save %D/%%DATADIR%%
-@exec chmod 0775 %D/%%DATADIR%%/save %D/%%DATADIR%%
-@dirrmtry %%DATADIR%%/save
-@dirrmtry %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dir(games,games,0775) %%DATADIR%%
+@dir(games,games,0775) %%DATADIR%%/save