summaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-09 18:37:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-09 18:37:50 +0000
commit3a2ecd3119802b928f0723f2d8d4a9fa8ba27af9 (patch)
tree146f9d25ee6f316e00cec434215870377dc482f3 /japanese
parent08fc6a1973dd3a2e2dfe81f1390386e0b59f61d5 (diff)
downloadfreebsd-ports-3a2ecd3119802b928f0723f2d8d4a9fa8ba27af9.zip
Exuberant Ctags with Japanese language support.
Exuberant Ctags generates an index (or tag) file of source language objects in source files that allows these items to be quickly and easily located by a text editor or other utility. Alternatively, it can generate a cross reference file which lists, in human-readable form, information about the various objects found in a set of source code files. Supported languages include: Assembler, ASP, AWK, BETA, C, C++, C#, COBOL, Eiffel, Fortran, HTML, Java, Javascript, Lisp, Lua, Make, Pascal, Perl, PHP, PL/SQL, Python, REXX, Ruby, S-Lang, Scheme, Shell (Bourne/Korn/Z), Standard ML, Tcl, Vera, Verilog, Vim and Yacc. WWW: http://hp.vector.co.jp/authors/VA025040/ctags/ PR: ports/113125 Submitted by: issei
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/ctags/Makefile34
-rw-r--r--japanese/ctags/distinfo3
-rw-r--r--japanese/ctags/files/patch-Makefile.in11
-rw-r--r--japanese/ctags/files/patch-man-ctags.126
-rw-r--r--japanese/ctags/pkg-descr16
-rw-r--r--japanese/ctags/pkg-message3
-rw-r--r--japanese/ctags/pkg-plist6
8 files changed, 100 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index c5f7d1754ad0..54c239e188af 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -30,6 +30,7 @@
SUBDIR += chimera
SUBDIR += citrix_ica
SUBDIR += csrd
+ SUBDIR += ctags
SUBDIR += dbskkd-cdb
SUBDIR += ddskk
SUBDIR += ddskk-emacs20
diff --git a/japanese/ctags/Makefile b/japanese/ctags/Makefile
new file mode 100644
index 000000000000..0377b4a2bfb6
--- /dev/null
+++ b/japanese/ctags/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: Exuberant Ctags with Japanese support
+# Date created: 29 May 2007
+# Whom: issei
+#
+# $FreeBSD$
+#
+
+PORTNAME= ctags
+PORTVERSION= 5.6j1
+CATEGORIES= japanese devel
+MASTER_SITES= http://hp.vector.co.jp/authors/VA025040/ctags/downloads/
+
+MAINTAINER= issei@issei.org
+COMMENT= A feature-filled tagfile generator with Japanese support
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-macro-patterns --with-readlib
+
+MAN1= jexctags.1
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in README README_J.TXT
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+ @${STRIP_CMD} ${PREFIX}/bin/jexctags
+ @${SED} 's:%%PREFIX%%:'${PREFIX}':' < ${PKGDIR}/pkg-message > ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/japanese/ctags/distinfo b/japanese/ctags/distinfo
new file mode 100644
index 000000000000..7dff9a8dfba1
--- /dev/null
+++ b/japanese/ctags/distinfo
@@ -0,0 +1,3 @@
+MD5 (ctags-5.6j1.tar.gz) = 801f533e5f25f74c13cbef6353c92e27
+SHA256 (ctags-5.6j1.tar.gz) = b521b46aada5a606a62c59f977c1de724a8a1a43b42fa5001591b9dad6b715a4
+SIZE (ctags-5.6j1.tar.gz) = 287476
diff --git a/japanese/ctags/files/patch-Makefile.in b/japanese/ctags/files/patch-Makefile.in
new file mode 100644
index 000000000000..9a6e28a44ccd
--- /dev/null
+++ b/japanese/ctags/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Tue May 30 22:51:24 2006
++++ Makefile.in Tue May 30 22:51:27 2006
+@@ -6,7 +6,7 @@
+ # These are the names of the installed programs, in case you wish to change
+ # them.
+ #
+-CTAGS_PROG = ctags
++CTAGS_PROG = jexctags
+ ETAGS_PROG = etags
+
+ # Set this to the path to your shell (must run Bourne shell commands).
diff --git a/japanese/ctags/files/patch-man-ctags.1 b/japanese/ctags/files/patch-man-ctags.1
new file mode 100644
index 000000000000..327a86c3de9e
--- /dev/null
+++ b/japanese/ctags/files/patch-man-ctags.1
@@ -0,0 +1,26 @@
+--- ctags.1.orig Mon Mar 19 10:21:32 2001
++++ ctags.1 Wed Mar 21 11:23:43 2001
+@@ -1,19 +1,19 @@
+-.TH CTAGS 1 "Version 5.0" "Darren Hiebert"
++.TH JEXCTAGS 1 "Version 5.0" "Darren Hiebert"
+
+
+ .SH "NAME"
+-ctags \- Generate tag files for source code
++jexctags \- Generate tag files for source code
+
+
+ .SH SYNOPSIS
+ .TP 6
+-\fBctags\fP [\fBoptions\fP] [\fIfile(s)\fP]
++\fBjexctags\fP [\fBoptions\fP] [\fIfile(s)\fP]
+ .TP 6
+ \fBetags\fP [\fBoptions\fP] [\fIfile(s)\fP]
+
+
+ .SH "DESCRIPTION"
+-The \fBctags\fP and \fBetags\fP programs (hereinafter collectively referred to
++The \fBjexctags\fP and \fBetags\fP programs (hereinafter collectively referred to
+ as \fBctags\fP, except where distinguished) generate an index (or "tag") file
+ for a variety of language objects found in \fIfile(s)\fP.
+ This tag file allows these items to be quickly and easily located by a text
diff --git a/japanese/ctags/pkg-descr b/japanese/ctags/pkg-descr
new file mode 100644
index 000000000000..a5ee569bbfd2
--- /dev/null
+++ b/japanese/ctags/pkg-descr
@@ -0,0 +1,16 @@
+Exuberant Ctags with Japanese language support.
+
+Exuberant Ctags generates an index (or tag) file of source language
+objects in source files that allows these items to be quickly and
+easily located by a text editor or other utility.
+
+Alternatively, it can generate a cross reference file which lists,
+in human-readable form, information about the various objects found
+in a set of source code files.
+
+Supported languages include: Assembler, ASP, AWK, BETA, C, C++, C#,
+COBOL, Eiffel, Fortran, HTML, Java, Javascript, Lisp, Lua, Make,
+Pascal, Perl, PHP, PL/SQL, Python, REXX, Ruby, S-Lang, Scheme, Shell
+(Bourne/Korn/Z), Standard ML, Tcl, Vera, Verilog, Vim and Yacc.
+
+WWW: http://hp.vector.co.jp/authors/VA025040/ctags/
diff --git a/japanese/ctags/pkg-message b/japanese/ctags/pkg-message
new file mode 100644
index 000000000000..79ca5cbc7e20
--- /dev/null
+++ b/japanese/ctags/pkg-message
@@ -0,0 +1,3 @@
+************************************************************
+The executable for Exuberant CTAGS is installed as %%PREFIX%%/bin/jexctags
+************************************************************
diff --git a/japanese/ctags/pkg-plist b/japanese/ctags/pkg-plist
new file mode 100644
index 000000000000..c8ea535c5037
--- /dev/null
+++ b/japanese/ctags/pkg-plist
@@ -0,0 +1,6 @@
+bin/jexctags
+include/readtags.h
+lib/readtags.o
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README_J.TXT
+@dirrm %%DOCSDIR%%