summaryrefslogtreecommitdiff
path: root/japanese/diclookup-emacs20/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-08-03 00:15:02 +0000
committerSatoshi Asami <asami@FreeBSD.org>1998-08-03 00:15:02 +0000
commitf53a04c335f471c16a0336d6c38d313c5fbf7f6e (patch)
tree0bcb549d871162a7bb53fcc7436910f7cac6cdb1 /japanese/diclookup-emacs20/Makefile
parentbe10e3a77d734bdb347e80f7cb83c8c05e94014d (diff)
downloadfreebsd-ports-f53a04c335f471c16a0336d6c38d313c5fbf7f6e.zip
Diclookup version 2.3.3, now as a separate port (from dserver). Client
machines can install this one only. It's also newer than what used to be in the dserver port, benefitting some people with newer dictionaries, such as Satoshi (that's me). PR: 7471 Submitted by: MITA Yoshio <Yoshio.Mita@isen.fr>
Diffstat (limited to 'japanese/diclookup-emacs20/Makefile')
-rw-r--r--japanese/diclookup-emacs20/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/japanese/diclookup-emacs20/Makefile b/japanese/diclookup-emacs20/Makefile
new file mode 100644
index 000000000000..d28aa25182a1
--- /dev/null
+++ b/japanese/diclookup-emacs20/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: diclookup-mule
+# Version required: 2.3.1beta2
+# Date created: 31 Jan 1998
+# Whom: Mita Yoshio <mita@jp.FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= diclookup-mule-2.3.3
+PKGNAME= ja-diclookup-mule-2.3.3
+CATEGORIES= japanese
+MASTER_SITES= ftp://ftp.math.s.chiba-u.ac.jp/tools/diclookup-mule/
+
+PATCH_SITES= ${MASTER_SITES}
+PATCHFILES= diclookup-mule-2.3.3-wave-patch.gz
+
+MAINTAINER= mita@jp.FreeBSD.org
+
+RUN_DEPENDS= ${X11BASE}/lib/X11/fonts/non-cjk/fonts.dir:${PORTSDIR}/x11/etlfonts
+BUILD_DEPENDS= mule:${PORTSDIR}/japanese/mule-wnn4
+
+post-install:
+ ${MKDIR} ${PREFIX}/lib/dserver/doc
+ @${SED} s!PREFIX_DIR!${PREFIX}!g ${FILESDIR}/setup-diclookup.sh \
+ > ${PREFIX}/lib/dserver/setup-diclookup.sh
+ @${SED} s!PREFIX_DIR!${PREFIX}!g ${FILESDIR}/deinstall-diclookup.sh \
+ > ${PREFIX}/lib/dserver/deinstall-diclookup.sh
+ ${INSTALL_DATA} ${FILESDIR}/README.diclookup-setup.txt \
+ ${PREFIX}/lib/dserver/doc
+ ${INSTALL_DATA} ${WRKSRC}/README \
+ ${PREFIX}/lib/dserver/doc/README.diclookup-mule
+ ${INSTALL_DATA} ${WRKSRC}/README.sirup \
+ ${PREFIX}/lib/dserver/doc/
+ ${INSTALL_DATA} ${WRKSRC}/lib/README \
+ ${PREFIX}/lib/dserver/doc/README.diclookup-mule.lib
+
+.include <bsd.port.mk>