summaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2015-05-21 18:18:37 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2015-05-21 18:18:37 +0000
commit0be0c4085919ab8dd634257218a3d5779dfc19c1 (patch)
treef2126bc75adcec4b4c51e1d0024f9d141b205b2f /irc
parent858f9538634f0972a96ab3d80b7b12dd1a9379c8 (diff)
downloadfreebsd-ports-0be0c4085919ab8dd634257218a3d5779dfc19c1.zip
- Update to 2.10.2, announce message is here:
http://hexchat.readthedocs.org/en/latest/changelog.html - Change master site from http://dl.hexchat.org/ to http://dl.hexchat.net - Remove obsolete REINPLACE, hexchat.appdata.xml install properly - Recreate patches, changed by upstream
Diffstat (limited to 'irc')
-rw-r--r--irc/hexchat/Makefile6
-rw-r--r--irc/hexchat/distinfo4
-rw-r--r--irc/hexchat/files/patch-src__common__server.c12
-rw-r--r--irc/hexchat/files/patch-src__common__ssl.c8
4 files changed, 14 insertions, 16 deletions
diff --git a/irc/hexchat/Makefile b/irc/hexchat/Makefile
index c2ecb2e32b41..09d90e065b4d 100644
--- a/irc/hexchat/Makefile
+++ b/irc/hexchat/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= hexchat
-PORTVERSION= 2.10.1
+PORTVERSION= 2.10.2
CATEGORIES= irc gnome ipv6
-MASTER_SITES= http://dl.hexchat.org/${PORTNAME}/
+MASTER_SITES= http://dl.hexchat.net/${PORTNAME}/
MAINTAINER= nemysis@FreeBSD.org
COMMENT= IRC chat program with GTK and Text Frontend
@@ -80,8 +80,6 @@ USE_GNOME+= gconf2
.endif
post-patch:
- @${REINPLACE_CMD} -e '/^appdata_DATA/s|hexchat.appdata.xml||' \
- ${WRKSRC}/data/misc/Makefile.in
@${REINPLACE_CMD} -e 's|%%CA_BUNDLE%%|${CA_BUNDLE}|' \
${WRKSRC}/src/common/server.c
diff --git a/irc/hexchat/distinfo b/irc/hexchat/distinfo
index eed343f57889..4ed169e71114 100644
--- a/irc/hexchat/distinfo
+++ b/irc/hexchat/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hexchat-2.10.1.tar.xz) = ffccee6a3470d2f9539e75bd0dd2e3f35c65737004cb02e6d2106c1d5dcde9a9
-SIZE (hexchat-2.10.1.tar.xz) = 1618372
+SHA256 (hexchat-2.10.2.tar.xz) = 87ebf365c576656fa3f23f51d319b3a6d279e4a932f2f8961d891dd5a5e1b52c
+SIZE (hexchat-2.10.2.tar.xz) = 1529732
diff --git a/irc/hexchat/files/patch-src__common__server.c b/irc/hexchat/files/patch-src__common__server.c
index 9d8a2048932f..725ae96f033b 100644
--- a/irc/hexchat/files/patch-src__common__server.c
+++ b/irc/hexchat/files/patch-src__common__server.c
@@ -1,11 +1,11 @@
---- ./src/common/server.c.orig 2013-09-12 00:18:19.000000000 +0200
-+++ ./src/common/server.c 2014-04-12 16:12:48.778585855 +0200
-@@ -862,7 +862,7 @@
+--- src/common/server.c.orig 2014-11-25 18:42:31.000000000 +0100
++++ src/common/server.c 2015-05-21 15:48:24.162789182 +0200
+@@ -875,7 +875,7 @@
/* it'll be a memory leak, if connection isn't terminated by
server_cleanup() */
- serv->ssl = _SSL_socket (ctx, serv->sok);
-- if ((err = _SSL_set_verify (ctx, ssl_cb_verify, NULL)))
-+ if ((err = _SSL_set_verify (ctx, ssl_cb_verify, %%CA_BUNDLE%%)))
+ serv->ssl = _SSL_socket (serv->ctx, serv->sok);
+- if ((err = _SSL_set_verify (serv->ctx, ssl_cb_verify, NULL)))
++ if ((err = _SSL_set_verify (serv->ctx, ssl_cb_verify, %%CA_BUNDLE%%)))
{
EMIT_SIGNAL (XP_TE_CONNFAIL, serv->server_session, err, NULL,
NULL, NULL, 0);
diff --git a/irc/hexchat/files/patch-src__common__ssl.c b/irc/hexchat/files/patch-src__common__ssl.c
index 7c1b66cc031f..1112fe1f025a 100644
--- a/irc/hexchat/files/patch-src__common__ssl.c
+++ b/irc/hexchat/files/patch-src__common__ssl.c
@@ -1,6 +1,6 @@
---- src/common/ssl.c.orig 2014-07-28 19:47:50 UTC
-+++ src/common/ssl.c
-@@ -310,7 +310,7 @@
+--- src/common/ssl.c.orig 2014-11-25 18:42:31.000000000 +0100
++++ src/common/ssl.c 2015-05-21 15:58:31.403630733 +0200
+@@ -320,7 +320,7 @@
__SSL_fill_err_buf ("SSL_CTX_set_default_verify_paths");
return (err_buf);
}
@@ -9,7 +9,7 @@
if (cacert)
{
if (!SSL_CTX_load_verify_locations (ctx, cacert, NULL))
-@@ -319,7 +319,7 @@
+@@ -329,7 +329,7 @@
return (err_buf);
}
}