summaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-22 07:37:59 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-22 07:37:59 +0000
commitfc7077556cbb08a1f9a6d96a344d487fe94eda8b (patch)
tree0bde9642dfda117173ca1b53a99c18bb70e6d94f /graphics
parent881451e6615786cd6bda1bf067aafd75be11ba58 (diff)
downloadfreebsd-ports-fc7077556cbb08a1f9a6d96a344d487fe94eda8b.zip
Add exifprobe 1.2.4, probes JPEG or TIFF images and reports contents and
structure. PR: ports/69403 Submitted by: Michael Johnson <ahze@ahze.net>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/exifprobe/Makefile39
-rw-r--r--graphics/exifprobe/distinfo2
-rw-r--r--graphics/exifprobe/pkg-descr11
4 files changed, 53 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index acaf72b60abc..652f0b1db0d3 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -74,6 +74,7 @@
SUBDIR += eterm-bg
SUBDIR += evas
SUBDIR += evolvotron
+ SUBDIR += exifprobe
SUBDIR += exiftags
SUBDIR += fbm
SUBDIR += feh
diff --git a/graphics/exifprobe/Makefile b/graphics/exifprobe/Makefile
new file mode 100644
index 000000000000..11913f3151b4
--- /dev/null
+++ b/graphics/exifprobe/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: exifprobe
+# Date created: 2004-07-21
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= exifprobe
+PORTVERSION= 1.2.4
+CATEGORIES= graphics
+MASTER_SITES= http://www.monroe.net/~dhh/exifprobe.d/
+
+MAINTAINER= ahze@ahze.net
+COMMENT= Probes JPEG or TIFF images and reports contents and structure
+
+USE_REINPLACE= yes
+
+MAN1= exifgrep.1 exifprobe.1
+PORTDOCS= DESCRIPTION exifprobe-rman.html
+PLIST_FILES= bin/exifgrep bin/exifprobe
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|cc|${CC}|; s|-DC|${CFLAGS} -DC|' \
+ ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/exifgrep ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/exifprobe ${PREFIX}/bin
+.for i in ${MAN1}
+ @${INSTALL_MAN} ${WRKSRC}/${i} ${MANPREFIX}/man/man1
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/exifprobe/distinfo b/graphics/exifprobe/distinfo
new file mode 100644
index 000000000000..d68255555f7c
--- /dev/null
+++ b/graphics/exifprobe/distinfo
@@ -0,0 +1,2 @@
+MD5 (exifprobe-1.2.4.tar.gz) = e10f72205e805928102fdcf44c508a64
+SIZE (exifprobe-1.2.4.tar.gz) = 108720
diff --git a/graphics/exifprobe/pkg-descr b/graphics/exifprobe/pkg-descr
new file mode 100644
index 000000000000..841e1ff9bbd2
--- /dev/null
+++ b/graphics/exifprobe/pkg-descr
@@ -0,0 +1,11 @@
+[From exifprobe(1)]
+
+Exifprobe examines and reports the contents and structure of JPEG and
+TIFF image files. It will recognize all standard JPEG markers (including
+APPn markers) and will report the contents of any properly structured TIFF
+IFD encountered, even when entry tags are not recognized. Recognized TIFF
+and TIFF/EP tags are expanded, including EXIF2.2 sections and camera MakerNotes
+which are found to be in TIFF IFD format. Location, size, and format of image
+data is reported by default.
+
+WWW: http://www.monroe.net/~dhh/exifprobe.d/exifprobe.html