summaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 02:44:22 +0200
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 02:48:20 +0200
commit95274bf4f99c71fc056013d966aec239161dfd74 (patch)
treebc1e95977678cb5b6b00b33e333b28161885e706 /graphics
parentdbe06d2da8c38d9d058f7939a7c6af36a2c0f1c7 (diff)
downloadfreebsd-ports-95274bf4f99c71fc056013d966aec239161dfd74.zip
*/*: Fix build with llvm16 on 13.2-STABLE
As like as HEAD(14.0-RELEASE) llvm16 was merged in base for 13.2-STABLE with the OSVERSION 1302507. - Utilize USE_CXXSTD=c++14 or similar solution where applicable - Update conditionals to addtionally check for OSVERSION greater than 1302507 and less than 1400000 Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'graphics')
-rw-r--r--graphics/agg/Makefile7
-rw-r--r--graphics/anttweakbar/Makefile2
-rw-r--r--graphics/devil/Makefile7
-rw-r--r--graphics/dia/Makefile2
-rw-r--r--graphics/djvulibre/Makefile7
-rw-r--r--graphics/gdchart/Makefile2
-rw-r--r--graphics/gle/Makefile2
-rw-r--r--graphics/mesa-demos/Makefile2
-rw-r--r--graphics/opennurbs/Makefile4
-rw-r--r--graphics/pixen/Makefile5
-rw-r--r--graphics/plotutils/Makefile7
-rw-r--r--graphics/povray37/Makefile5
-rw-r--r--graphics/py-pyvips/Makefile2
-rw-r--r--graphics/quesoglc/Makefile2
-rw-r--r--graphics/togl/Makefile2
15 files changed, 17 insertions, 41 deletions
diff --git a/graphics/agg/Makefile b/graphics/agg/Makefile
index 1564f22d1ed3..d36f004c0749 100644
--- a/graphics/agg/Makefile
+++ b/graphics/agg/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= libfreetype.so:print/freetype2
USES= autoreconf cpe gmake libtool pathfix pkgconfig sdl xorg
CPE_VENDOR= antigrain
+USE_CXXSTD= c++14
USE_LDCONFIG= yes
USE_SDL= sdl
USE_XORG= x11
@@ -25,12 +26,6 @@ GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
-CPPFLAGS+= -Dregister=
-.endif
-
post-patch:
@${REINPLACE_CMD} 's/_LDFLAGS/_LDADD/' ${WRKSRC}/examples/Makefile.am
diff --git a/graphics/anttweakbar/Makefile b/graphics/anttweakbar/Makefile
index 046e1d0b0028..a2914a650142 100644
--- a/graphics/anttweakbar/Makefile
+++ b/graphics/anttweakbar/Makefile
@@ -34,7 +34,7 @@ PLIST_FILES= include/AntTweakBar.h \
.include <bsd.port.options.mk>
post-patch:
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
@${REINPLACE_CMD} -e 's|public binary_function|public __binary_function|' \
${WRKSRC}/TwMgr.cpp
.endif
diff --git a/graphics/devil/Makefile b/graphics/devil/Makefile
index 9e32b36d06bc..38a32d02f057 100644
--- a/graphics/devil/Makefile
+++ b/graphics/devil/Makefile
@@ -13,6 +13,7 @@ LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake pkgconfig
+USE_CXXSTD= c++14
USE_GITHUB= yes
GH_ACCOUNT= DentonW
GH_PROJECT= DevIL
@@ -62,12 +63,6 @@ SQUISH_CMAKE_BOOL= IL_USE_DXTC_SQUISH
#NVTT_CMAKE_BOOL= IL_USE_DXTC_NVIDIA
CMAKE_ARGS+= -DIL_USE_DXTC_NVIDIA=0
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
-CXXFLAGS+= -Dregister=
-.endif
-
post-install-DOCS-on:
cd ${WRKSRC}/DevIL-docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/DevIL && ${INSTALL_DATA} CREDITS NEWS README.md TODO ${STAGEDIR}${DOCSDIR}/
diff --git a/graphics/dia/Makefile b/graphics/dia/Makefile
index db387895707d..1d1214ccda8e 100644
--- a/graphics/dia/Makefile
+++ b/graphics/dia/Makefile
@@ -43,7 +43,7 @@ CONFIGURE_ARGS+= --disable-libemf
PLIST_SUB+= WMF="@comment "
#.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/graphics/djvulibre/Makefile b/graphics/djvulibre/Makefile
index 3dc7fe8f0ef1..54cf4a929c87 100644
--- a/graphics/djvulibre/Makefile
+++ b/graphics/djvulibre/Makefile
@@ -14,6 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libtiff.so:graphics/tiff
USES= cpe gmake iconv jpeg libtool
+USE_CXXSTD= c++14
USE_LDCONFIG= yes
CPE_VENDOR= djvulibre_project
@@ -38,12 +39,6 @@ DESKTOPFILES_DESC= Install icons and mime types
DESKTOPFILES_CONFIGURE_ENABLE= desktopfiles
DESKTOPFILES_USES= gnome
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
-CPPFLAGS+= -Dregister=
-.endif
-
post-patch:
# Remove custom optimization compiler flags
@${REINPLACE_CMD} -e '/-[Og]\*)/d ; \
diff --git a/graphics/gdchart/Makefile b/graphics/gdchart/Makefile
index 844cd6ae5305..eac798c22a53 100644
--- a/graphics/gdchart/Makefile
+++ b/graphics/gdchart/Makefile
@@ -32,7 +32,7 @@ PLIST_SUB+= PROFILE="@comment "
PLIST_SUB+= PROFILE=""
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/graphics/gle/Makefile b/graphics/gle/Makefile
index 839d2bcb1922..bce3610a8951 100644
--- a/graphics/gle/Makefile
+++ b/graphics/gle/Makefile
@@ -27,7 +27,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/graphics/mesa-demos/Makefile b/graphics/mesa-demos/Makefile
index dbfe288960dd..f8a8bb89904e 100644
--- a/graphics/mesa-demos/Makefile
+++ b/graphics/mesa-demos/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ARGS+=--disable-gles1 --disable-osmesa --disable-vg --disable-wayland
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/graphics/opennurbs/Makefile b/graphics/opennurbs/Makefile
index 58b6fb58d7c3..bcbb8f284b46 100644
--- a/graphics/opennurbs/Makefile
+++ b/graphics/opennurbs/Makefile
@@ -37,8 +37,8 @@ MAKE_ARGS+= ON_GNU_OPTIMIZER_FLAGS="-g -fPIC"
.endif
post-patch:
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
- @${REINPLACE_CMD} -e 's|D_GNU_SOURCE -I|D_GNU_SOURCE -Dregister= -I|g' \
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+ @${REINPLACE_CMD} -e 's|D_GNU_SOURCE -I|D_GNU_SOURCE --std=c++14 -I|g' \
${WRKSRC}/makefile
.endif
diff --git a/graphics/pixen/Makefile b/graphics/pixen/Makefile
index e6e594945e27..dc4ce1d6c78e 100644
--- a/graphics/pixen/Makefile
+++ b/graphics/pixen/Makefile
@@ -21,11 +21,10 @@ ADDITIONAL_OBJCFLAGS+= -Dlog2=logb
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=int-conversion
-.endif
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 )
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
+.endif
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/System/Applications/Pixen.app/Pixen
diff --git a/graphics/plotutils/Makefile b/graphics/plotutils/Makefile
index b9883a7df9d1..9f40d000611d 100644
--- a/graphics/plotutils/Makefile
+++ b/graphics/plotutils/Makefile
@@ -14,6 +14,7 @@ LICENSE= GPLv3
LIB_DEPENDS= libpng.so:graphics/png
USES= gmake libtool localbase:ldflags xorg # parallel builds are broken with bmake(1)
+USE_CXXSTD= c++14
USE_LDCONFIG= yes
USE_XORG= ice sm x11 xaw xext xmu xt
@@ -24,10 +25,4 @@ TEST_TARGET= check
INFO= libxmi plotutils
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
-CPPFLAGS+= -Dregister=
-.endif
-
.include <bsd.port.mk>
diff --git a/graphics/povray37/Makefile b/graphics/povray37/Makefile
index ec3be553b1dc..dd0c62027ea5 100644
--- a/graphics/povray37/Makefile
+++ b/graphics/povray37/Makefile
@@ -15,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
USES= autoreconf:build compiler:c11 gmake
+USE_CXXSTD= c++14
USE_GITHUB= yes
GH_ACCOUNT= POV-Ray
@@ -97,10 +98,6 @@ post-patch:
${REINPLACE_CMD} -e 's|@@EXAMPLESDIR@@|${EXAMPLESDIR}|' \
-e 's|@@ETCDIR@@|${ETCDIR}|' \
${WRKSRC}/unix/povray.conf
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
- @${REINPLACE_CMD} -e 's|auto_ptr|unique_ptr|' \
- ${WRKSRC}/source/backend/render/trace.cpp
-.endif
pre-configure:
cd ${WRKSRC}/unix && ./prebuild.sh
diff --git a/graphics/py-pyvips/Makefile b/graphics/py-pyvips/Makefile
index c8567d469065..f4868665baf3 100644
--- a/graphics/py-pyvips/Makefile
+++ b/graphics/py-pyvips/Makefile
@@ -24,7 +24,7 @@ USE_PYTHON= autoplist concurrent distutils
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/graphics/quesoglc/Makefile b/graphics/quesoglc/Makefile
index d1f4af37b456..1b7230e876ac 100644
--- a/graphics/quesoglc/Makefile
+++ b/graphics/quesoglc/Makefile
@@ -42,7 +42,7 @@ TEST_TEST_TARGET= check
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/graphics/togl/Makefile b/graphics/togl/Makefile
index 3943f03e8d82..2913857f8d5c 100644
--- a/graphics/togl/Makefile
+++ b/graphics/togl/Makefile
@@ -29,7 +29,7 @@ TOGL_INSTDIR= ${PREFIX}/lib/${DISTNAME}
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif