summaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2020-02-24 11:36:15 +0000
committerKai Knoblich <kai@FreeBSD.org>2020-02-24 11:36:15 +0000
commit74174b26616baa21c285c0515b591e7d738c5c0f (patch)
tree1c10419849a595f8ebfa59836f2e676bb7ec3469 /graphics
parent45b08b671d6459dc7e71950a89cac654920ec089 (diff)
downloadfreebsd-ports-74174b26616baa21c285c0515b591e7d738c5c0f.zip
graphics/py-pillow: Update to 7.0.0
* Repo-Copy the Pillow 6.2.2 release to graphics/py-pillow6 to retain backwards compatibility for Python 2 consumers as the Pillow 7.0.0 release dropped the support for Python 2. * Apply conditional statements to use either Pillow 7.x or Pillow 6.x for consumers that can be built for Python 2 or newer. * Exceptions are ports that can be built only for either Python 2 or Python 3. For the first case, consumers are just assigned to the repo-copied graphics/py-pillow6. * Also remove Pillow from BUILD_DEPENDS of math/py-PyWavelets as it is not listed in setup.py as a build dependency [1] and relax the version requirements of Pillow for www/py-wagtail. Release Notes: * https://pillow.readthedocs.io/en/latest/releasenotes/index.html Backward Incompatible Changes (7.0.0): * https://pillow.readthedocs.io/en/latest/releasenotes/7.0.0.html#backwards-incompatible-changes Detailed Changelog: * https://github.com/python-pillow/Pillow/blob/7.0.0/CHANGES.rst PR: 243665 Submitted by: sunpoet (patch for 7.0.0 and repo-copied version) Reviewed by: koobs [1], sunpoet Approved by: koobs (maintainer) Differential Revision: https://reviews.freebsd.org/D23713
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/caffe/Makefile4
-rw-r--r--graphics/impressive/Makefile4
-rw-r--r--graphics/py-PyOpenGL/Makefile19
-rw-r--r--graphics/py-actdiag/Makefile3
-rw-r--r--graphics/py-blockdiag/Makefile3
-rw-r--r--graphics/py-cartopy/Makefile18
-rw-r--r--graphics/py-django-easy-thumbnails/Makefile19
-rw-r--r--graphics/py-face_recognition/Makefile12
-rw-r--r--graphics/py-imageio24/Makefile15
-rw-r--r--graphics/py-img2pdf/Makefile14
-rw-r--r--graphics/py-mcomix/Makefile4
-rw-r--r--graphics/py-nwdiag/Makefile3
-rw-r--r--graphics/py-photocollage/Makefile13
-rw-r--r--graphics/py-pillow/Makefile8
-rw-r--r--graphics/py-pillow/distinfo6
-rw-r--r--graphics/py-pillow6/Makefile83
-rw-r--r--graphics/py-pillow6/distinfo3
-rw-r--r--graphics/py-pillow6/pkg-descr5
-rw-r--r--graphics/py-pyinsane2/Makefile12
-rw-r--r--graphics/py-pypillowfight/Makefile12
-rw-r--r--graphics/py-sane/Makefile4
-rw-r--r--graphics/py-scikit-image/Makefile12
-rw-r--r--graphics/py-seqdiag/Makefile3
-rw-r--r--graphics/py-sorl-thumbnail/Makefile15
-rw-r--r--graphics/py-soya3d/Makefile2
-rw-r--r--graphics/sk1/Makefile3
27 files changed, 244 insertions, 56 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index b02cb7458d15..b716c881d415 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -830,6 +830,7 @@
SUBDIR += py-openimageio
SUBDIR += py-photocollage
SUBDIR += py-pillow
+ SUBDIR += py-pillow6
SUBDIR += py-pivy
SUBDIR += py-plotly
SUBDIR += py-png
diff --git a/graphics/caffe/Makefile b/graphics/caffe/Makefile
index 53cb0d5a5faf..47c7df58e512 100644
--- a/graphics/caffe/Makefile
+++ b/graphics/caffe/Makefile
@@ -2,7 +2,7 @@
PORTNAME= caffe
PORTVERSION= 1.0
-PORTREVISION= 31
+PORTREVISION= 32
CATEGORIES= graphics
MAINTAINER= eric@camachat.org
@@ -30,7 +30,7 @@ LIB_DEPENDS= libsnappy.so:archivers/snappy \
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}protobuf>=2.5.0:devel/py-protobuf@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scikit-image>=0.12:graphics/py-scikit-image@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pillow>=1.7:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow6>=1.7:graphics/py-pillow6@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}networkx>=1.8:math/py-networkx@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}matplotlib>=1.1:math/py-matplotlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}PyWavelets>=0.4:math/py-PyWavelets@${PY_FLAVOR}
diff --git a/graphics/impressive/Makefile b/graphics/impressive/Makefile
index 627608297b4a..4a590ac0a9d4 100644
--- a/graphics/impressive/Makefile
+++ b/graphics/impressive/Makefile
@@ -3,7 +3,7 @@
PORTNAME= impressive
PORTVERSION= 0.12.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics python
MASTER_SITES= SF/${PORTNAME}/Impressive/${PORTVERSION}/
DISTNAME= Impressive-${PORTVERSION}
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/license.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}PyOpenGL>=0:graphics/py-PyOpenGL@${PY_FLAVOR} \
${PYGAME} \
- ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
USES= python:2.7 sdl shebangfix
USE_SDL= sdl
diff --git a/graphics/py-PyOpenGL/Makefile b/graphics/py-PyOpenGL/Makefile
index ab88134abfe3..0967cfb29540 100644
--- a/graphics/py-PyOpenGL/Makefile
+++ b/graphics/py-PyOpenGL/Makefile
@@ -3,7 +3,7 @@
PORTNAME= PyOpenGL
PORTVERSION= 3.1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,9 +12,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= python@FreeBSD.org
COMMENT= OpenGL (and related library) interface for Python
-BUILD_DEPENDS= ${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY}
OPTIONS_DEFINE= TKINTER
OPTIONS_DEFAULT= TKINTER
@@ -27,10 +26,20 @@ USE_PYTHON= distutils autoplist
TKINTER_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
TKINTER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
+.else
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} ${REINPLACE_CMD} -e \
's|<malloc\.h>|<stdlib.h>|g'
@${FIND} ${WRKSRC} -name "*.bak" -delete
${REINPLACE_CMD} -e 's|posix |posix|g' ${WRKSRC}/OpenGL/__init__.py
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/py-actdiag/Makefile b/graphics/py-actdiag/Makefile
index a3e695fbd2a6..f459433b001a 100644
--- a/graphics/py-actdiag/Makefile
+++ b/graphics/py-actdiag/Makefile
@@ -3,6 +3,7 @@
PORTNAME= actdiag
PORTVERSION= 0.5.4
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
DEPRECATED= Uses deprecated version of python
EXPIRATION_DATE= 2020-08-15
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=2.2.1:graphics/py-pillow@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow6>=2.2.1:graphics/py-pillow6@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}blockdiag>=1.5.0:graphics/py-blockdiag@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}funcparserlib>=0.3.6:devel/py-funcparserlib@${PY_FLAVOR}
diff --git a/graphics/py-blockdiag/Makefile b/graphics/py-blockdiag/Makefile
index 6ffd1fd37533..cf5511bbd582 100644
--- a/graphics/py-blockdiag/Makefile
+++ b/graphics/py-blockdiag/Makefile
@@ -3,6 +3,7 @@
PORTNAME= blockdiag
PORTVERSION= 1.5.4
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +14,7 @@ COMMENT= Simple block-diagram image generator
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=2.2.1:graphics/py-pillow@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow6>=2.2.1:graphics/py-pillow6@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}funcparserlib>=0.3.6:devel/py-funcparserlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}webcolors>=0:graphics/py-webcolors@${PY_FLAVOR}
diff --git a/graphics/py-cartopy/Makefile b/graphics/py-cartopy/Makefile
index 856250bbe495..386b9de27c43 100644
--- a/graphics/py-cartopy/Makefile
+++ b/graphics/py-cartopy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cartopy
PORTVERSION= 0.17.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -36,11 +36,19 @@ OWS_DESC= OGC Web Service support
PLOTTING_DESC= Plotting support
EPSG_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyepsg>=0:graphics/py-pyepsg@${PY_FLAVOR}
-OWS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}OWSLib>=0.8.11:graphics/py-OWSLib@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pillow>=1.7.8:graphics/py-pillow@${PY_FLAVOR}
+OWS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}OWSLib>=0.8.11:graphics/py-OWSLib@${PY_FLAVOR}
PLOTTING_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gdal>=1.10.0:graphics/py-gdal@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}matplotlib>=1.5.1:math/py-matplotlib@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pillow>=1.7.8:graphics/py-pillow@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.10:science/py-scipy@${PY_FLAVOR}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+OWS_RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>=1.7.8:graphics/py-pillow6@${PY_FLAVOR}
+PLOTTING_RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>=1.7.8:graphics/py-pillow6@${PY_FLAVOR}
+.else
+OWS_RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>=1.7.8:graphics/py-pillow@${PY_FLAVOR}
+PLOTTING_RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>=1.7.8:graphics/py-pillow@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/py-django-easy-thumbnails/Makefile b/graphics/py-django-easy-thumbnails/Makefile
index 88d3e25d1e7b..d3d876eaa7eb 100644
--- a/graphics/py-django-easy-thumbnails/Makefile
+++ b/graphics/py-django-easy-thumbnails/Makefile
@@ -3,6 +3,7 @@
PORTNAME= easy-thumbnails
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}django-
@@ -13,8 +14,7 @@ COMMENT= Easy thumbnails for Django
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django111>=1.8:www/py-django111@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django111>=1.8:www/py-django111@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist concurrent distutils
@@ -24,10 +24,19 @@ PORTDOCS= *
OPTIONS_DEFINE= DOCS
DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django111>=1.8:www/py-django111@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR}
DOCS_VARS= PYDISTUTILS_BUILD_TARGET+="build_sphinx -a -E"
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>=0:graphics/py-pillow6@${PY_FLAVOR}
+DOCS_BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR}
+DOCS_BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+.endif
+
post-patch-DOCS-on:
@${REINPLACE_CMD} -e 's|^\(release = \)\(easy_thumbnails.get_version()\)|\1version|' ${WRKSRC}/docs/conf.py
@@ -35,4 +44,4 @@ post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/build/sphinx/html && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} "! -name .buildinfo -and ! -name objects.inv")
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/py-face_recognition/Makefile b/graphics/py-face_recognition/Makefile
index be4311117946..9719b859cc3d 100644
--- a/graphics/py-face_recognition/Makefile
+++ b/graphics/py-face_recognition/Makefile
@@ -3,6 +3,7 @@
PORTNAME= face_recognition
PORTVERSION= 1.3.0
+PORTREVISION= 1
CATEGORIES= graphics python devel
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,7 +16,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=6.0:devel/py-click@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}numpy>0:math/py-numpy@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}face_recognition_models>0:graphics/py-face_recognition_models@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dlib>=19.7:science/py-dlib@${PY_FLAVOR}
@@ -24,4 +24,12 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/py-imageio24/Makefile b/graphics/py-imageio24/Makefile
index c531b4aa2fbe..3f7fbe76b0bd 100644
--- a/graphics/py-imageio24/Makefile
+++ b/graphics/py-imageio24/Makefile
@@ -2,7 +2,7 @@
PORTNAME= imageio
DISTVERSION= 2.4.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,8 +18,7 @@ LIB_DEPENDS= libfreeimage.so:graphics/freeimage
RUN_DEPENDS= ffmpeg:multimedia/ffmpeg \
${PY_ENUM34} \
${PY_FUTURES} \
- ${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+ ${PYNUMPY}
USES= python
USE_PYTHON= distutils concurrent autoplist
@@ -28,4 +27,12 @@ NO_ARCH= yes
PORTSCOUT= limit:^2\.4\.
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/py-img2pdf/Makefile b/graphics/py-img2pdf/Makefile
index 4c78789c1f45..0264339bcb91 100644
--- a/graphics/py-img2pdf/Makefile
+++ b/graphics/py-img2pdf/Makefile
@@ -2,6 +2,7 @@
PORTNAME= img2pdf
DISTVERSION= 0.3.3
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,8 +13,7 @@ COMMENT= Convert images to PDF via direct JPEG inclusion
LICENSE= LGPL3+
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
- ${PY_ENUM34}
+RUN_DEPENDS= ${PY_ENUM34}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pdfrw>0:textproc/py-pdfrw@${PY_FLAVOR}
USES= python
@@ -21,9 +21,17 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+.endif
+
# Note: The tests only work with Python 3, see also:
# https://gitlab.mister-muffin.de/josch/img2pdf/issues/60
do-test:
@(cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/py-mcomix/Makefile b/graphics/py-mcomix/Makefile
index 7d9cb46f5689..51bdda0dc97c 100644
--- a/graphics/py-mcomix/Makefile
+++ b/graphics/py-mcomix/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mcomix
PORTVERSION= 1.2.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/MComix-${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
DEPRECATED= Old, uses EOLed python27
EXPIRATION_DATE= 2020-03-01
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=5.2.0:graphics/py-pillow@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow6>=5.2.0:graphics/py-pillow6@${PY_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= gnome python:2.7 tar:bzip2
diff --git a/graphics/py-nwdiag/Makefile b/graphics/py-nwdiag/Makefile
index de54f286aa3a..10cae5f05a31 100644
--- a/graphics/py-nwdiag/Makefile
+++ b/graphics/py-nwdiag/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nwdiag
PORTVERSION= 1.0.4
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
DEPRECATED= Uses deprecated version of python
EXPIRATION_DATE= 2020-08-15
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=2.2.1:graphics/py-pillow@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow6>=2.2.1:graphics/py-pillow6@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}funcparserlib>=0.3.6:devel/py-funcparserlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}blockdiag>=1.5.0:graphics/py-blockdiag@${PY_FLAVOR}
diff --git a/graphics/py-photocollage/Makefile b/graphics/py-photocollage/Makefile
index 6eeb4b72f81e..e3808975d2a8 100644
--- a/graphics/py-photocollage/Makefile
+++ b/graphics/py-photocollage/Makefile
@@ -2,7 +2,7 @@
PORTNAME= photocollage
DISTVERSION= 1.4.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,13 +14,20 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>0:graphics/py-cairo@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>:devel/py-six@${PY_FLAVOR}
USES= gettext-tools python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e ' \
s|${PORTNAME}|${PORTNAME}-${PYTHON_VER}| ; \
@@ -32,4 +39,4 @@ post-patch:
${MV} $$f $$(${ECHO} $$f | ${SED} -E 's|photocollage\.([[:alpha:].]*)|photocollage-${PYTHON_VER}.\1|'); \
done
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/py-pillow/Makefile b/graphics/py-pillow/Makefile
index 5a2700cd5b24..6051e421d28b 100644
--- a/graphics/py-pillow/Makefile
+++ b/graphics/py-pillow/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pillow
-PORTVERSION= 6.2.2
+PORTVERSION= 7.0.0
CATEGORIES= graphics python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,14 +17,16 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${PY_FLAVOR}
-# Python 2.7,3.5+
-USES= cpe python
+# Python 3.5+
+USES= cpe python:3.5+
USE_GITHUB= yes
USE_PYTHON= autoplist concurrent distutils
GH_ACCOUNT= python-${PORTNAME}
GH_PROJECT= ${PORTNAME:C/p/P/}
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}pillow6
+
OPTIONS_DEFINE= FREETYPE JPEG JPEG2000 LCMS OLE PNG TIFF TKINTER WEBP
OPTIONS_DEFAULT= FREETYPE JPEG JPEG2000 LCMS OLE PNG TIFF TKINTER WEBP
diff --git a/graphics/py-pillow/distinfo b/graphics/py-pillow/distinfo
index 22f4c9a333ee..9e0c77dce471 100644
--- a/graphics/py-pillow/distinfo
+++ b/graphics/py-pillow/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1579047758
-SHA256 (python-pillow-Pillow-6.2.2_GH0.tar.gz) = cc4ec754ddcc98b7166a1afe062c6355c841776145f0f23bdd3bea1eaa41e2db
-SIZE (python-pillow-Pillow-6.2.2_GH0.tar.gz) = 37538464
+TIMESTAMP = 1579047762
+SHA256 (python-pillow-Pillow-7.0.0_GH0.tar.gz) = 925f52e26491063943c14edadc6d276e3a8427b11d6943113fd2ef24dcbeabca
+SIZE (python-pillow-Pillow-7.0.0_GH0.tar.gz) = 37880130
diff --git a/graphics/py-pillow6/Makefile b/graphics/py-pillow6/Makefile
new file mode 100644
index 000000000000..3569559c60e0
--- /dev/null
+++ b/graphics/py-pillow6/Makefile
@@ -0,0 +1,83 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pillow
+PORTVERSION= 6.2.2
+CATEGORIES= graphics python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 6
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Fork of the Python Imaging Library (PIL)
+
+LICENSE= PIL
+LICENSE_NAME= Standard PIL License
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${PY_FLAVOR}
+
+# Python 2.7,3.5+
+USES= cpe python
+USE_GITHUB= yes
+USE_PYTHON= autoplist concurrent distutils
+
+GH_ACCOUNT= python-${PORTNAME}
+GH_PROJECT= ${PORTNAME:C/p/P/}
+
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}pillow
+
+OPTIONS_DEFINE= FREETYPE JPEG JPEG2000 LCMS OLE PNG TIFF TKINTER WEBP
+OPTIONS_DEFAULT= FREETYPE JPEG JPEG2000 LCMS OLE PNG TIFF TKINTER WEBP
+
+LCMS_DESC= Little Color Management System
+OLE_DESC= Microsoft OLE2 file format support
+TKINTER_DESC= Tkinter (Tcl/Tk) BitmapImage & PhotoImage support
+
+FREETYPE_LIB_DEPENDS= libfreetype.so:print/freetype2
+FREETYPE_VARS= PYDISTUTILS_BUILDARGS+=--enable-freetype
+FREETYPE_VARS_OFF= PYDISTUTILS_BUILDARGS+=--disable-freetype
+
+JPEG_USES= jpeg
+JPEG_VARS= PYDISTUTILS_BUILDARGS+=--enable-jpeg
+JPEG_VARS_OFF= PYDISTUTILS_BUILDARGS+=--disable-jpeg
+
+JPEG2000_LIB_DEPENDS= libopenjp2.so:graphics/openjpeg
+JPEG2000_VARS= PYDISTUTILS_BUILDARGS+=--enable-jpeg2000
+JPEG2000_VARS_OFF= PYDISTUTILS_BUILDARGS+=--disable-jpeg2000
+
+LCMS_LIB_DEPENDS= liblcms2.so:graphics/lcms2
+LCMS_VARS= PYDISTUTILS_BUILDARGS+=--enable-lcms
+LCMS_VARS_OFF= PYDISTUTILS_BUILDARGS+=--disable-lcms
+
+OLE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}olefile>0:devel/py-olefile@${PY_FLAVOR}
+
+PNG_VARS= PYDISTUTILS_BUILDARGS+=--enable-zlib
+PNG_VARS_OFF= PYDISTUTILS_BUILDARGS+=--disable-zlib
+
+TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
+TIFF_VARS= PYDISTUTILS_BUILDARGS+=--enable-tiff
+TIFF_VARS_OFF= PYDISTUTILS_BUILDARGS+=--disable-tiff
+
+TKINTER_USES= tk
+TKINTER_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
+TKINTER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
+TKINTER_VARS= PYDISTUTILS_BUILDARGS+="--include-dirs=${TCL_INCLUDEDIR}:${TK_INCLUDEDIR}"
+
+WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
+WEBP_VARS= PYDISTUTILS_BUILDARGS+="--enable-webp --enable-webpmux"
+WEBP_VARS_OFF= PYDISTUTILS_BUILDARGS+="--disable-webp --disable-webpmux"
+
+.include <bsd.port.pre.mk>
+
+PYDISTUTILS_BUILD_TARGET= build build_ext
+PYDISTUTILS_BUILDARGS+= saveopts
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PIL/*.so
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.post.mk>
diff --git a/graphics/py-pillow6/distinfo b/graphics/py-pillow6/distinfo
new file mode 100644
index 000000000000..22f4c9a333ee
--- /dev/null
+++ b/graphics/py-pillow6/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1579047758
+SHA256 (python-pillow-Pillow-6.2.2_GH0.tar.gz) = cc4ec754ddcc98b7166a1afe062c6355c841776145f0f23bdd3bea1eaa41e2db
+SIZE (python-pillow-Pillow-6.2.2_GH0.tar.gz) = 37538464
diff --git a/graphics/py-pillow6/pkg-descr b/graphics/py-pillow6/pkg-descr
new file mode 100644
index 000000000000..0249c5723e14
--- /dev/null
+++ b/graphics/py-pillow6/pkg-descr
@@ -0,0 +1,5 @@
+Pillow is the "friendly" PIL fork. PIL is the Python Imaging Library. Pillow
+was started for and is currently maintained by the Plone community. But it is
+used by many other folks in the Python web community.
+
+WWW: https://python-pillow.org/
diff --git a/graphics/py-pyinsane2/Makefile b/graphics/py-pyinsane2/Makefile
index f7b56a9ca7c5..dd05be7b8927 100644
--- a/graphics/py-pyinsane2/Makefile
+++ b/graphics/py-pyinsane2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pyinsane2
DISTVERSION= 2.0.13
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,10 +14,17 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=1.0:devel/py-nose@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
USES= gmake python
USE_PYTHON= distutils autoplist
NO_ARCH= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/py-pypillowfight/Makefile b/graphics/py-pypillowfight/Makefile
index a384b842f691..e33fdedb14cd 100644
--- a/graphics/py-pypillowfight/Makefile
+++ b/graphics/py-pypillowfight/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pypillowfight
DISTVERSION= 0.3.0
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,9 +14,16 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=1.0:devel/py-nose@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
USES= python
USE_PYTHON= distutils autoplist
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/py-sane/Makefile b/graphics/py-sane/Makefile
index 6f36ad249d9b..576cc9b3c159 100644
--- a/graphics/py-sane/Makefile
+++ b/graphics/py-sane/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sane
PORTVERSION= 2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics python
MASTER_SITES= http://effbot.org/media/downloads/ \
http://www.pythonware.net/storage/
@@ -17,7 +17,7 @@ DEPRECATED= Uses deprecated version of python
EXPIRATION_DATE= 2020-08-15
LIB_DEPENDS= libsane.so:graphics/sane-backends
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
DIST_SUBDIR= python
USES= python:2.7
diff --git a/graphics/py-scikit-image/Makefile b/graphics/py-scikit-image/Makefile
index 7713a109a493..d8120655f2b1 100644
--- a/graphics/py-scikit-image/Makefile
+++ b/graphics/py-scikit-image/Makefile
@@ -2,6 +2,7 @@
PORTNAME= scikit-image
PORTVERSION= 0.14.3
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= graphics python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,7 +21,6 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}six>=1.4:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.9:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}numpydoc>=0.6:textproc/py-numpydoc@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pillow>=1.7:graphics/py-pillow@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}networkx>=1.8:math/py-networkx@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}matplotlib>=1.1:math/py-matplotlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}PyWavelets>=0.4:math/py-PyWavelets@${PY_FLAVOR} \
@@ -33,6 +33,14 @@ USE_PYTHON= autoplist concurrent distutils cython cython_run
PYDISTUTILS_BUILD_TARGET= build build_ext
PYDISTUTILS_BUILDARGS+= saveopts
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>=1.7:graphics/py-pillow6@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>=1.7:graphics/py-pillow@${PY_FLAVOR}
+.endif
+
post-install:
@${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR}/skimage -name "*.so" -exec ${STRIP_CMD} {} \;
@@ -42,4 +50,4 @@ do-test:
${PYTHON_CMD} selftest.py && \
${PYTHON_CMD} -m nose -vx Tests/test_*.py
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/py-seqdiag/Makefile b/graphics/py-seqdiag/Makefile
index 1942a93dda4d..c66f8f65a364 100644
--- a/graphics/py-seqdiag/Makefile
+++ b/graphics/py-seqdiag/Makefile
@@ -3,6 +3,7 @@
PORTNAME= seqdiag
PORTVERSION= 0.9.6
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
DEPRECATED= Uses deprecated version of python
EXPIRATION_DATE= 2020-08-15
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=2.2.1:graphics/py-pillow@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow6>=2.2.1:graphics/py-pillow6@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}funcparserlib>=0.3.6:devel/py-funcparserlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}blockdiag>=1.5.0:graphics/py-blockdiag@${PY_FLAVOR}
diff --git a/graphics/py-sorl-thumbnail/Makefile b/graphics/py-sorl-thumbnail/Makefile
index 5fbb46d00de1..bf7e6e4e3d88 100644
--- a/graphics/py-sorl-thumbnail/Makefile
+++ b/graphics/py-sorl-thumbnail/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sorl-thumbnail
PORTVERSION= 12.4.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -34,7 +34,6 @@ DOCS_VARS= PYDISTUTILS_BUILD_TARGET+="build_sphinx -a -E"
GRAPHICSMAGICK_RUN_DEPENDS= ${LOCALBASE}/bin/gm:graphics/GraphicsMagick
IMAGEMAGICK_RUN_DEPENDS= ${LOCALBASE}/bin/convert:graphics/ImageMagick6
-PILLOW_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
REDIS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}redis>0:databases/py-redis@${PY_FLAVOR}
WAND_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Wand>0:graphics/py-wand@${PY_FLAVOR}
@@ -44,10 +43,20 @@ PILLOW_DESC= Use internal image processing
REDIS_DESC= Use REDIS as Key Value Store
WAND_DESC= Use Wand with ImageMagick
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MPILLOW}
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+.endif
+.endif
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/build/sphinx/html && \
${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} \
"! -name .buildinfo -and ! -name objects.inv")
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/py-soya3d/Makefile b/graphics/py-soya3d/Makefile
index 2121dfa8c55a..8fb080c42d00 100644
--- a/graphics/py-soya3d/Makefile
+++ b/graphics/py-soya3d/Makefile
@@ -17,7 +17,7 @@ COMMENT= Very high level 3D engine for Python
DEPRECATED= Unmaintained, uses EOLed python27
EXPIRATION_DATE= 2020-03-19
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
LIB_DEPENDS= libode.so:devel/ode \
libcal3d.so:graphics/cal3d \
libfreetype.so:print/freetype2
diff --git a/graphics/sk1/Makefile b/graphics/sk1/Makefile
index 8b9e931b3285..5c835254da61 100644
--- a/graphics/sk1/Makefile
+++ b/graphics/sk1/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sk1
DISTVERSION= 2.0
DISTVERSIONSUFFIX= rc3
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= https://downloads.sk1project.net/sk1/${DISTVERSIONFULL}/
@@ -19,7 +20,7 @@ LIB_DEPENDS= liblcms2.so:graphics/lcms2 \
libMagickCore-6.so:graphics/ImageMagick6
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>0:graphics/py-cairo@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>0:graphics/py-cairo@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pycups>0:print/py-pycups@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}reportlab>0:print/py-reportlab@${PY_FLAVOR}