summaryrefslogtreecommitdiff
path: root/graphics/djvulibre
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2009-01-10 02:45:46 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2009-01-10 02:45:46 +0000
commit15b6544926b07a98710eeb765baf03e3fc9a195c (patch)
tree35103cf986d2ed2295c97768e62afcc47dfed877 /graphics/djvulibre
parent23fcf54562404bb41380488c8318ac0e3ce15efc (diff)
downloadfreebsd-ports-15b6544926b07a98710eeb765baf03e3fc9a195c.zip
Add a new framework for browser plugins, USE_WEBPLUGINS. It is for which foo
plugins support one of web browsers and can take care of plist (depend on how you use it) at the same time. I have written a complete document and even show how it works in the www/firefox/Makefile.webplugins so be sure to read in there. If there is anything that isn't clear in the document, please feel free to ask and I will try my best to improvement it. FYI: GNOME 2.24 depends on this, so it's coming. BTW: It's based on www/linux-mplayer-plugin/Makefile.npapi with heavy modified. Approved by: portmgr
Diffstat (limited to 'graphics/djvulibre')
-rw-r--r--graphics/djvulibre/Makefile14
-rw-r--r--graphics/djvulibre/pkg-plist4
2 files changed, 6 insertions, 12 deletions
diff --git a/graphics/djvulibre/Makefile b/graphics/djvulibre/Makefile
index 9443d97b9c9b..def7456bba41 100644
--- a/graphics/djvulibre/Makefile
+++ b/graphics/djvulibre/Makefile
@@ -7,7 +7,7 @@
PORTNAME= djvulibre
PORTVERSION= 3.5.21
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= graphics www
MASTER_SITES= SF/djvu
@@ -41,7 +41,12 @@ MAN1= djview3.1 nsdejavu.1
MLINKS= djview3.1 djview.1
DESKTOPDIR= ${PREFIX}/share/djvu/djview3/desktop
+USE_WEBPLUGINS= gecko*
+WEBPLUGINS_DIR= ${PREFIX}/lib/djvulibre/plugins
+WEBPLUGINS_FILES= nsdejavu.so
+
.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
post-patch:
@${REINPLACE_CMD} -E \
@@ -82,11 +87,4 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/desktopfiles/register-djview-menu \
${DESKTOPDIR}
-#
-# Install browser plugin.
-#
- @${MKDIR} ${LOCALBASE}/lib/browser_plugins
- ${LN} -sf ${PREFIX}/lib/djvulibre/plugins/nsdejavu.so \
- ${LOCALBASE}/lib/browser_plugins/nsdejavu.so
-
.include <bsd.port.post.mk>
diff --git a/graphics/djvulibre/pkg-plist b/graphics/djvulibre/pkg-plist
index 4dcef853b7fd..d2f54f5e40be 100644
--- a/graphics/djvulibre/pkg-plist
+++ b/graphics/djvulibre/pkg-plist
@@ -12,9 +12,6 @@ share/djvu/djview3/fr/djview.qm
share/djvu/djview3/fr/qt.qm
share/djvu/djview3/ja/djview.qm
share/djvu/djview3/ja/qt.qm
-@exec mkdir -p %%LOCALBASE%%/lib/browser_plugins
-@exec ln -sf %D/lib/djvulibre/plugins/nsdejavu.so %%LOCALBASE%%/lib/browser_plugins/nsdejavu.so
-@unexec rm -f %%LOCALBASE%%/lib/browser_plugins/nsdejavu.so
@dirrm share/djvu/djview3/ja
@dirrm share/djvu/djview3/fr
@dirrm share/djvu/djview3/desktop
@@ -24,4 +21,3 @@ share/djvu/djview3/ja/qt.qm
@dirrmtry share/djvu
@dirrm lib/djvulibre/plugins
@dirrm lib/djvulibre
-@unexec rmdir %%LOCALBASE%%/lib/browser_plugins 2>/dev/null || true