summaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-10-27 19:23:50 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-10-27 19:23:50 +0000
commit0ab23fc51434a6b372ca366ecbef1929eaf4e9dd (patch)
treeda175c839d5d9a3c3c9c056df9e2315756c5212f /games
parenta5a5f16ac10fe97d23b22cdfedbb4ddc22c4d0a5 (diff)
downloadfreebsd-ports-0ab23fc51434a6b372ca366ecbef1929eaf4e9dd.zip
games/supertuxkart: fix build on arm platforms
Build fails with -mimplicit-it=always passed to as, but builds without it. PR: 241218 Approved by: linimon (mentor), amdmi3 (maintainer timeout)
Diffstat (limited to 'games')
-rw-r--r--games/supertuxkart/Makefile3
-rw-r--r--games/supertuxkart/files/patch-lib_angelscript_projects_cmake_CMakeLists.txt10
2 files changed, 10 insertions, 3 deletions
diff --git a/games/supertuxkart/Makefile b/games/supertuxkart/Makefile
index 7adc7bf18582..d822f64bf4d6 100644
--- a/games/supertuxkart/Makefile
+++ b/games/supertuxkart/Makefile
@@ -21,9 +21,6 @@ LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
libfreetype.so:print/freetype2 \
libenet.so:net/enet
-BROKEN_aarch64= invokes x86 assembler
-BROKEN_armv6= invokes x86 assembler
-BROKEN_armv7= invokes x86 assembler
BROKEN_mips= invokes x86 assembler
BROKEN_mips64= invokes x86 assembler
BROKEN_sparc64= invokes x86 assembler
diff --git a/games/supertuxkart/files/patch-lib_angelscript_projects_cmake_CMakeLists.txt b/games/supertuxkart/files/patch-lib_angelscript_projects_cmake_CMakeLists.txt
new file mode 100644
index 000000000000..7eb5858519cc
--- /dev/null
+++ b/games/supertuxkart/files/patch-lib_angelscript_projects_cmake_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- lib/angelscript/projects/cmake/CMakeLists.txt.orig 2019-10-12 16:56:04 UTC
++++ lib/angelscript/projects/cmake/CMakeLists.txt
+@@ -111,7 +111,6 @@ if(${CMAKE_SYSTEM_PROCESSOR} MATCHES "^arm")
+ enable_language(ASM)
+ if(CMAKE_ASM_COMPILER_WORKS)
+ set(ANGELSCRIPT_SOURCE ${ANGELSCRIPT_SOURCE} ../../source/as_callfunc_arm.cpp ../../source/as_callfunc_arm_gcc.S)
+- set_property(SOURCE ../../source/as_callfunc_arm_gcc.S APPEND PROPERTY COMPILE_FLAGS " -Wa,-mimplicit-it=always")
+ else()
+ message(FATAL ERROR "ARM target requires a working assembler")
+ endif()