summaryrefslogtreecommitdiff
path: root/games/quake3-excessive
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-07-08 09:37:51 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-07-08 09:37:51 +0000
commitc5beb65fa5ab0b51d32b1b4ea6a1ade0f30fd5cc (patch)
treeabcd91fa1763645ee9e25b6120cd004f53f4b38f /games/quake3-excessive
parent7a11b7a9487d55127d21d7a7da903b82194db5e9 (diff)
downloadfreebsd-ports-c5beb65fa5ab0b51d32b1b4ea6a1ade0f30fd5cc.zip
- Use modern MASTER_SITES syntax, get rid of MASTER_SITE_SUBDIR
- Stagify, cleanup extraction, transfer maintainership to games@ - Add missing OPTIONS_DEFINE and unmute installation commands - Convert rather short pkg-plist to PORTDATA and PORTDOCS - Remove now defunct WWW (there is another mod, Excessive Plus, available which is based on this one: www.excessiveplus.net)
Diffstat (limited to 'games/quake3-excessive')
-rw-r--r--games/quake3-excessive/Makefile28
-rw-r--r--games/quake3-excessive/pkg-descr2
-rw-r--r--games/quake3-excessive/pkg-plist8
3 files changed, 13 insertions, 25 deletions
diff --git a/games/quake3-excessive/Makefile b/games/quake3-excessive/Makefile
index b5c0447a8e08..e53eb2aeb24a 100644
--- a/games/quake3-excessive/Makefile
+++ b/games/quake3-excessive/Makefile
@@ -1,15 +1,14 @@
-# Created by: pat@databits.net
+# Created by: Patrick Li <pat@databits.net>
# $FreeBSD$
PORTNAME= excessive
PORTVERSION= 003
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= pat
+MASTER_SITES= LOCAL/pat
PKGNAMEPREFIX= ${Q3PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}_q3_server_${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= games@FreeBSD.org
COMMENT= Quake III Arena Mod: Excessive
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -18,23 +17,22 @@ USES= zip:infozip
NO_BUILD= yes
DATADIR= ${Q3DIR}/${PORTNAME}
+PORTDATA= description.txt motd.cfg maplist.cfg vm
+PORTDOCS= readme.txt
+
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
post-extract:
- @(cd ${WRKSRC}; ${UNZIP_CMD} description.pk3)
+ @${UNZIP_CMD} ${WRKSRC}/description.pk3 -d ${WRKSRC}
do-install:
- @${MKDIR} ${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}/vm
.for f in description.txt motd.cfg maplist.cfg
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DATADIR}
.endfor
- @${MKDIR} ${DATADIR}/vm
- @${INSTALL_DATA} ${WRKSRC}/vm/qagame.qvm ${DATADIR}/vm
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/vm/qagame.qvm ${STAGEDIR}${DATADIR}/vm
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${STAGEDIR}${DOCSDIR}
.include "${.CURDIR}/../quake3-data/Makefile.include"
-
.include <bsd.port.mk>
diff --git a/games/quake3-excessive/pkg-descr b/games/quake3-excessive/pkg-descr
index 38b90791043a..3f2df36f6c85 100644
--- a/games/quake3-excessive/pkg-descr
+++ b/games/quake3-excessive/pkg-descr
@@ -1,5 +1,3 @@
Excessive is a mod for Quake III Arena. It's a server-side only mod, so if you
only want to play on Excessive servers, you do not need to install this. If
you plan on running an Excessive server, then this is for you.
-
-WWW: http://www.planetquake.com/excessive/
diff --git a/games/quake3-excessive/pkg-plist b/games/quake3-excessive/pkg-plist
deleted file mode 100644
index 49ecc0a1e9a5..000000000000
--- a/games/quake3-excessive/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-%%DATADIR%%/description.txt
-%%DATADIR%%/maplist.cfg
-%%DATADIR%%/motd.cfg
-%%PORTDOCS%%%%DOCSDIR%%/readme.txt
-%%DATADIR%%/vm/qagame.qvm
-@dirrm %%DATADIR%%/vm
-@dirrm %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%