summaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-10 21:32:16 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-10 21:32:16 +0000
commit7396f9fee27d3f007cc76f6e4a712b8af62bfd57 (patch)
tree48e188547da0978014a5da19a1f0478a4514afb0 /ftp
parent99f396d0c1fb337caab7f0dd69be513999e9f44b (diff)
downloadfreebsd-ports-7396f9fee27d3f007cc76f6e4a712b8af62bfd57.zip
Remove broken extra patch files/extra-patch-module-mod_ldap.c the patch itself
is actually repeated 3 times so it tries to reverse itself and fails. This patch is only applied if the LDAP know is checked so it doesn't appear on all builds. The patch itself defines TLS support in the LDAP module. There are two problems with doing this. One, it breaks LDAP if the server doesn't support TLS. And two it causes the build to fail on 4.x. The patch to do this was a requested option, and isn't critical for most people. The maintainer is going to add another option knob for LDAP_TLS support once the 4.x build problems are resolved. PR: 96713 Submitted by: Beech Rintoul <beech@mangohealth.org> (maintainer)
Diffstat (limited to 'ftp')
-rw-r--r--ftp/proftpd-devel/Makefile10
-rw-r--r--ftp/proftpd-devel/files/extra-patch-module-mod_ldap.c31
-rw-r--r--ftp/proftpd/Makefile10
-rw-r--r--ftp/proftpd/files/extra-patch-module-mod_ldap.c31
4 files changed, 6 insertions, 76 deletions
diff --git a/ftp/proftpd-devel/Makefile b/ftp/proftpd-devel/Makefile
index b84903971b44..0e6fa9b77d96 100644
--- a/ftp/proftpd-devel/Makefile
+++ b/ftp/proftpd-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= proftpd
DISTVERSION= 1.3.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
@@ -52,10 +52,10 @@ OPTIONS= IPV6 "Use IPv6" off \
WRAP "Include mod_wrap" on \
RADIUS "Include mod_radius" off
-MODULES?=
-
.include <bsd.port.pre.mk>
+MODULES?=
+
.if defined(WITH_RATIO)
MODULES:=${MODULES}:mod_ratio
.endif
@@ -125,10 +125,6 @@ USE_OPENSSL= yes
.include <${PORTSDIR}/Mk/bsd.openssl.mk>
PROFTPD_LIBS+= -lssl -lcrypto -L${LOCALBASE}/lib
MODULES:=${MODULES}:mod_tls
-
-.if defined(WITH_LDAP)
-EXTRA_PATCHES=${FILESDIR}/extra-patch-module-mod_ldap.c
-.endif
.endif
.if defined(WITH_CTRLS)
diff --git a/ftp/proftpd-devel/files/extra-patch-module-mod_ldap.c b/ftp/proftpd-devel/files/extra-patch-module-mod_ldap.c
deleted file mode 100644
index 632264c44c44..000000000000
--- a/ftp/proftpd-devel/files/extra-patch-module-mod_ldap.c
+++ /dev/null
@@ -1,31 +0,0 @@
---- contrib/mod_ldap.c Fri Apr 21 10:31:23 2006
-+++ contrib/mod_ldap.c Fri Apr 21 10:31:43 2006
-@@ -55,7 +55,7 @@
- * after connecting to the LDAP server. If TLS cannot be enabled, the LDAP
- * connection will fail.
- */
--/* #define USE_LDAP_TLS */
-+#define USE_LDAP_TLS
-
- /* Uncomment this if you have OpenSSL and wish to verify non-crypt()
- * password hashes locally with OpenSSL. You'll also need to edit--- contrib/mod_ldap.c Fri Apr 21 10:31:23 2006
-+++ contrib/mod_ldap.c Fri Apr 21 10:31:43 2006
-@@ -55,7 +55,7 @@
- * after connecting to the LDAP server. If TLS cannot be enabled, the LDAP
- * connection will fail.
- */
--/* #define USE_LDAP_TLS */
-+#define USE_LDAP_TLS
-
- /* Uncomment this if you have OpenSSL and wish to verify non-crypt()
- * password hashes locally with OpenSSL. You'll also need to edit--- contrib/mod_ldap.c Fri Apr 21 10:31:23 2006
-+++ contrib/mod_ldap.c Fri Apr 21 10:31:43 2006
-@@ -55,7 +55,7 @@
- * after connecting to the LDAP server. If TLS cannot be enabled, the LDAP
- * connection will fail.
- */
--/* #define USE_LDAP_TLS */
-+#define USE_LDAP_TLS
-
- /* Uncomment this if you have OpenSSL and wish to verify non-crypt()
- * password hashes locally with OpenSSL. You'll also need to edit
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index b84903971b44..0e6fa9b77d96 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= proftpd
DISTVERSION= 1.3.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
@@ -52,10 +52,10 @@ OPTIONS= IPV6 "Use IPv6" off \
WRAP "Include mod_wrap" on \
RADIUS "Include mod_radius" off
-MODULES?=
-
.include <bsd.port.pre.mk>
+MODULES?=
+
.if defined(WITH_RATIO)
MODULES:=${MODULES}:mod_ratio
.endif
@@ -125,10 +125,6 @@ USE_OPENSSL= yes
.include <${PORTSDIR}/Mk/bsd.openssl.mk>
PROFTPD_LIBS+= -lssl -lcrypto -L${LOCALBASE}/lib
MODULES:=${MODULES}:mod_tls
-
-.if defined(WITH_LDAP)
-EXTRA_PATCHES=${FILESDIR}/extra-patch-module-mod_ldap.c
-.endif
.endif
.if defined(WITH_CTRLS)
diff --git a/ftp/proftpd/files/extra-patch-module-mod_ldap.c b/ftp/proftpd/files/extra-patch-module-mod_ldap.c
deleted file mode 100644
index 632264c44c44..000000000000
--- a/ftp/proftpd/files/extra-patch-module-mod_ldap.c
+++ /dev/null
@@ -1,31 +0,0 @@
---- contrib/mod_ldap.c Fri Apr 21 10:31:23 2006
-+++ contrib/mod_ldap.c Fri Apr 21 10:31:43 2006
-@@ -55,7 +55,7 @@
- * after connecting to the LDAP server. If TLS cannot be enabled, the LDAP
- * connection will fail.
- */
--/* #define USE_LDAP_TLS */
-+#define USE_LDAP_TLS
-
- /* Uncomment this if you have OpenSSL and wish to verify non-crypt()
- * password hashes locally with OpenSSL. You'll also need to edit--- contrib/mod_ldap.c Fri Apr 21 10:31:23 2006
-+++ contrib/mod_ldap.c Fri Apr 21 10:31:43 2006
-@@ -55,7 +55,7 @@
- * after connecting to the LDAP server. If TLS cannot be enabled, the LDAP
- * connection will fail.
- */
--/* #define USE_LDAP_TLS */
-+#define USE_LDAP_TLS
-
- /* Uncomment this if you have OpenSSL and wish to verify non-crypt()
- * password hashes locally with OpenSSL. You'll also need to edit--- contrib/mod_ldap.c Fri Apr 21 10:31:23 2006
-+++ contrib/mod_ldap.c Fri Apr 21 10:31:43 2006
-@@ -55,7 +55,7 @@
- * after connecting to the LDAP server. If TLS cannot be enabled, the LDAP
- * connection will fail.
- */
--/* #define USE_LDAP_TLS */
-+#define USE_LDAP_TLS
-
- /* Uncomment this if you have OpenSSL and wish to verify non-crypt()
- * password hashes locally with OpenSSL. You'll also need to edit