summaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-10-12 05:06:50 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-10-12 05:06:50 +0000
commita0888aa7fc65555649c9cb1aa2f00d6df5cc4e01 (patch)
tree497c5d406c44f77fbd1a3a8ec0272bbfcfd6207c /emulators
parent79ba25f958b015bdeabe08ddb7fac0c13162d774 (diff)
downloadfreebsd-ports-a0888aa7fc65555649c9cb1aa2f00d6df5cc4e01.zip
Blight's SDL input plugin for Mupen64
- Mupen64 is a highly portable Nintendo 64 emulator. It has been developed on/for Linux originally but has already been ported successfully to other operating systems. The program can easily be ported to all operating systems supported by the SDL library. In its current state, the emulator is highly compatible and uses a plugin system. With the correct plugins ("correct" can be computer dependent), it can achieve nearly perfect graphics and sound in many games. WWW: http://mupen64.emulation64.com/ PR: 71895 Submitted by: Travis Poppe
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/mupen64-sdlinput/Makefile46
-rw-r--r--emulators/mupen64-sdlinput/distinfo2
-rw-r--r--emulators/mupen64-sdlinput/files/patch-SDL_ttf.c12
-rw-r--r--emulators/mupen64-sdlinput/pkg-descr15
-rw-r--r--emulators/mupen64-sdlinput/pkg-message9
6 files changed, 85 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index b810bd31bd8a..7144beaa62f2 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -68,6 +68,7 @@
SUBDIR += mupen64-rice
SUBDIR += mupen64-rsp
SUBDIR += mupen64-sdlaudio
+ SUBDIR += mupen64-sdlinput
SUBDIR += osf1_base
SUBDIR += p-interp
SUBDIR += pcemu
diff --git a/emulators/mupen64-sdlinput/Makefile b/emulators/mupen64-sdlinput/Makefile
new file mode 100644
index 000000000000..a692d33ac904
--- /dev/null
+++ b/emulators/mupen64-sdlinput/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: mupen64-sdlinput
+# Date created: 12.Aug 2004
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= mupen64
+PORTVERSION= 0.0.8
+CATEGORIES+= emulators
+MASTER_SITES= http://mupen64.emulation64.com/files/0.4/
+PKGNAMESUFFIX= -sdlinput
+DISTNAME= blight_input-${PORTVERSION}-b
+
+MAINTAINER?= tlp@LiquidX.org
+COMMENT= Blight's SDL input plugin for Mupen64
+
+LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+USE_GCC= 3.4
+USE_AUTOHEADER_VER= 259
+ONLY_FOR_ARCHS= i386
+
+PLUGIN_NAME= blight_input
+PLIST_FILES= share/mupen64/plugins/${PLUGIN_NAME}.so
+PLIST_DIRS= share/mupen64/plugins
+PLIST_DIRS+= share/mupen64
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/mupen64/plugins
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/.libs/${PLUGIN_NAME}.so \
+ ${PREFIX}/share/mupen64/plugins/
+
+.include <bsd.port.pre.mk>
+
+CFLAGS+= -fPIC
+CFLAGS+= -O3 -fomit-frame-pointer -funroll-loops -ffast-math -Wall -pipe
+CFLAGS+= -DX86 -mcpu=athlon
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/emulators/mupen64-sdlinput/distinfo b/emulators/mupen64-sdlinput/distinfo
new file mode 100644
index 000000000000..1b18c7d9216f
--- /dev/null
+++ b/emulators/mupen64-sdlinput/distinfo
@@ -0,0 +1,2 @@
+MD5 (blight_input-0.0.8-b.tar.gz) = 31661c6fca2dc455d7cbe7e87d316021
+SIZE (blight_input-0.0.8-b.tar.gz) = 733624
diff --git a/emulators/mupen64-sdlinput/files/patch-SDL_ttf.c b/emulators/mupen64-sdlinput/files/patch-SDL_ttf.c
new file mode 100644
index 000000000000..f0e6a0abe42b
--- /dev/null
+++ b/emulators/mupen64-sdlinput/files/patch-SDL_ttf.c
@@ -0,0 +1,12 @@
+--- src/SDL_ttf.c.orig Wed Oct 15 02:44:17 2003
++++ src/SDL_ttf.c Thu Aug 12 15:06:42 2004
+@@ -39,7 +39,8 @@
+ #define FREEA(p) free(p)
+ #endif
+
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ #include <freetype/ftoutln.h>
+ #include <freetype/ttnameid.h>
+ #include <freetype/internal/ftobjs.h>
diff --git a/emulators/mupen64-sdlinput/pkg-descr b/emulators/mupen64-sdlinput/pkg-descr
new file mode 100644
index 000000000000..6b42e6932a83
--- /dev/null
+++ b/emulators/mupen64-sdlinput/pkg-descr
@@ -0,0 +1,15 @@
+Blight's SDL input plugin for Mupen64
+-
+Mupen64 is a highly portable Nintendo 64 emulator. It has been developed
+on/for Linux originally but has already been ported successfully to other
+operating systems. The program can easily be ported to all operating systems
+supported by the SDL library.
+
+In its current state, the emulator is highly compatible and uses a plugin
+system. With the correct plugins ("correct" can be computer dependent), it
+can achieve nearly perfect graphics and sound in many games.
+
+WWW: http://mupen64.emulation64.com/
+
+- Travis Poppe
+tlp@liquidx.org
diff --git a/emulators/mupen64-sdlinput/pkg-message b/emulators/mupen64-sdlinput/pkg-message
new file mode 100644
index 000000000000..d53470396a22
--- /dev/null
+++ b/emulators/mupen64-sdlinput/pkg-message
@@ -0,0 +1,9 @@
+-------------------------------------------------------------------------------
+If you have installed/upgraded any new plugins or are upgrading from a previous
+version of Mupen64, please note that in order for these changes to take effect,
+you -must- backup and then remove ~/.mupen64 first. After you have removed the
+directory, run 'mupen64' to re-create it. Then, manually copy back your save
+files/other data you need from the backup if necessary.
+
+Enjoy!
+-------------------------------------------------------------------------------