summaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2014-06-02 17:26:45 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2014-06-02 17:26:45 +0000
commitf26899ecee57a5af6180cc7376e8c9b36721c333 (patch)
treefb379b0221c467a6eb4400a3ec10e39bf2c80da6 /emulators
parentf2406d7e802491d43b7fe12bfdc24f49908b6979 (diff)
downloadfreebsd-ports-f26899ecee57a5af6180cc7376e8c9b36721c333.zip
Stagify.
Reviewed by: flo (mentor) Approved by: flo (mentor)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/darcnes/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/emulators/darcnes/Makefile b/emulators/darcnes/Makefile
index 824045704256..27c0412ee6bf 100644
--- a/emulators/darcnes/Makefile
+++ b/emulators/darcnes/Makefile
@@ -5,7 +5,9 @@ PORTNAME= darcnes
PORTVERSION= 9b0401
PORTREVISION= 6
CATEGORIES= emulators
-MASTER_SITES= http://www.dridus.com/~nyef/darcnes/download/
+MASTER_SITES= http://www.dridus.com/~nyef/darcnes/download/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= grembo
DISTNAME= dn${PORTVERSION}
EXTRACT_SUFX= .tgz
@@ -21,7 +23,6 @@ USES= gmake
MAKE_ARGS= CC="${CC}" TARGET_CC="${CC}" CXX="${CXX}" TARGET_CXX="${CXX}" \
AS="${AS}" TARGET_AS="${CC}" LD="${LD}" TARGET_LD="${CC}"
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386" || defined(WITHOUT_X86_ASM)
@@ -48,10 +49,10 @@ post-patch:
@${CP} ${FILESDIR}/endian.h ${WRKSRC}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/darcnes ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/darcnes ${STAGEDIR}${PREFIX}/bin
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/readme ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.post.mk>