summaryrefslogtreecommitdiff
path: root/emulators/virtualbox-ose-kmod
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2014-03-04 00:45:37 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2014-03-04 00:45:37 +0000
commit71b986b697eb47831633a5989d1ba733991d89f7 (patch)
tree53bb6028fa45eb6699198f10d447206ea4b8abe2 /emulators/virtualbox-ose-kmod
parentc1d29d3843199576133cc1bd50d429ad7c89abf2 (diff)
downloadfreebsd-ports-71b986b697eb47831633a5989d1ba733991d89f7.zip
Update to 4.3.8.
Obtained from: svn.redports.org/virtualbox
Diffstat (limited to 'emulators/virtualbox-ose-kmod')
-rw-r--r--emulators/virtualbox-ose-kmod/Makefile36
-rw-r--r--emulators/virtualbox-ose-kmod/distinfo4
-rw-r--r--emulators/virtualbox-ose-kmod/files/extrapatch-Config.kmk11
-rw-r--r--emulators/virtualbox-ose-kmod/files/extrapatch-src-VBox-HostDrivers-Support-freebsd-Makefile11
-rw-r--r--emulators/virtualbox-ose-kmod/files/patch-Config.kmk56
-rw-r--r--emulators/virtualbox-ose-kmod/files/patch-src-VBox-HostDrivers-Support-freebsd-Makefile10
-rw-r--r--emulators/virtualbox-ose-kmod/files/patch-src-VBox-HostDrivers-VBoxNetAdp-Makefile.kmk25
-rw-r--r--emulators/virtualbox-ose-kmod/files/patch-src-VBox-HostDrivers-VBoxNetFlt-freebsd-VBoxNetFlt-freebsd.c72
-rw-r--r--emulators/virtualbox-ose-kmod/files/patch-src-VBox-Runtime-r0drv-freebsd-memobj-r0drv-freebsd.c47
-rw-r--r--emulators/virtualbox-ose-kmod/files/patch-src-VBox-Runtime-r0drv-freebsd-sleepqueue-r0drv-freebsd.h20
-rw-r--r--emulators/virtualbox-ose-kmod/pkg-plist7
11 files changed, 24 insertions, 275 deletions
diff --git a/emulators/virtualbox-ose-kmod/Makefile b/emulators/virtualbox-ose-kmod/Makefile
index 7160043dee67..566845ebbe9d 100644
--- a/emulators/virtualbox-ose-kmod/Makefile
+++ b/emulators/virtualbox-ose-kmod/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= virtualbox-ose
-DISTVERSION= 4.3.6
+DISTVERSION= 4.3.8
CATEGORIES= emulators
MASTER_SITES= http://download.virtualbox.org/virtualbox/${DISTVERSION}/ \
http://tmp.chruetertee.ch/ \
@@ -22,6 +22,7 @@ BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm \
USES= kmod
UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
+PATCHDIR= ${.CURDIR}/../${PORTNAME}/files
WRKSRC= ${WRKDIR}/VirtualBox-${PORTVERSION}
USE_RC_SUBR= vboxnet
ONLY_FOR_ARCHS= i386 amd64
@@ -37,27 +38,29 @@ CONFLICTS= bcc-[0-9]*
CONFLICTS_INSTALL= virtualbox-ose-kmod-devel-4* virtualbox-ose-kmod-legacy-4*
OPTIONS_DEFINE= DEBUG VIMAGE
+OPTIONS_SUB= yes
DEBUG_DESC= Debug symbols, additional logs and assertions
VIMAGE_DESC= VIMAGE virtual networking support
.include <bsd.port.options.mk>
VBOX_BIN= ${WRKSRC}/out/${KMK_ARCH}/${KMK_BUILDTYPE}/bin/src
+VBOX_KMODS= vboxdrv \
+ vboxnetadp \
+ vboxnetflt
+
+BUILD_WRKSRC= ${VBOX_BIN}
KMK_BUILDTYPE= release
KMK_CONFIG= VBOX_LIBPATH_X11=${LOCALBASE} VBOX_FREEBSD_SRC=${SRC_BASE}/sys
KMK_FLAGS= HostDrivers-scripts vboxdrv-mod VBoxNetFlt-src VBoxNetAdp-src
-MAKE_FLAGS= SYSDIR=${SRC_BASE}/sys
-
.if ${PORT_OPTIONS:MDEBUG}
KMK_FLAGS+= BUILD_TYPE=debug
KMK_BUILDTYPE= debug
-EXTRA_PATCHES+= ${FILESDIR}/extrapatch-Config.kmk ${FILESDIR}/extrapatch-src-VBox-HostDrivers-Support-freebsd-Makefile
-MAKE_FLAGS+= DEBUG_FLAGS="-O1 -g"
-PLIST_SUB+= WITH_DEBUG=""
-.else
-PLIST_SUB+= WITH_DEBUG="@comment "
+EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-Config.kmk \
+ ${PATCHDIR}/extrapatch-src-VBox-HostDrivers-Support-freebsd-Makefile
+MAKE_ARGS+= DEBUG_FLAGS="-O1 -g"
.endif
.if ${ARCH} == i386
@@ -84,19 +87,16 @@ post-patch:
pre-build:
@${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|' \
${WRKSRC}/env.sh
-
-do-build:
- cd ${WRKSRC} && ${SH} env.sh && cd ${WRKSRC}/src/VBox/HostDrivers && ${KMK_CONFIG} ${LOCALBASE}/bin/kmk ${KMK_FLAGS}
- cd ${VBOX_BIN} && make ${MAKE_FLAGS}
+ cd ${WRKSRC} && ${SH} env.sh && cd ${WRKSRC}/src/VBox/HostDrivers && \
+ ${KMK_CONFIG} ${LOCALBASE}/bin/kmk ${KMK_FLAGS}
do-install:
- ${INSTALL_KLD} ${VBOX_BIN}/vboxdrv/vboxdrv.ko ${STAGEDIR}${KMODDIR}
- ${INSTALL_KLD} ${VBOX_BIN}/vboxnetadp/vboxnetadp.ko ${STAGEDIR}${KMODDIR}
- ${INSTALL_KLD} ${VBOX_BIN}/vboxnetflt/vboxnetflt.ko ${STAGEDIR}${KMODDIR}
+ ${MKDIR} ${STAGEDIR}${KMODDIR}
+.for i in ${VBOX_KMODS}
+ ${INSTALL_KLD} ${VBOX_BIN}/${i}/${i}.ko ${STAGEDIR}${KMODDIR}
.if ${PORT_OPTIONS:MDEBUG}
- ${INSTALL_KLD} ${VBOX_BIN}/vboxdrv/vboxdrv.ko.symbols ${STAGEDIR}${KMODDIR}
- ${INSTALL_KLD} ${VBOX_BIN}/vboxnetadp/vboxnetadp.ko.symbols ${STAGEDIR}${KMODDIR}
- ${INSTALL_KLD} ${VBOX_BIN}/vboxnetflt/vboxnetflt.ko.symbols ${STAGEDIR}${KMODDIR}
+ ${INSTALL_KLD} ${VBOX_BIN}/${i}/${i}.ko.symbols ${STAGEDIR}${KMODDIR}
.endif
+.endfor
.include <bsd.port.post.mk>
diff --git a/emulators/virtualbox-ose-kmod/distinfo b/emulators/virtualbox-ose-kmod/distinfo
index 24e378bdad60..3ccbbdbc199b 100644
--- a/emulators/virtualbox-ose-kmod/distinfo
+++ b/emulators/virtualbox-ose-kmod/distinfo
@@ -1,2 +1,2 @@
-SHA256 (VirtualBox-4.3.6.tar.bz2) = c547e1e32e0b06fba9ee4ca7842f8ddee8e94c64aab17c2b0d0793f0caccbb27
-SIZE (VirtualBox-4.3.6.tar.bz2) = 89609199
+SHA256 (VirtualBox-4.3.8.tar.bz2) = ffabd8735bdc80753cec29d01b499769f41e083f37a3f58b3055f19d3b1b9641
+SIZE (VirtualBox-4.3.8.tar.bz2) = 90224116
diff --git a/emulators/virtualbox-ose-kmod/files/extrapatch-Config.kmk b/emulators/virtualbox-ose-kmod/files/extrapatch-Config.kmk
deleted file mode 100644
index 7df1b0883f27..000000000000
--- a/emulators/virtualbox-ose-kmod/files/extrapatch-Config.kmk
+++ /dev/null
@@ -1,11 +0,0 @@
---- Config.kmk.orig 2012-05-24 01:15:53.393052000 +0200
-+++ Config.kmk 2012-05-24 01:16:15.883067161 +0200
-@@ -3188,7 +3188,7 @@
- | xargs -J% objcopy % $(out)
-
- ## Strip debug info (comment out if debugging or something).
-- objcopy --strip-debug $(out)
-+# objcopy --strip-debug $(out)
- endef
- else # x86
- TOOL_FREEBSDKMODLD_LINK_SYSMOD_OUTPUT = $(outbase).kld
diff --git a/emulators/virtualbox-ose-kmod/files/extrapatch-src-VBox-HostDrivers-Support-freebsd-Makefile b/emulators/virtualbox-ose-kmod/files/extrapatch-src-VBox-HostDrivers-Support-freebsd-Makefile
deleted file mode 100644
index 67361da543f7..000000000000
--- a/emulators/virtualbox-ose-kmod/files/extrapatch-src-VBox-HostDrivers-Support-freebsd-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/VBox/HostDrivers/Support/freebsd/Makefile.orig 2012-10-18 16:23:16.000000000 +0200
-+++ src/VBox/HostDrivers/Support/freebsd/Makefile 2012-10-20 08:13:07.301179212 +0200
-@@ -27,7 +27,7 @@
-
- KMOD = vboxdrv
-
--CFLAGS += -DRT_OS_FREEBSD -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DSUPDRV_WITH_RELEASE_LOGGER -DVBOX -DRT_WITH_VBOX -Iinclude -I. -Ir0drv -w -DVBOX_WITH_HARDENING -DVBOX_WITH_64_BITS_GUESTS
-+CFLAGS += -DRT_OS_FREEBSD -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DSUPDRV_WITH_RELEASE_LOGGER -DVBOX -DRT_WITH_VBOX -Iinclude -I. -Ir0drv -w -DVBOX_WITH_HARDENING -DVBOX_WITH_64_BITS_GUESTS -DDEBUG
-
- .if (${MACHINE_ARCH} == "i386")
- CFLAGS += -DRT_ARCH_X86
diff --git a/emulators/virtualbox-ose-kmod/files/patch-Config.kmk b/emulators/virtualbox-ose-kmod/files/patch-Config.kmk
deleted file mode 100644
index d7edc886bb4a..000000000000
--- a/emulators/virtualbox-ose-kmod/files/patch-Config.kmk
+++ /dev/null
@@ -1,56 +0,0 @@
---- Config.kmk.orig 2012-12-20 14:44:38.260858319 +0100
-+++ Config.kmk 2012-12-20 14:55:59.491850177 +0100
-@@ -3239,7 +3239,7 @@
- $(VBOX_GCC_WARN) -Wpointer-arith -Winline $(VBOX_GCC_Wno-pointer-sign) $(VBOX_GCC_fdiagnostics-show-option) \
- -Wstrict-prototypes -Wmissing-prototypes -Wstrict-prototypes \
- -Wimplicit-function-declaration -Werror-implicit-function-declaration \
-- -O2 -fformat-extensions -ffreestanding -fno-strict-aliasing -fno-common -finline-limit=8000 \
-+ -O2 -ffreestanding -fno-strict-aliasing -fno-common -finline-limit=8000 \
- $(VBOX_GCC_fno-stack-protector) $(VBOX_GCC_R0_OPT) $(VBOX_GCC_R0_FP) \
- -nostdinc -std=c99
- TEMPLATE_VBOXR0DRV_CFLAGS.x86 = -m32 -mno-align-long-strings -mpreferred-stack-boundary=2 -mno-mmx -mno-3dnow -mno-sse -mno-sse2
-@@ -3248,7 +3248,7 @@
- -mno-3dnow -msoft-float -fno-asynchronous-unwind-tables -Wundef
- TEMPLATE_VBOXR0DRV_CXXFLAGS = -fno-exceptions -fno-rtti \
- $(VBOX_GCC_WARN) -Wpointer-arith -Winline \
-- -O2 -fno-format-extensions -fno-strict-aliasing -fno-common -finline-limit=8000 \
-+ -O2 -fno-strict-aliasing -fno-common -finline-limit=8000 \
- $(VBOX_GCC_fno-stack-protector) $(VBOX_GCC_R0_OPT) $(VBOX_GCC_R0_FP) \
- -nostdinc
- TEMPLATE_VBOXR0DRV_CXXFLAGS.x86 = $(TEMPLATE_VBOXR0DRV_CFLAGS.x86)
-@@ -3465,8 +3465,6 @@
- /usr/X11R6/include \
- /usr/local/include
- TEMPLATE_VBOXR3EXE_LIBPATH += \
-- /usr/lib \
-- /usr/X11R6/lib \
- /usr/local/lib
- else ifeq ($(KBUILD_TARGET),solaris)
- TEMPLATE_VBOXR3EXE_TOOL = GXX3PLAIN
-@@ -3955,8 +3953,6 @@
- /usr/X11R6/include \
- /usr/local/include
- TEMPLATE_VBOXMAINEXE_LIBPATH += \
-- /usr/lib \
-- /usr/X11R6/lib \
- /usr/local/lib
- else ifeq ($(KBUILD_TARGET),solaris)
- TEMPLATE_VBOXMAINEXE_TOOL = GXX3PLAIN
-@@ -4371,8 +4367,6 @@
- /usr/X11R6/include \
- /usr/local/include
- TEMPLATE_VBOXQT4GUIEXE_LIBPATH += \
-- /usr/lib \
-- /usr/X11R6/lib \
- /usr/local/lib
- endif
- ifeq ($(KBUILD_TARGET),solaris)
-@@ -4555,8 +4549,6 @@
- /usr/X11R6/include \
- /usr/local/include
- TEMPLATE_VBOXBLDPROG_LIBPATH += \
-- /usr/lib \
-- /usr/X11R6/lib \
- /usr/local/lib
- else ifeq ($(KBUILD_HOST),solaris)
- TEMPLATE_VBOXBLDPROG_TOOL = GXX3PLAIN
diff --git a/emulators/virtualbox-ose-kmod/files/patch-src-VBox-HostDrivers-Support-freebsd-Makefile b/emulators/virtualbox-ose-kmod/files/patch-src-VBox-HostDrivers-Support-freebsd-Makefile
deleted file mode 100644
index 56fa83e858e0..000000000000
--- a/emulators/virtualbox-ose-kmod/files/patch-src-VBox-HostDrivers-Support-freebsd-Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/VBox/HostDrivers/Support/freebsd/Makefile.orig 2013-10-17 00:51:57.724397794 +0400
-+++ src/VBox/HostDrivers/Support/freebsd/Makefile 2013-10-17 00:52:05.491398026 +0400
-@@ -170,6 +170,7 @@
- SRCS += \
- semspinmutex-r0drv-generic.c \
- mpnotification-r0drv-generic.c \
-+ threadctxhooks-r0drv-generic.c \
- RTMpIsCpuWorkPending-r0drv-generic.c
-
- .PATH: ${.CURDIR}/VBox
diff --git a/emulators/virtualbox-ose-kmod/files/patch-src-VBox-HostDrivers-VBoxNetAdp-Makefile.kmk b/emulators/virtualbox-ose-kmod/files/patch-src-VBox-HostDrivers-VBoxNetAdp-Makefile.kmk
deleted file mode 100644
index 01d25b3ac02a..000000000000
--- a/emulators/virtualbox-ose-kmod/files/patch-src-VBox-HostDrivers-VBoxNetAdp-Makefile.kmk
+++ /dev/null
@@ -1,25 +0,0 @@
-Fix kmod panic when VIMAGE is disabled in the kernel and port
-
-Submitted by: Gleb Kurtsou <gleb@freebsd.org>
---- src/VBox/HostDrivers/VBoxNetAdp/Makefile.kmk.orig 2013-04-12 03:38:10.000000000 -0700
-+++ src/VBox/HostDrivers/VBoxNetAdp/Makefile.kmk 2013-06-11 21:24:05.000000000 -0700
-@@ -143,12 +143,15 @@
- $$(if $$(eq $$(VBoxNetAdp/freebsd/Makefile_VBOX_HARDENED),$$(VBOX_WITH_HARDENING)),,FORCE) \
- | $$(dir $$@)
- $(QUIET)$(RM) -f -- $@
-- ifndef VBOX_WITH_HARDENING
-- $(QUIET)$(SED) -e "s;-DVBOX_WITH_HARDENING;;g" --output $@ $<
-- else
- $(QUIET)$(CP) -f $< $@
-+ ifndef VBOX_WITH_HARDENING
-+ $(QUIET)$(SED) -e "s;-DVBOX_WITH_HARDENING;;g" --output $@.tmp $@
-+ ${QUIET}$(MV) -f $@.tmp $@
-+ endif
-+ ifndef VBOX_WITH_NETFLT_VIMAGE
-+ $(QUIET)$(SED) -e "s;-DVIMAGE;;g" --output $@.tmp $@
-+ ${QUIET}$(MV) -f $@.tmp $@
- endif
--
- endif # freebsd
-
- include $(FILE_KBUILD_SUB_FOOTER)
diff --git a/emulators/virtualbox-ose-kmod/files/patch-src-VBox-HostDrivers-VBoxNetFlt-freebsd-VBoxNetFlt-freebsd.c b/emulators/virtualbox-ose-kmod/files/patch-src-VBox-HostDrivers-VBoxNetFlt-freebsd-VBoxNetFlt-freebsd.c
deleted file mode 100644
index 6cb5a1ebd30c..000000000000
--- a/emulators/virtualbox-ose-kmod/files/patch-src-VBox-HostDrivers-VBoxNetFlt-freebsd-VBoxNetFlt-freebsd.c
+++ /dev/null
@@ -1,72 +0,0 @@
-Add VLAN trunking support to vboxnetflt
-
-See: http://lists.freebsd.org/pipermail/freebsd-emulation/2012-April/009698.html
-See: http://lists.freebsd.org/pipermail/freebsd-emulation/2013-May/010605.html
-Submitted by: Landon J Fuller <landonf at plausible.coop>
---- ./src/VBox/HostDrivers/VBoxNetFlt/freebsd/VBoxNetFlt-freebsd.c.orig 2013-04-12 06:38:11.000000000 -0400
-+++ ./src/VBox/HostDrivers/VBoxNetFlt/freebsd/VBoxNetFlt-freebsd.c 2013-05-25 20:14:52.152180452 -0400
-@@ -51,6 +51,7 @@
- #include <net/if_dl.h>
- #include <net/if_types.h>
- #include <net/ethernet.h>
-+#include <net/if_vlan_var.h>
-
- #include <netgraph/ng_message.h>
- #include <netgraph/netgraph.h>
-@@ -427,6 +428,8 @@
- struct ifnet *ifp = pThis->u.s.ifp;
- unsigned int cSegs = 0;
- bool fDropIt = false, fActive;
-+ bool is_vl_tagged = false;
-+ uint16_t vl_tag;
- PINTNETSG pSG;
-
- VBOXCURVNET_SET(ifp->if_vnet);
-@@ -439,6 +442,19 @@
- if (m == NULL)
- break;
-
-+ /* Prepend a VLAN header for consumption by the virtual switch */
-+ if (m->m_flags & M_VLANTAG) {
-+ vl_tag = m->m_pkthdr.ether_vtag;
-+ is_vl_tagged = true;
-+
-+ m = ether_vlanencap(m, m->m_pkthdr.ether_vtag);
-+ if (m == NULL) {
-+ printf("vboxflt: unable to prepend VLAN header\n");
-+ break;
-+ }
-+ m->m_flags &= ~M_VLANTAG;
-+ }
-+
- for (m0 = m; m0 != NULL; m0 = m0->m_next)
- if (m0->m_len > 0)
- cSegs++;
-@@ -453,6 +469,27 @@
- vboxNetFltFreeBSDMBufToSG(pThis, m, pSG, cSegs, 0);
- fDropIt = pThis->pSwitchPort->pfnRecv(pThis->pSwitchPort, NULL /* pvIf */, pSG, INTNETTRUNKDIR_WIRE);
- RTMemTmpFree(pSG);
-+
-+ /* Restore the VLAN flags before re-injecting the packet */
-+ if (is_vl_tagged && !fDropIt) {
-+ struct ether_vlan_header *vl_hdr;
-+
-+ /* This shouldn't fail, as the header was just prepended */
-+ if (m->m_len < sizeof(*vl_hdr) && (m = m_pullup(m, sizeof(*vl_hdr))) == NULL) {
-+ printf("vboxflt: unable to pullup VLAN header\n");
-+ m_freem(m);
-+ break;
-+ }
-+
-+ /* Copy the MAC dhost/shost over the 802.1q field */
-+ vl_hdr = mtod(m, struct ether_vlan_header *);
-+ bcopy((char *)vl_hdr, (char *)vl_hdr + ETHER_VLAN_ENCAP_LEN, ETHER_HDR_LEN - ETHER_TYPE_LEN);
-+ m_adj(m, ETHER_VLAN_ENCAP_LEN);
-+
-+ m->m_pkthdr.ether_vtag = vl_tag;
-+ m->m_flags |= M_VLANTAG;
-+ }
-+
- if (fDropIt)
- m_freem(m);
- else
diff --git a/emulators/virtualbox-ose-kmod/files/patch-src-VBox-Runtime-r0drv-freebsd-memobj-r0drv-freebsd.c b/emulators/virtualbox-ose-kmod/files/patch-src-VBox-Runtime-r0drv-freebsd-memobj-r0drv-freebsd.c
deleted file mode 100644
index b760cfe7f940..000000000000
--- a/emulators/virtualbox-ose-kmod/files/patch-src-VBox-Runtime-r0drv-freebsd-memobj-r0drv-freebsd.c
+++ /dev/null
@@ -1,47 +0,0 @@
-From Alan L. Cox on FreeBSD-current:
-
- I just glanced at the virtualbox code for a couple minutes. For
- FreeBSD 9 and 10, these lock acquires are completely unnecessary, and
- have been since FreeBSD 9.0. Just delete them. They may be equally
- unnecessary under FreeBSD 8, but I didn't look carefully enough to
- answer that question.
-
-[1] http://lists.freebsd.org/pipermail/freebsd-current/2012-November/037963.html
---- src/VBox/Runtime/r0drv/freebsd/memobj-r0drv-freebsd.c.orig 2013-11-29 12:04:53.000000000 +0100
-+++ src/VBox/Runtime/r0drv/freebsd/memobj-r0drv-freebsd.c 2013-11-29 12:37:29.000000000 +0100
-@@ -168,14 +168,19 @@
- VM_OBJECT_LOCK(pMemFreeBSD->pObject);
- #endif
- vm_page_t pPage = vm_page_find_least(pMemFreeBSD->pObject, 0);
-+#if __FreeBSD_version < 900000
-+ /* See http://lists.freebsd.org/pipermail/freebsd-current/2012-November/037963.html */
- vm_page_lock_queues();
-+#endif
- for (vm_page_t pPage = vm_page_find_least(pMemFreeBSD->pObject, 0);
- pPage != NULL;
- pPage = vm_page_next(pPage))
- {
- vm_page_unwire(pPage, 0);
- }
-+#if __FreeBSD_version < 900000
- vm_page_unlock_queues();
-+#endif
- #if __FreeBSD_version >= 1000030
- VM_OBJECT_WUNLOCK(pMemFreeBSD->pObject);
- #else
-@@ -291,11 +296,15 @@
- while (iPage-- > 0)
- {
- pPage = vm_page_lookup(pObject, iPage);
-+#if __FreeBSD_version < 900000
- vm_page_lock_queues();
-+#endif
- if (fWire)
- vm_page_unwire(pPage, 0);
- vm_page_free(pPage);
-+#if __FreeBSD_version < 900000
- vm_page_unlock_queues();
-+#endif
- }
- #if __FreeBSD_version >= 1000030
- VM_OBJECT_WUNLOCK(pObject);
diff --git a/emulators/virtualbox-ose-kmod/files/patch-src-VBox-Runtime-r0drv-freebsd-sleepqueue-r0drv-freebsd.h b/emulators/virtualbox-ose-kmod/files/patch-src-VBox-Runtime-r0drv-freebsd-sleepqueue-r0drv-freebsd.h
deleted file mode 100644
index e1ae4d7ea855..000000000000
--- a/emulators/virtualbox-ose-kmod/files/patch-src-VBox-Runtime-r0drv-freebsd-sleepqueue-r0drv-freebsd.h
+++ /dev/null
@@ -1,20 +0,0 @@
-Without this patch any waits for periods shorter than a single tick return
-immediately leading to a lot of unnecessary spinning. For example, I observe that
-my guest's idle loop does a lot of sleeps with periods slightly shorter than 1 ms
-(1/hz), e.g. 900us. All that waiting turns into pure spinning and VirtualBox eats
-100% of a core.
-The patch improves the situation significantly. Also, it (approximately) follows
-what tvtohz does.
-
-Submitted by: Andriy Gapon <avg@FreeBSD.org>
---- src/VBox/Runtime/r0drv/freebsd/sleepqueue-r0drv-freebsd.h.orig 2012-12-19 19:27:29.000000000 +0100
-+++ src/VBox/Runtime/r0drv/freebsd/sleepqueue-r0drv-freebsd.h 2012-12-20 12:07:48.941861966 +0100
-@@ -82,6 +82,8 @@
- uint64_t cTicks = ASMMultU64ByU32DivByU32(uTimeout, hz, UINT32_C(1000000000));
- if (cTicks >= INT_MAX)
- return RTSEMWAIT_FLAGS_INDEFINITE;
-+ else if (cTicks == 0 && uTimeout > 0)
-+ pWait->iTimeout = 1;
- else
- pWait->iTimeout = (int)cTicks;
- #endif
diff --git a/emulators/virtualbox-ose-kmod/pkg-plist b/emulators/virtualbox-ose-kmod/pkg-plist
index 50d6e52825bb..0fdfc43f46e5 100644
--- a/emulators/virtualbox-ose-kmod/pkg-plist
+++ b/emulators/virtualbox-ose-kmod/pkg-plist
@@ -1,7 +1,8 @@
+@comment $FreeBSD$
@cwd /
%%KMODDIR%%/vboxdrv.ko
-%%WITH_DEBUG%%%%KMODDIR%%/vboxdrv.ko.symbols
+%%DEBUG%%%%KMODDIR%%/vboxdrv.ko.symbols
%%KMODDIR%%/vboxnetadp.ko
-%%WITH_DEBUG%%%%KMODDIR%%/vboxnetadp.ko.symbols
+%%DEBUG%%%%KMODDIR%%/vboxnetadp.ko.symbols
%%KMODDIR%%/vboxnetflt.ko
-%%WITH_DEBUG%%%%KMODDIR%%/vboxnetflt.ko.symbols
+%%DEBUG%%%%KMODDIR%%/vboxnetflt.ko.symbols