summaryrefslogtreecommitdiff
path: root/emulators/nestopia
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-09-05 17:13:08 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-09-05 17:13:08 +0000
commit8e2733d4144cca6f30dee92cf3e2f37730339d41 (patch)
tree24b160b481e10b044a1ee225a1915a48fd195eb0 /emulators/nestopia
parent1033b5c631608c2eb1d289291abd4622d60d2334 (diff)
downloadfreebsd-ports-8e2733d4144cca6f30dee92cf3e2f37730339d41.zip
emulators/nestopia: Update to 1.4.8
PR: 222058 Submitted by: Neel Chauhan <neel@neelc.org>
Diffstat (limited to 'emulators/nestopia')
-rw-r--r--emulators/nestopia/Makefile11
-rw-r--r--emulators/nestopia/distinfo5
-rw-r--r--emulators/nestopia/files/patch-Makefile29
-rw-r--r--emulators/nestopia/files/patch-source_unix_gtkui_gtkui.h10
-rw-r--r--emulators/nestopia/pkg-plist21
5 files changed, 21 insertions, 55 deletions
diff --git a/emulators/nestopia/Makefile b/emulators/nestopia/Makefile
index 283d4857f27b..6a8543ae6ba8 100644
--- a/emulators/nestopia/Makefile
+++ b/emulators/nestopia/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= nestopia
-PORTVERSION= 1.47
-PORTREVISION= 1
+PORTVERSION= 1.48
CATEGORIES= emulators
MAINTAINER= neel@neelc.org
@@ -10,16 +9,18 @@ COMMENT= Portable NES/Famicom emulator
LICENSE= GPLv2
-LIB_DEPENDS= libao.so:audio/libao
+LIB_DEPENDS= libao.so:audio/libao libepoxy.so:graphics/libepoxy
-USES= gmake libarchive pkgconfig
+USES= cmake desktop-file-utils libarchive localbase:ldflags pkgconfig
USE_GL= glu
-USE_GNOME= gtk30
+USE_GNOME= cairo gdkpixbuf2 gtk30
USE_SDL= sdl2
USE_GITHUB= yes
GH_ACCOUNT= rdanbrook
+INSTALLS_ICONS= yes
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
diff --git a/emulators/nestopia/distinfo b/emulators/nestopia/distinfo
index e0a6c31ccc06..6051edf76504 100644
--- a/emulators/nestopia/distinfo
+++ b/emulators/nestopia/distinfo
@@ -1,2 +1,3 @@
-SHA256 (rdanbrook-nestopia-1.47_GH0.tar.gz) = 915db5aeeda5c9e800a96dac229766d82c0990a7ee165a30317a62bfabccf9b7
-SIZE (rdanbrook-nestopia-1.47_GH0.tar.gz) = 1271675
+TIMESTAMP = 1504559258
+SHA256 (rdanbrook-nestopia-1.48_GH0.tar.gz) = fb6629b5d0da8548bbf5beb387209d1958358b303e5a2100a94491497e019ea0
+SIZE (rdanbrook-nestopia-1.48_GH0.tar.gz) = 1263143
diff --git a/emulators/nestopia/files/patch-Makefile b/emulators/nestopia/files/patch-Makefile
deleted file mode 100644
index 9e6874dc225a..000000000000
--- a/emulators/nestopia/files/patch-Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
---- Makefile.orig 2016-01-15 15:25:05.060978417 -0500
-+++ Makefile 2016-01-15 19:19:38.773106245 -0500
-@@ -395,16 +395,16 @@
- $(CC) $(LDFLAGS) $^ $(LIBS) -o $(BIN)
-
- install:
-- mkdir -p $(BINDIR)
-- mkdir -p $(DATADIR)/icons
-- mkdir -p $(PREFIX)/share/pixmaps
-- install -m 0755 $(BIN) $(BINDIR)
-- install -m 0644 source/unix/icons/nestopia.desktop $(DATADIR)
-- install -m 0644 NstDatabase.xml $(DATADIR)
-- install -m 0644 source/unix/icons/*.png $(DATADIR)/icons
-- install -m 0644 source/unix/icons/*.svg $(DATADIR)/icons
-- install -m 0644 source/unix/icons/nestopia.svg $(PREFIX)/share/pixmaps
-- xdg-desktop-menu install --novendor $(DATADIR)/nestopia.desktop
-+ mkdir -p $(DESTDIR)$(BINDIR)
-+ mkdir -p $(DESTDIR)$(DATADIR)/icons
-+ mkdir -p $(DESTDIR)$(PREFIX)/share/pixmaps
-+ install -m 0755 $(BIN) $(DESTDIR)$(BINDIR)
-+ install -m 0644 source/unix/icons/nestopia.desktop $(DESTDIR)$(DATADIR)
-+ install -m 0644 NstDatabase.xml $(DESTDIR)$(DATADIR)
-+ install -m 0644 source/unix/icons/*.png $(DESTDIR)$(DATADIR)/icons
-+ install -m 0644 source/unix/icons/*.svg $(DESTDIR)$(DATADIR)/icons
-+ install -m 0644 source/unix/icons/nestopia.svg $(DESTDIR)$(PREFIX)/share/pixmaps
-+ install -m 0644 source/unix/icons/nestopia.desktop $(DESTDIR)$(PREFIX)/share/applications/nestopia.desktop
-
- uninstall:
- xdg-desktop-menu uninstall $(DATADIR)/nestopia.desktop
diff --git a/emulators/nestopia/files/patch-source_unix_gtkui_gtkui.h b/emulators/nestopia/files/patch-source_unix_gtkui_gtkui.h
deleted file mode 100644
index 886909deb20a..000000000000
--- a/emulators/nestopia/files/patch-source_unix_gtkui_gtkui.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./source/unix/gtkui/gtkui.h.orig 2016-01-09 18:34:38 -0500
-+++ ./source/unix/gtkui/gtkui.h 2016-01-15 11:34:58 -0500
-@@ -8,7 +8,6 @@
- #elif _APPLE
- #else
- #include <gdk/gdkx.h>
--#include <gdk/gdkwayland.h>
- #endif
-
- void gtkui_init(int argc, char *argv[]);
diff --git a/emulators/nestopia/pkg-plist b/emulators/nestopia/pkg-plist
index b9a6cd1bc3f2..0339d460d355 100644
--- a/emulators/nestopia/pkg-plist
+++ b/emulators/nestopia/pkg-plist
@@ -1,12 +1,15 @@
bin/nestopia
-share/pixmaps/nestopia.svg
+share/icons/hicolor/128x128/apps/nestopia.png
+share/icons/hicolor/32x32/apps/nestopia.png
+share/icons/hicolor/48x48/apps/nestopia.png
+share/icons/hicolor/64x64/apps/nestopia.png
+share/icons/hicolor/96x96/apps/nestopia.png
+share/icons/hicolor/scalable/apps/nespad.svg
+share/icons/hicolor/scalable/apps/nestopia.svg
share/applications/nestopia.desktop
-%%DATADIR%%/icons/nestopia.svg
-%%DATADIR%%/icons/nespad.svg
-%%DATADIR%%/icons/nestopia48.png
-%%DATADIR%%/icons/nestopia96.png
-%%DATADIR%%/icons/nestopia32.png
-%%DATADIR%%/icons/nestopia128.png
-%%DATADIR%%/icons/nestopia64.png
%%DATADIR%%/NstDatabase.xml
-%%DATADIR%%/nestopia.desktop
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%PORTDOCS%%%%DOCSDIR%%/README.unix
+%%PORTDOCS%%%%DOCSDIR%%/html/readme.html