summaryrefslogtreecommitdiff
path: root/editors/libreoffice/files/patch-avmedia_Library__avmediaogl.mk
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2015-09-01 21:26:44 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2015-09-01 21:26:44 +0000
commitf6862ef6519138ee01e5fd3d912b38341ad953e7 (patch)
tree096d23e157bb6c7cf824e6673e76df1c3416d2bc /editors/libreoffice/files/patch-avmedia_Library__avmediaogl.mk
parent8e614fd8ecb3555279fc6107528c2d0fa71e6dda (diff)
downloadfreebsd-ports-f6862ef6519138ee01e5fd3d912b38341ad953e7.zip
Update LibreOffice to 5.0.1.
Unfortunately, LibreOffice project completely dropped support for pre-C++11 compilers and libraries since 4.4. Therefore, we cannot easily build it on FeeBSD 9.x any more unless the system was rebuilt with WITH_CLANG_IS_CC and WITH_LIBCPLUSPLUS. If user is unable to upgrade the system for some reason, the old port, i.e., 4.3.7, is still available from devel/libreoffice4 (with no language packs).
Diffstat (limited to 'editors/libreoffice/files/patch-avmedia_Library__avmediaogl.mk')
-rw-r--r--editors/libreoffice/files/patch-avmedia_Library__avmediaogl.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/editors/libreoffice/files/patch-avmedia_Library__avmediaogl.mk b/editors/libreoffice/files/patch-avmedia_Library__avmediaogl.mk
new file mode 100644
index 000000000000..7782dd1ed7de
--- /dev/null
+++ b/editors/libreoffice/files/patch-avmedia_Library__avmediaogl.mk
@@ -0,0 +1,11 @@
+--- avmedia/Library_avmediaogl.mk.orig 2015-08-22 06:41:35 UTC
++++ avmedia/Library_avmediaogl.mk
+@@ -52,7 +52,7 @@ else ifeq ($(OS),MACOSX)
+ $(eval $(call gb_Library_use_system_darwin_frameworks,avmediaogl,\
+ OpenGL \
+ ))
+-else ifeq ($(OS),LINUX)
++else ifneq ($(filter FREEBSD LINUX,$(OS)),)
+ $(eval $(call gb_Library_add_libs,avmediaogl,\
+ -lGL \
+ ))