summaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-02-22 12:47:25 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-02-22 12:47:25 +0000
commit117125bd1d7585cad82d623f0da6715acced2cdc (patch)
tree7cb0e5b1b8537c9ebe89d41eb3b26e8e6edbc147 /dns
parent95b9127ec09113d7a72cc1181b67b4bec53afb40 (diff)
downloadfreebsd-ports-117125bd1d7585cad82d623f0da6715acced2cdc.zip
- Fix man installation after port was stagified [1]
- Convert LIB_DEPENDS to new format [1] - Remove leading article from COMMENT - Switch to options helpers - Conditional installation of docs is not needed with stage - Don't show pkg-message twice PR: ports/186693 [1] Submitted by: Denis Generalov <gd.workbox@gmail.com> Approved by: maintainer
Diffstat (limited to 'dns')
-rw-r--r--dns/nsd/Makefile79
-rw-r--r--dns/nsd/pkg-plist4
2 files changed, 21 insertions, 62 deletions
diff --git a/dns/nsd/Makefile b/dns/nsd/Makefile
index f04ee2bc0496..f69867401850 100644
--- a/dns/nsd/Makefile
+++ b/dns/nsd/Makefile
@@ -3,13 +3,13 @@
PORTNAME= nsd
PORTVERSION= 4.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns ipv6
MASTER_SITES= http://www.nlnetlabs.nl/downloads/nsd/ \
ftp://ftp.rhnet.is/pub/nsd/
MAINTAINER= jaap@NLnetLabs.nl
-COMMENT= An authoritative only non-recursive name server
+COMMENT= Authoritative only non-recursive name server
LICENSE= BSD3CLAUSE
@@ -40,9 +40,6 @@ SUB_LIST+= NSDUSER=${NSDUSER} \
USE_OPENSSL= yes
-MAN5= nsd.conf.5
-MAN8= nsd.8 nsd-checkconf.8 nsd-control.8
-
PORTDOCS= CREDITS ChangeLog LICENSE NSD-DATABASE NSD-DIFFFILE \
NSD-4-features NSD-FOR-BIND-USERS README README.icc RELNOTES \
REQUIREMENTS TESTPLAN TODO UPGRADING coding-style \
@@ -65,57 +62,20 @@ MAXIPS_DESC= Raise max-ips from 8 to ${NSDMAX_IPS}
RRL_DESC= Response Rate Limiting
EUI_RRTYPES_DESC= EUI48 and EUI64 RRtypes support
-.include <bsd.port.options.mk>
-
-LIB_DEPENDS+= event-1:${PORTSDIR}/devel/libevent
-
-.if ${PORT_OPTIONS:MROOT_SERVER}
-CONFIGURE_ARGS+= --enable-root-server
-.endif
-
-.if empty(PORT_OPTIONS:MLARGEFILE)
-CONFIGURE_ARGS+= --disable-largefile
-.endif
-
-.if empty(PORT_OPTIONS:MIPV6)
-CONFIGURE_ARGS+= --disable-ipv6
-.endif
-
-.if ${PORT_OPTIONS:MBIND8_STATS}
-CONFIGURE_ARGS+= --enable-bind8-stats
-.endif
-
-.if ${PORT_OPTIONS:MCHECKING}
-CONFIGURE_ARGS+= --enable-checking
-.endif
-
-.if empty(PORT_OPTIONS:MNSEC3)
-CONFIGURE_ARGS+= --disable-nsec3
-.endif
-
-.if empty(PORT_OPTIONS:MMINRESPSIZE)
-CONFIGURE_ARGS+= --disable-minimal-responses
-.endif
-
-.if empty(PORT_OPTIONS:MNSEC3PREHASH)
-CONFIGURE_ARGS+= --disable-full-prehash
-.endif
-
-.if ${PORT_OPTIONS:MMMAP}
-CONFIGURE_ARGS+= --enable-mmap
-.endif
-
-.if ${PORT_OPTIONS:MMAXIPS}
-CONFIGURE_ARGS+= --with-max-ips=${NSDMAX_IPS}
-.endif
-
-.if ${PORT_OPTIONS:MRRL}
-CONFIGURE_ARGS+= --enable-ratelimit
-.endif
-
-.if ${PORT_OPTIONS:MEUI_RRTYPES}
-CONFIGURE_ARGS+= --enable-draft-rrtypes
-.endif
+LIB_DEPENDS+= libevent-1.4.so:${PORTSDIR}/devel/libevent
+
+ROOT_SERVER_CONFIGURE_ON= --enable-root-server
+LARGEFILE_CONFIGURE_OFF= --disable-largefile
+IPV6_CONFIGURE_OFF= --disable-ipv6
+BIND8_STATS_CONFIGURE_ON= --enable-bind8-stats
+CHECKING_CONFIGURE_ON= --enable-checking
+NSEC3_CONFIGURE_OFF= --disable-nsec3
+MINRESPSIZE_CONFIGURE_OFF= --disable-minimal-responses
+NSEC3PREHASH_CONFIGURE_OFF= --disable-full-prehash
+MMAP_CONFIGURE_ON= --enable-mmap
+MAXIPS_CONFIGURE_ON= --with-max-ips=${NSDMAX_IPS}
+RRL_CONFIGURE_ON= --enable-ratelimit
+EUI_RRTYPES_CONFIGURE_ON= --enable-draft-rrtypes
pre-patch:
.if defined(NSD_OPTIONS)
@@ -135,13 +95,8 @@ pre-patch:
post-install:
${INSTALL_DATA} ${WRKSRC}/nsd.conf.sample \
${STAGEDIR}${PREFIX}/etc/nsd/nsd.conf.sample
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${STAGEDIR}${DOCSDIR}/${f}
-.endfor
-.endif
+ (cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/dns/nsd/pkg-plist b/dns/nsd/pkg-plist
index 42c4439f2e48..16ff85c803dc 100644
--- a/dns/nsd/pkg-plist
+++ b/dns/nsd/pkg-plist
@@ -1,4 +1,8 @@
%%ETCDIR%%/nsd.conf.sample
+man/man5/nsd.conf.5.gz
+man/man8/nsd-checkconf.8.gz
+man/man8/nsd-control.8.gz
+man/man8/nsd.8.gz
sbin/nsd
sbin/nsd-checkconf
sbin/nsd-control