summaryrefslogtreecommitdiff
path: root/dns/zkt/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-08-17 06:09:52 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-08-17 06:09:52 +0000
commitdf49f00e215962de0fa78d88861426e9f7ed482e (patch)
tree6e4d5923c2d4b32188195a671579cea5ced5d221 /dns/zkt/Makefile
parent7d924dfbd2b88ac60f341b8a75da22b97a84b1a1 (diff)
downloadfreebsd-ports-df49f00e215962de0fa78d88861426e9f7ed482e.zip
New port: dns/zkt (ZKT is a tool to manage keys and signatures for DNSSEC-zones)
ZKT is a tool to manage keys and signatures for DNSSEC-zones. The Zone Key Tool consists of two commands: - dnssec-zkt to create and list dnssec zone keys and - dnssec-signer to sign a zone and manage the lifetime of the zone signing keys See: http://www.hznet.de/dns/zkt/ PR: ports/126296 Submitted by: Frank Behrens <frank+ports@ilse.behrens.de>
Diffstat (limited to 'dns/zkt/Makefile')
-rw-r--r--dns/zkt/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/dns/zkt/Makefile b/dns/zkt/Makefile
new file mode 100644
index 000000000000..a7b640cb25dd
--- /dev/null
+++ b/dns/zkt/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: zkt
+# Date created: 2008-08-06
+# Whom: Frank Behrens <frank+ports@ilse.behrens.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zkt
+PORTVERSION= 0.97
+CATEGORIES= dns
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.hznet.de/dns/zkt/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= frank+ports@ilse.behrens.de
+COMMENT= Tool to manage keys and signatures for DNSSEC-zones
+
+DIR_NAMED_CONF?= /etc/namedb
+
+PLIST_FILES= sbin/dnssec-zkt \
+ sbin/dnssec-signer \
+ sbin/zkt-soaserial
+MAN8= dnssec-zkt.8 dnssec-signer.8
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --enable-configpath=${DIR_NAMED_CONF}
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/dnssec-zkt ${PREFIX}/sbin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/dnssec-signer ${PREFIX}/sbin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/zkt-soaserial ${PREFIX}/sbin/
+ ${INSTALL_MAN} ${WRKSRC}/dnssec-zkt.8 ${PREFIX}/man/man8/
+ ${INSTALL_MAN} ${WRKSRC}/dnssec-signer.8 ${PREFIX}/man/man8/
+
+.include <bsd.port.post.mk>