summaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-08-09 07:52:10 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-08-09 07:52:10 +0000
commitcc9f432ba7b71cf5f00f53d816532b34cfc91d2c (patch)
tree68ad4ff4dd39f2b8c179edbab0143d5b9cbb8b29 /devel
parentd2e84a9206a0c9fa7faef564855ad0ca0671c623 (diff)
downloadfreebsd-ports-cc9f432ba7b71cf5f00f53d816532b34cfc91d2c.zip
Add python3 flavor for py-xdg.
Obtained from: gnome devel repo
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py3-xdg/Makefile26
-rw-r--r--devel/py3-xdg/distinfo2
-rw-r--r--devel/py3-xdg/files/patch-xdg_BaseDirectory.py18
-rw-r--r--devel/py3-xdg/pkg-descr11
5 files changed, 58 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 781c2aa6c44a..c1b68d9b418f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4040,6 +4040,7 @@
SUBDIR += py_static_check
SUBDIR += py3-dbus
SUBDIR += py3-gobject3
+ SUBDIR += py3-xdg
SUBDIR += pybaz
SUBDIR += pybugz
SUBDIR += pychecker
diff --git a/devel/py3-xdg/Makefile b/devel/py3-xdg/Makefile
new file mode 100644
index 000000000000..6cf661aacb78
--- /dev/null
+++ b/devel/py3-xdg/Makefile
@@ -0,0 +1,26 @@
+# Created by: michael johnson <ahze@ahze.net>
+# $FreeBSD$
+# $MCom: ports/trunk/devel/py3-xdg/Makefile 19571 2014-04-25 18:12:46Z kwm $
+
+PORTNAME= xdg
+PORTVERSION= 0.25
+CATEGORIES= devel python
+MASTER_SITES= http://people.freedesktop.org/~takluyver/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Python 3 library to access freedesktop.org standards
+
+LICENSE= LGPL20
+
+USE_PYTHON= 3
+USE_PYDISTUTILS=yes
+PYDISTUTILS_AUTOPLIST= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/xdg/BaseDirectory.py
+
+.include <bsd.port.mk>
diff --git a/devel/py3-xdg/distinfo b/devel/py3-xdg/distinfo
new file mode 100644
index 000000000000..c3a868b4c088
--- /dev/null
+++ b/devel/py3-xdg/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pyxdg-0.25.tar.gz) = 81e883e0b9517d624e8b0499eb267b82a815c0b7146d5269f364988ae031279d
+SIZE (pyxdg-0.25.tar.gz) = 48935
diff --git a/devel/py3-xdg/files/patch-xdg_BaseDirectory.py b/devel/py3-xdg/files/patch-xdg_BaseDirectory.py
new file mode 100644
index 000000000000..23fa9b13f8c5
--- /dev/null
+++ b/devel/py3-xdg/files/patch-xdg_BaseDirectory.py
@@ -0,0 +1,18 @@
+--- xdg/BaseDirectory.py.orig 2012-12-06 22:07:26.000000000 +0100
++++ xdg/BaseDirectory.py 2014-03-04 17:22:23.000000000 +0100
+@@ -32,13 +32,13 @@
+ os.path.join(_home, '.local', 'share')
+
+ xdg_data_dirs = [xdg_data_home] + \
+- (os.environ.get('XDG_DATA_DIRS') or '/usr/local/share:/usr/share').split(':')
++ (os.environ.get('XDG_DATA_DIRS') or '%%LOCALBASE%%/share').split(':')
+
+ xdg_config_home = os.environ.get('XDG_CONFIG_HOME') or \
+ os.path.join(_home, '.config')
+
+ xdg_config_dirs = [xdg_config_home] + \
+- (os.environ.get('XDG_CONFIG_DIRS') or '/etc/xdg').split(':')
++ (os.environ.get('XDG_CONFIG_DIRS') or '%%LOCALBASE%%/etc/xdg').split(':')
+
+ xdg_cache_home = os.environ.get('XDG_CACHE_HOME') or \
+ os.path.join(_home, '.cache')
diff --git a/devel/py3-xdg/pkg-descr b/devel/py3-xdg/pkg-descr
new file mode 100644
index 000000000000..4dd138ecb22d
--- /dev/null
+++ b/devel/py3-xdg/pkg-descr
@@ -0,0 +1,11 @@
+A python library to access freedesktop.org standards.
+
+Currently supported are:
+ o Base Directory Specification
+ o Menu Specification
+ o Desktop Entry Specification
+ o Icon Theme Specification
+ o Recent File Spec
+ o Shared-MIME-Database Specification
+
+WWW: http://freedesktop.org/Software/pyxdg