summaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-08-20 10:12:45 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-08-20 10:12:45 +0000
commitb5cfea04707c22c96ca0f0628b8ade3f7d99193d (patch)
tree818a440fff28bd7cc71a44592e49b0f323ab2230 /devel
parent2a7de8b29fbf6ab4526a2fee2cf0eba293baf306 (diff)
downloadfreebsd-ports-b5cfea04707c22c96ca0f0628b8ade3f7d99193d.zip
- update to 0.8.7
Diffstat (limited to 'devel')
-rw-r--r--devel/pkgconf/Makefile4
-rw-r--r--devel/pkgconf/distinfo4
-rw-r--r--devel/pkgconf/files/patch-fail-on-missing_and_keep-backslash63
3 files changed, 4 insertions, 67 deletions
diff --git a/devel/pkgconf/Makefile b/devel/pkgconf/Makefile
index 9f6747623a29..ac77914e3a9b 100644
--- a/devel/pkgconf/Makefile
+++ b/devel/pkgconf/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= pkgconf
-PORTVERSION= 0.8.6
+PORTVERSION= 0.8.7
CATEGORIES= devel
-MASTER_SITES= http://nenolod.net/~nenolod/distfiles/
+MASTER_SITES= http://tortois.es/~nenolod/distfiles/
MAINTAINER= bapt@FreeBSD.org
COMMENT= pkg-config compatible utility which does not depend on glib
diff --git a/devel/pkgconf/distinfo b/devel/pkgconf/distinfo
index 4c0935eb3364..f7ffe84103c2 100644
--- a/devel/pkgconf/distinfo
+++ b/devel/pkgconf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pkgconf-0.8.6.tar.bz2) = 05a6f88b7654b93335f9dc292e5e6141d63d43a526337f16c873e301eb5a77d4
-SIZE (pkgconf-0.8.6.tar.bz2) = 79582
+SHA256 (pkgconf-0.8.7.tar.bz2) = ee075e9d601e5d8582085fc662a619b34643550383c75f6aef37016ab99371f9
+SIZE (pkgconf-0.8.7.tar.bz2) = 79823
diff --git a/devel/pkgconf/files/patch-fail-on-missing_and_keep-backslash b/devel/pkgconf/files/patch-fail-on-missing_and_keep-backslash
deleted file mode 100644
index a1ca84a5a98a..000000000000
--- a/devel/pkgconf/files/patch-fail-on-missing_and_keep-backslash
+++ /dev/null
@@ -1,63 +0,0 @@
-diff --git argvsplit.c argvsplit.c
-index cbfb55d..e9ed7b6 100644
---- argvsplit.c
-+++ argvsplit.c
-@@ -92,6 +92,8 @@ pkg_argv_split(const char *src, int *argc, char ***argv)
- free(argv);
- free(buf);
- return -1;
-+ } else {
-+ *dst_iter++ = '\\';
- }
- default:
- *dst_iter++ = *src_iter;
-diff --git fileio.c fileio.c
-index f1247c9..2c6b9e9 100644
---- fileio.c
-+++ fileio.c
-@@ -73,7 +73,14 @@ pkg_fgetline(char *line, size_t size, FILE *stream)
- break;
- }
- else
-+ {
-+ if (quoted) {
-+ *s++ = '\\';
-+ quoted = false;
-+ }
- *s++ = c;
-+ }
-+
- }
-
- *s = '\0';
-diff --git tests/lib1/quotes.pc tests/lib1/quotes.pc
-new file mode 100644
-index 0000000..1aee256
---- /dev/null
-+++ tests/lib1/quotes.pc
-@@ -0,0 +1,10 @@
-+prefix=/usr
-+exec_prefix=${prefix}
-+libdir=${prefix}/lib
-+includedir=${prefix}/include
-+
-+Name: quotes
-+Description: A testing pkg-config file
-+Version: 1.2.3
-+Libs: -L${libdir} -lfoo
-+Cflags: -DQUOTED=\"bla\"
-diff --git tests/run.sh.in tests/run.sh.in
-index 231af22..ee50b3d 100644
---- tests/run.sh.in
-+++ tests/run.sh.in
-@@ -167,6 +167,10 @@ run_test "PKG_CONFIG_PATH=${selfdir}/lib1 ${1} --max-version 2.0 'foo '; echo \$
- run_test "PKG_CONFIG_PATH=${selfdir}/lib1 ${1} --cflags missing-require; echo \$?" \
- '1'
-
-+# test quoted #35
-+run_test "PKG_CONFIG_PATH=${selfdir}/lib1 ${1} --cflags quotes" \
-+ "-DQUOTED=\\\"bla\\\""
-+
- # 10) tests for internal getopt implementation with options at the end
- if [ "x@STRICT_MODE@" = "xno" ]; then
- run_test "PKG_CONFIG_PATH=${selfdir}/lib1 ${1} foo --libs" \