summaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2016-10-20 15:16:44 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2016-10-20 15:16:44 +0000
commit790a14405dcdbab432aa1103d5eb1b8a4ea743f8 (patch)
tree18a51bf2c176f7d2feb96d562c650e473069f1cb /devel
parent95e78bcb50c62b3a82d226bd935b143f823f9bfc (diff)
downloadfreebsd-ports-790a14405dcdbab432aa1103d5eb1b8a4ea743f8.zip
Add py-oslo.cache 1.14.0, cache storage for OpenStack projects.
PR: 213542 Submitted by: Alexander Nusov <alexander.nusov@nfvexpress.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-oslo.cache/Makefile26
-rw-r--r--devel/py-oslo.cache/distinfo3
-rw-r--r--devel/py-oslo.cache/pkg-descr6
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9c9f9ac9dc01..ce32d27b9ba5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4329,6 +4329,7 @@
SUBDIR += py-ordereddict
SUBDIR += py-os-client-config
SUBDIR += py-osc-lib
+ SUBDIR += py-oslo.cache
SUBDIR += py-oslo.concurrency
SUBDIR += py-oslo.config
SUBDIR += py-oslo.context
diff --git a/devel/py-oslo.cache/Makefile b/devel/py-oslo.cache/Makefile
new file mode 100644
index 000000000000..9cc0a32c3f2f
--- /dev/null
+++ b/devel/py-oslo.cache/Makefile
@@ -0,0 +1,26 @@
+# Created by: Alexander Nusov <alexander.nusov@nfvexpress.com>
+# $FreeBSD$
+
+PORTNAME= oslo.cache
+PORTVERSION= 1.14.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= alexander.nusov@nfvexpress.com
+COMMENT= Cache storage for OpenStack projects
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.6:devel/py-pbr
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}oslo.utils>=3.16.0:devel/py-oslo.utils \
+ ${PYTHON_PKGNAMEPREFIX}oslo.log>=1.14.0:devel/py-oslo.log \
+ ${PYTHON_PKGNAMEPREFIX}oslo.i18n>=2.1.0:devel/py-oslo.i18n \
+ ${PYTHON_PKGNAMEPREFIX}oslo.config>=3.14.0:devel/py-oslo.config \
+ ${PYTHON_PKGNAMEPREFIX}dogpile.cache>=0.6.1:devel/py-dogpile.cache
+
+NO_ARCH= yes
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-oslo.cache/distinfo b/devel/py-oslo.cache/distinfo
new file mode 100644
index 000000000000..0456fe23964a
--- /dev/null
+++ b/devel/py-oslo.cache/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1476297283
+SHA256 (oslo.cache-1.14.0.tar.gz) = 3ba84b421f80c5a6609789cf17b1da86aab465a96e68298620e839fafec3f0be
+SIZE (oslo.cache-1.14.0.tar.gz) = 45780
diff --git a/devel/py-oslo.cache/pkg-descr b/devel/py-oslo.cache/pkg-descr
new file mode 100644
index 000000000000..07fc1db57948
--- /dev/null
+++ b/devel/py-oslo.cache/pkg-descr
@@ -0,0 +1,6 @@
+oslo.cache aims to provide a generic caching mechanism for OpenStack projects
+by wrapping the dogpile.cache library. The dogpile.cache library provides
+support memoization, key value storage and interfaces to common caching
+backends such as Memcached.
+
+WWW: https://pypi.python.org/pypi/oslo.cache