summaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-07-15 20:17:13 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-07-15 20:17:13 +0000
commit678c33f017095d8e9f960b825ce0de4b6e6a17a3 (patch)
treed641437ed826c02a35c3bc8771fc23c8177d610c /devel
parent0b8062d39e858091a6a80fc8a7e9cdca5a8b2bfe (diff)
downloadfreebsd-ports-678c33f017095d8e9f960b825ce0de4b6e6a17a3.zip
- Add devel/p5-Minilla
Minilla is a CPAN module authoring tool. Minilla provides 'minil' command for authorizing a CPAN distribution. The repository created and managed by Minilla is git install ready, and cpan of course. Minilla is built on only few small libraries. You can install Minilla without a huge list of dependencies to heavy modules. Conventions: module written in Pure Perl are located in lib/; executable file is in script/ directory, if any; module is maintained with Git and git ls-files matches with what you will release; module has a static list of prerequisites that can be described in cpanfile; has a Changes file. WWW: http://search.cpan.org/dist/Minilla/ PR: 200515 Submitted by: oklaspec@gmail.com
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile3
-rw-r--r--devel/p5-Minilla/Makefile67
-rw-r--r--devel/p5-Minilla/distinfo2
-rw-r--r--devel/p5-Minilla/pkg-descr10
-rw-r--r--devel/p5-Minilla/pkg-plist62
5 files changed, 143 insertions, 1 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 54aead8ee61c..0b5597d81afd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2496,6 +2496,7 @@
SUBDIR += p5-Metabase-Fact
SUBDIR += p5-Method-Alias
SUBDIR += p5-Method-Signatures-Simple
+ SUBDIR += p5-Minilla
SUBDIR += p5-Minion
SUBDIR += p5-Mixin-Linewise
SUBDIR += p5-Mknod
@@ -4591,9 +4592,9 @@
SUBDIR += rubygem-deprecated2
SUBDIR += rubygem-descendants_tracker
SUBDIR += rubygem-devise
- SUBDIR += rubygem-devise-rails4
SUBDIR += rubygem-devise-async
SUBDIR += rubygem-devise-async-rails4
+ SUBDIR += rubygem-devise-rails4
SUBDIR += rubygem-directory_watcher
SUBDIR += rubygem-ditz
SUBDIR += rubygem-docile
diff --git a/devel/p5-Minilla/Makefile b/devel/p5-Minilla/Makefile
new file mode 100644
index 000000000000..82981b6ef0db
--- /dev/null
+++ b/devel/p5-Minilla/Makefile
@@ -0,0 +1,67 @@
+# Created by: Serguei Okladnikov <oklaspec@gmail.com>
+# $FreeBSD$
+# Date created: 2015-05-28
+
+PORTNAME= Minilla
+PORTVERSION= 2.4.1
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR=CPAN:TOKUHIROM
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= oklaspec@gmail.com
+COMMENT= CPAN module authoring tool
+
+BUILD_DEPENDS= git>=0:${PORTSDIR}/devel/git \
+ tree>=0:${PORTSDIR}/sysutils/tree \
+ p5-App-cpanminus>=1.6902:${PORTSDIR}/devel/p5-App-cpanminus \
+ p5-Archive-Tar>=1.60:${PORTSDIR}/archivers/p5-Archive-Tar \
+ p5-CPAN-Meta>=2.132830:${PORTSDIR}/devel/p5-CPAN-Meta \
+ p5-Config-Identity>=0:${PORTSDIR}/devel/p5-Config-Identity \
+ p5-Data-Section-Simple>=0.04:${PORTSDIR}/devel/p5-Data-Section-Simple \
+ p5-ExtUtils-Manifest>=1.54:${PORTSDIR}/devel/p5-ExtUtils-Manifest \
+ p5-CPAN-Uploader>=0:${PORTSDIR}/devel/p5-CPAN-Uploader \
+ p5-Class-XSAccessor>=0:${PORTSDIR}/devel/p5-Class-XSAccessor \
+ p5-Config-Identity>=0:${PORTSDIR}/devel/p5-Config-Identity \
+ p5-Devel-CheckBin>=0:${PORTSDIR}/devel/p5-Devel-CheckBin \
+ p5-Devel-GlobalDestruction>=0:${PORTSDIR}/devel/p5-Devel-GlobalDestruction \
+ p5-File-Copy-Recursive>=0:${PORTSDIR}/devel/p5-File-Copy-Recursive \
+ p5-File-Which>=0:${PORTSDIR}/sysutils/p5-File-Which \
+ p5-File-pushd>=0:${PORTSDIR}/devel/p5-File-pushd \
+ p5-Getopt-Long>=2.36:${PORTSDIR}/devel/p5-Getopt-Long \
+ p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
+ p5-Module-Build-Tiny>=0:${PORTSDIR}/devel/p5-Module-Build-Tiny \
+ p5-Module-CPANfile>=0.9025:${PORTSDIR}/devel/p5-Module-CPANfile \
+ p5-Module-Metadata>=1.000012:${PORTSDIR}/devel/p5-Module-Metadata \
+ p5-Module-Runtime>=0:${PORTSDIR}/devel/p5-Module-Runtime \
+ p5-Moo>=1.001:${PORTSDIR}/devel/p5-Moo \
+ p5-Pod-Markdown>=1.322:${PORTSDIR}/textproc/p5-Pod-Markdown \
+ p5-TOML>=0:${PORTSDIR}/textproc/p5-TOML \
+ p5-Term-ANSIColor>=0:${PORTSDIR}/devel/p5-Term-ANSIColor \
+ p5-Text-MicroTemplate>=0.20:${PORTSDIR}/textproc/p5-Text-MicroTemplate \
+ p5-Time-Piece>=1.16:${PORTSDIR}/devel/p5-Time-Piece \
+ p5-Try-Tiny>=0:${PORTSDIR}/lang/p5-Try-Tiny \
+ p5-Role-Tiny>=0:${PORTSDIR}/devel/p5-Role-Tiny \
+ p5-Test-Output>=0:${PORTSDIR}/devel/p5-Test-Output \
+ p5-Test-Requires>=0:${PORTSDIR}/devel/p5-Test-Requires \
+ p5-Test-Harness>=0:${PORTSDIR}/devel/p5-Test-Harness \
+ p5-strictures>=0:${PORTSDIR}/devel/p5-strictures \
+ p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Software-License>=0:${PORTSDIR}/misc/p5-Software-License \
+ p5-Version-Next>=0:${PORTSDIR}/textproc/p5-Version-Next
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
+
+USES= perl5
+USE_PERL5= modbuild
+NO_ARCH= yes
+
+regression-test: build
+ @test ! -e ${WRKDIR}/.gitconfig && \
+ ${SETENV} ${MAKE_ENV} git config --global user.name "ports-test" && \
+ ${SETENV} ${MAKE_ENV} git config --global user.email "${USER}@${HOST}" || \
+ true
+ @cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${PERL5} ${PL_BUILD} ${MAKE_ARGS} test
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Minilla/distinfo b/devel/p5-Minilla/distinfo
new file mode 100644
index 000000000000..f84f9882ec97
--- /dev/null
+++ b/devel/p5-Minilla/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Minilla-v2.4.1.tar.gz) = e748642bf97ce87ec76c807491f0d03c27f0c1780d4619d982a719bc1a41d725
+SIZE (Minilla-v2.4.1.tar.gz) = 81986
diff --git a/devel/p5-Minilla/pkg-descr b/devel/p5-Minilla/pkg-descr
new file mode 100644
index 000000000000..9da39bdcff1f
--- /dev/null
+++ b/devel/p5-Minilla/pkg-descr
@@ -0,0 +1,10 @@
+Minilla is a CPAN module authoring tool. Minilla provides 'minil' command for
+authorizing a CPAN distribution. The repository created and managed by Minilla
+is git install ready, and cpan of course. Minilla is built on only few small
+libraries. You can install Minilla without a huge list of dependencies to
+heavy modules. Conventions: module written in Pure Perl are located in lib/;
+executable file is in script/ directory, if any; module is maintained with
+Git and git ls-files matches with what you will release; module has a static
+list of prerequisites that can be described in cpanfile; has a Changes file.
+
+WWW: http://search.cpan.org/dist/Minilla/
diff --git a/devel/p5-Minilla/pkg-plist b/devel/p5-Minilla/pkg-plist
new file mode 100644
index 000000000000..4a4a2931d9b0
--- /dev/null
+++ b/devel/p5-Minilla/pkg-plist
@@ -0,0 +1,62 @@
+bin/minil
+%%SITE_PERL%%/Minilla.pm
+%%SITE_PERL%%/Minilla/CLI.pm
+%%SITE_PERL%%/Minilla/CLI/Build.pm
+%%SITE_PERL%%/Minilla/CLI/Clean.pm
+%%SITE_PERL%%/Minilla/CLI/Dist.pm
+%%SITE_PERL%%/Minilla/CLI/Help.pm
+%%SITE_PERL%%/Minilla/CLI/Install.pm
+%%SITE_PERL%%/Minilla/CLI/Migrate.pm
+%%SITE_PERL%%/Minilla/CLI/New.pm
+%%SITE_PERL%%/Minilla/CLI/Release.pm
+%%SITE_PERL%%/Minilla/CLI/Run.pm
+%%SITE_PERL%%/Minilla/CLI/Test.pm
+%%SITE_PERL%%/Minilla/Errors.pm
+%%SITE_PERL%%/Minilla/FileGatherer.pm
+%%SITE_PERL%%/Minilla/Git.pm
+%%SITE_PERL%%/Minilla/Gitignore.pm
+%%SITE_PERL%%/Minilla/License/Perl_5.pm
+%%SITE_PERL%%/Minilla/License/Unknown.pm
+%%SITE_PERL%%/Minilla/Logger.pm
+%%SITE_PERL%%/Minilla/Metadata.pm
+%%SITE_PERL%%/Minilla/Migrate.pm
+%%SITE_PERL%%/Minilla/ModuleMaker/ExtUtilsMakeMaker.pm
+%%SITE_PERL%%/Minilla/ModuleMaker/ModuleBuild.pm
+%%SITE_PERL%%/Minilla/ModuleMaker/ModuleBuildTiny.pm
+%%SITE_PERL%%/Minilla/Profile/Base.pm
+%%SITE_PERL%%/Minilla/Profile/Default.pm
+%%SITE_PERL%%/Minilla/Profile/ExtUtilsMakeMaker.pm
+%%SITE_PERL%%/Minilla/Profile/ModuleBuild.pm
+%%SITE_PERL%%/Minilla/Profile/ModuleBuildTiny.pm
+%%SITE_PERL%%/Minilla/Profile/XS.pm
+%%SITE_PERL%%/Minilla/Project.pm
+%%SITE_PERL%%/Minilla/Release/BumpVersion.pm
+%%SITE_PERL%%/Minilla/Release/CheckChanges.pm
+%%SITE_PERL%%/Minilla/Release/CheckOrigin.pm
+%%SITE_PERL%%/Minilla/Release/CheckUntrackedFiles.pm
+%%SITE_PERL%%/Minilla/Release/Commit.pm
+%%SITE_PERL%%/Minilla/Release/DistTest.pm
+%%SITE_PERL%%/Minilla/Release/MakeDist.pm
+%%SITE_PERL%%/Minilla/Release/RegenerateFiles.pm
+%%SITE_PERL%%/Minilla/Release/RewriteChanges.pm
+%%SITE_PERL%%/Minilla/Release/RunHooks.pm
+%%SITE_PERL%%/Minilla/Release/Tag.pm
+%%SITE_PERL%%/Minilla/Release/UploadToCPAN.pm
+%%SITE_PERL%%/Minilla/ReleaseTest.pm
+%%SITE_PERL%%/Minilla/Tutorial.pod
+%%SITE_PERL%%/Minilla/Util.pm
+%%SITE_PERL%%/Minilla/WorkDir.pm
+%%SITE_PERL%%/Module/BumpVersion.pm
+%%PERL5_MAN3%%/Minilla.3.gz
+%%PERL5_MAN3%%/Minilla::CLI::Build.3.gz
+%%PERL5_MAN3%%/Minilla::CLI::Clean.3.gz
+%%PERL5_MAN3%%/Minilla::CLI::Dist.3.gz
+%%PERL5_MAN3%%/Minilla::CLI::Help.3.gz
+%%PERL5_MAN3%%/Minilla::CLI::Install.3.gz
+%%PERL5_MAN3%%/Minilla::CLI::Migrate.3.gz
+%%PERL5_MAN3%%/Minilla::CLI::New.3.gz
+%%PERL5_MAN3%%/Minilla::CLI::Release.3.gz
+%%PERL5_MAN3%%/Minilla::CLI::Run.3.gz
+%%PERL5_MAN3%%/Minilla::CLI::Test.3.gz
+%%PERL5_MAN3%%/Minilla::Profile::Base.3.gz
+%%PERL5_MAN3%%/Minilla::Tutorial.3.gz