summaryrefslogtreecommitdiff
path: root/devel/py-jira/Makefile
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2020-05-11 23:51:58 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2020-05-11 23:51:58 +0000
commit75a5f7f0762c1039d83da77f699eed5f26998731 (patch)
treed08289c54ff9db139f0a17e3129c69e9b0ae39b1 /devel/py-jira/Makefile
parent91dd9e62375f38dcfa9e2214347d9837b18c8810 (diff)
downloadfreebsd-ports-75a5f7f0762c1039d83da77f699eed5f26998731.zip
Update Sphinx
- Repocopy textproc/py-sphinx to textproc/py-sphinx18 Update it to 1.8.5 (latest version from 1.8.X). This version supports Python 2 and 3. Add test target. - textproc/py-sphinx: Update to 3.0.2 Python 3 only (3.5+). Add test target. - Mk/Uses/python.mk: Add PY_SPHINX Shared macro to use with flavors and not break ports with USES=python (all versions). Python >=3.5 --> textproc/py-sphinx (v3.0.2) Python < 3.5 --> textproc/py-sphinx18 (v1.8.5) All ports that uses sphinx were changed to use the new variable ${PY_SPHINX} in the dependency line, exceptions: * Ports that fails to build with sphinx 3.0.2 because of code. They are pointing to textproc/py-sphinx18 directly. There aren't many ports. * Ports that doesn't know Python flavors. - Add several patches to fix Sphinx consumers The most common issues are related with pkg-plist, the output files from Sphinx changes between versions, keep this dynamically is the better approach. This will save time in future sphinx updates. PR: 245629 Exp-run by: antoine
Diffstat (limited to 'devel/py-jira/Makefile')
-rw-r--r--devel/py-jira/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/py-jira/Makefile b/devel/py-jira/Makefile
index cbff9b31cb34..e1fe8da0c491 100644
--- a/devel/py-jira/Makefile
+++ b/devel/py-jira/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pbr>=1.9:devel/py-pbr@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}sphinx>=1.6.5:textproc/py-sphinx@${PY_FLAVOR}
+ ${PY_SPHINX}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=1.2.3:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests-oauthlib>=0.3.3:www/py-requests-oauthlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tlslite>=0.4.4:security/py-tlslite@${PY_FLAVOR} \