summaryrefslogtreecommitdiff
path: root/devel/glade2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-06-11 16:07:59 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-06-11 16:07:59 +0000
commite3bf748e077908798752548a3eedb16a54244f0d (patch)
tree41a11afb38fa4e0b4ad5d509482ae27a73e5e30f /devel/glade2/Makefile
parent9fefb173c1ffdfc9143c80d50d41df2ea0103db5 (diff)
downloadfreebsd-ports-e3bf748e077908798752548a3eedb16a54244f0d.zip
Add glade2 and GNOME DB 2 to the tree. These are still beta versions of the
software, but it gives GNOME 2 testers some more stuff to play with.
Diffstat (limited to 'devel/glade2/Makefile')
-rw-r--r--devel/glade2/Makefile31
1 files changed, 18 insertions, 13 deletions
diff --git a/devel/glade2/Makefile b/devel/glade2/Makefile
index d8e10f056cac..e90b5fa35bd5 100644
--- a/devel/glade2/Makefile
+++ b/devel/glade2/Makefile
@@ -1,31 +1,36 @@
-# New ports collection makefile for: glade
-# Date created: 29 June 1998
-# Whom: Dom Mitchell <dom@myrddin.demon.co.uk>
+# New ports collection makefile for: glade2
+# Date created: 02 June 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= glade
-PORTVERSION= 0.6.4
+PORTNAME= glade2
+PORTVERSION= 1.1.0
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= stable/sources/glade
+MASTER_SITE_SUBDIR= pre-gnome2/sources/glade
+DISTNAME= glade-${PORTVERSION}
+DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
+LIB_DEPENDS= gnomedb-2.1:${PORTSDIR}/databases/libgnomedb \
+ gnomeprintui-2.0:${PORTSDIR}/x11-toolkits/libgnomeprintui
+
+USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOME= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-bonobo --enable-gnome-db
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/libs"
+ LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
- s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
- s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'