summaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-12-30 20:13:46 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-12-30 20:13:46 +0000
commitb28f4972855f1b355b5b156ffca59f4135e0e4c8 (patch)
treef8d16b26e7f6882796704c78c3316de2d96ca435 /deskutils
parent83b4f7b7528232f46a80c28193ac942e4e8c2f83 (diff)
downloadfreebsd-ports-b28f4972855f1b355b5b156ffca59f4135e0e4c8.zip
Update cinnamon to 2.4, this should fix [1] and [2].
Update totem to 3.14 now that we have gstreamer 1.4 and minor gnome updates. Update evolution suite to 3.12.9. Make sure gtk30 pulls in adwait-icon-theme, since it now the default theme [3]. PR: 195290 [1], 195289 [2], 195455 [3] Obtained from: gnome devel repo
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/california/Makefile6
-rw-r--r--deskutils/california/distinfo4
-rw-r--r--deskutils/california/pkg-plist19
-rw-r--r--deskutils/gnote/Makefile2
-rw-r--r--deskutils/gnote/distinfo4
-rw-r--r--deskutils/nemo-extensions/Makefile14
-rw-r--r--deskutils/nemo-extensions/distinfo4
7 files changed, 36 insertions, 17 deletions
diff --git a/deskutils/california/Makefile b/deskutils/california/Makefile
index 1a576592569c..6c3332dad966 100644
--- a/deskutils/california/Makefile
+++ b/deskutils/california/Makefile
@@ -3,7 +3,7 @@
# $MCom: ports/trunk/deskutils/california/Makefile 20027 2014-10-28 13:45:13Z gusi $
PORTNAME= california
-PORTVERSION= 0.2.0
+PORTVERSION= 0.3.0
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -11,12 +11,14 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Calendar client for GNOME 3
-BUILD_DEPENDS= itstool:${PORTSDIR}/textproc/itstool
+BUILD_DEPENDS= itstool:${PORTSDIR}/textproc/itstool \
+ xdg-open:${PORTSDIR}/devel/xdg-utils
LIB_DEPENDS= libwebkitgtk-3.0.so:${PORTSDIR}/www/webkit-gtk3 \
libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
libgee-0.8.so:${PORTSDIR}/devel/libgee \
libgdata.so:${PORTSDIR}/devel/libgdata \
libgoa-1.0.so:${PORTSDIR}/net/gnome-online-accounts
+RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
USES= desktop-file-utils gettext gmake libtool pathfix \
pkgconfig tar:xz
diff --git a/deskutils/california/distinfo b/deskutils/california/distinfo
index 1dc85cfe4bfe..d2ec6a18289b 100644
--- a/deskutils/california/distinfo
+++ b/deskutils/california/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome3/california-0.2.0.tar.xz) = 8d901b28a24a10852cc0b2e5f5156430ce88dca1014c6b7cbcdb5813d9ad299d
-SIZE (gnome3/california-0.2.0.tar.xz) = 872068
+SHA256 (gnome3/california-0.3.0.tar.xz) = 8a0aeb7288237ec70964e0e2acef9d9d961f8971c47edf2331cf5ddc88aa354f
+SIZE (gnome3/california-0.3.0.tar.xz) = 986384
diff --git a/deskutils/california/pkg-plist b/deskutils/california/pkg-plist
index 4dafc6591ba5..ffadfb8a09cf 100644
--- a/deskutils/california/pkg-plist
+++ b/deskutils/california/pkg-plist
@@ -24,6 +24,22 @@ share/help/C/california/index.page
share/help/C/california/legal.xml
share/help/C/california/media/california-screenshot.png
share/help/C/california/media/x-office-calendar.png
+share/help/ca/california/cal-add-calendar.page
+share/help/ca/california/cal-change-view.page
+share/help/ca/california/cal-event-edit.page
+share/help/ca/california/cal-event-quick-add.page
+share/help/ca/california/cal-event-remove.page
+share/help/ca/california/cal-hide-a-calendar.page
+share/help/ca/california/cal-open-calendar-list.xml
+share/help/ca/california/cal-quickstart.page
+share/help/ca/california/cal-remove-calendar.page.stub
+share/help/ca/california/cal-rename-calendar.page
+share/help/ca/california/cal-shortcut-keys.page
+share/help/ca/california/gnome-help.sct
+share/help/ca/california/index.page
+share/help/ca/california/legal.xml
+share/help/ca/california/media/california-screenshot.png
+share/help/ca/california/media/x-office-calendar.png
share/locale/ca/LC_MESSAGES/california.mo
share/locale/cs/LC_MESSAGES/california.mo
share/locale/de/LC_MESSAGES/california.mo
@@ -34,8 +50,11 @@ share/locale/gl/LC_MESSAGES/california.mo
share/locale/he/LC_MESSAGES/california.mo
share/locale/hu/LC_MESSAGES/california.mo
share/locale/id/LC_MESSAGES/california.mo
+share/locale/kk/LC_MESSAGES/california.mo
share/locale/pl/LC_MESSAGES/california.mo
+share/locale/pt/LC_MESSAGES/california.mo
share/locale/pt_BR/LC_MESSAGES/california.mo
+share/locale/ru/LC_MESSAGES/california.mo
share/locale/sl/LC_MESSAGES/california.mo
share/locale/sr/LC_MESSAGES/california.mo
share/locale/sr@latin/LC_MESSAGES/california.mo
diff --git a/deskutils/gnote/Makefile b/deskutils/gnote/Makefile
index f0f3319e9fb0..4c755c7d87c7 100644
--- a/deskutils/gnote/Makefile
+++ b/deskutils/gnote/Makefile
@@ -3,7 +3,7 @@
# $MCom: ports/trunk/deskutils/gnote/Makefile 19997 2014-10-19 18:15:03Z gusi $
PORTNAME= gnote
-PORTVERSION= 3.14.0
+PORTVERSION= 3.14.1
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME
diff --git a/deskutils/gnote/distinfo b/deskutils/gnote/distinfo
index 79e8f0f32bca..4bd0c45de0dd 100644
--- a/deskutils/gnote/distinfo
+++ b/deskutils/gnote/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnote-3.14.0.tar.xz) = a2df3639a29e14cd1e3a887b743d3dd471c5ef2c138fd967a4d531ffb0911156
-SIZE (gnote-3.14.0.tar.xz) = 3139948
+SHA256 (gnote-3.14.1.tar.xz) = d4c1338fca37fb0b107b7491a1b033c1d9dc410d5448dbc5fc8592a094b07949
+SIZE (gnote-3.14.1.tar.xz) = 3140812
diff --git a/deskutils/nemo-extensions/Makefile b/deskutils/nemo-extensions/Makefile
index 99c63411f530..8aa7bb7081bd 100644
--- a/deskutils/nemo-extensions/Makefile
+++ b/deskutils/nemo-extensions/Makefile
@@ -1,17 +1,15 @@
# Created by: Gustau Perez i Querol <gustau.perez@gmail.com>
# $FreeBSD$
-# $MCom: ports/trunk/deskutils/nemo-extensions/Makefile 19704 2014-05-28 09:16:09Z gusi $
PORTNAME= nemo-extensions
-PORTVERSION= 2.2.0
-PORTREVISION= 2
-CATEGORIES= deskutils gnome
+PORTVERSION= 2.4.0
+CATEGORIES= x11-fm gnome
DIST_SUBDIR= gnome3
MAINTAINER= gustau.perez@gmail.com
COMMENT= File manager extensions for the Cinnamon desktop
-BUILD_DEPENDS= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme \
+BUILD_DEPENDS= gnome-icon-theme>=0:${PORTSDIR}/misc/gnome-icon-theme \
gtkdocize:${PORTSDIR}/textproc/gtk-doc \
rst2html:${PORTSDIR}/textproc/py-docutils \
automake>=0:${PORTSDIR}/devel/automake \
@@ -31,13 +29,13 @@ LIB_DEPENDS= libexif.so:${PORTSDIR}/graphics/libexif \
libclutter-gst-2.0.so:${PORTSDIR}/multimedia/clutter-gst \
libmusicbrainz5.so:${PORTSDIR}/audio/libmusicbrainz5 \
libwebkitgtk-3.0.so:${PORTSDIR}/www/webkit-gtk3
-RUN_DEPENDS= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme \
- ${LOCALBASE}/libdata/pkgconfig/gsettings-desktop-schemas.pc:${PORTSDIR}/devel/gsettings-desktop-schemas
+RUN_DEPENDS= gnome-icon-theme>=0:${PORTSDIR}/misc/gnome-icon-theme \
+ gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
USE_GITHUB= yes
GH_ACCOUNT= linuxmint
GH_PROJECT= nemo-extensions
-GH_COMMIT= 54f4d94
+GH_COMMIT= 6c8ec3a
GH_TAGNAME= ${GH_COMMIT}
USE_GNOME= gconf2 gnomeprefix gnomedocutils gtksourceview3 intlhack \
diff --git a/deskutils/nemo-extensions/distinfo b/deskutils/nemo-extensions/distinfo
index 90cdb7632ce7..1c4024a6a9fa 100644
--- a/deskutils/nemo-extensions/distinfo
+++ b/deskutils/nemo-extensions/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome3/nemo-extensions-2.2.0.tar.gz) = 5e91a1c9083e3e38121059ee0fcafbb3c39d28d516dc2a1335947c6141b2dc99
-SIZE (gnome3/nemo-extensions-2.2.0.tar.gz) = 2621485
+SHA256 (gnome3/nemo-extensions-2.4.0.tar.gz) = 96ac6c048cdcf3ee54259da3d9ec8e68db348d09e64ef491ab36d34202eed836
+SIZE (gnome3/nemo-extensions-2.4.0.tar.gz) = 3616122