summaryrefslogtreecommitdiff
path: root/deskutils/timer-applet/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-01-29 03:11:13 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-01-29 03:11:13 +0000
commit4d91f6cc2cd673e2ce4910accdd9ed55d7db8fff (patch)
tree6620a7f16469bc88d84c536ce31066b5cda5b9d4 /deskutils/timer-applet/Makefile
parent39242afef0682e453ff1d8a680ba6a6ee8e0b793 (diff)
downloadfreebsd-ports-4d91f6cc2cd673e2ce4910accdd9ed55d7db8fff.zip
Update to 1.2
Diffstat (limited to 'deskutils/timer-applet/Makefile')
-rw-r--r--deskutils/timer-applet/Makefile18
1 files changed, 3 insertions, 15 deletions
diff --git a/deskutils/timer-applet/Makefile b/deskutils/timer-applet/Makefile
index 56993711f26a..dc9a43a5dc5c 100644
--- a/deskutils/timer-applet/Makefile
+++ b/deskutils/timer-applet/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= timer-applet
-PORTVERSION= 1.1.1
-PORTREVISION= 1
+PORTVERSION= 1.2
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= timerapplet
@@ -20,29 +19,18 @@ RUN_DEPENDS= ${X11BASE}/share/gnome/sounds/gtk-events/clicked.wav:${PORTSDIR}/au
USE_GNOME= gnomehack gnomeprefix gnomepanel intlhack
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --bindir=${PREFIX}/libexec # applets belong to libexec
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GCONF_SCHEMAS= timer-applet.schemas
INSTALLS_OMF= yes
-OMFDIR= ${PREFIX}/share/gnome/omf/${PORTNAME}
post-patch:
@${REINPLACE_CMD} -e \
- 's|/usr/share/pixmaps/|${PREFIX}/share/gnome/pixmaps/|; \
- s|location="timer-applet"|location="${PREFIX}/libexec/timer-applet"|' \
- ${WRKSRC}/GNOME_TimerApplet.server.in
+ 's|/usr/share/pixmaps/|${PREFIX}/share/gnome/pixmaps/|' \
+ ${WRKSRC}/GNOME_TimerApplet.server.in.in
@${REINPLACE_CMD} -e \
's|$$(datadir)/sounds|${X11BASE}/share/gnome/sounds|' \
${WRKSRC}/src/Makefile.in
- @${MKDIR} ${WRKSRC}/omf-install
-
-post-install:
- ${MKDIR} ${OMFDIR}
-.for lang in C fr
- ${INSTALL_DATA} ${WRKSRC}/omf-install/${PORTNAME}-${lang}.omf ${OMFDIR}
- -scrollkeeper-install -q ${OMFDIR}/${PORTNAME}-${lang}.omf
-.endfor
.include <bsd.port.mk>