summaryrefslogtreecommitdiff
path: root/deskutils/timer-applet/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-05 18:22:07 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-05 18:22:07 +0000
commit0203a5397b1d3cca6a6d1d98e180d30f16728066 (patch)
tree6be69eb26919469bae0356d0c65234064f06a104 /deskutils/timer-applet/Makefile
parentc3eb2392c8f1a53e57398a65a6cbc6f11cee96e8 (diff)
downloadfreebsd-ports-0203a5397b1d3cca6a6d1d98e180d30f16728066.zip
- Update to 0.5.1
PR: ports/77145 Submitted by: Jean-Yves Lefort <jylefort@brutele.be> (maintainer)
Diffstat (limited to 'deskutils/timer-applet/Makefile')
-rw-r--r--deskutils/timer-applet/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/deskutils/timer-applet/Makefile b/deskutils/timer-applet/Makefile
index 91897ae2b6f6..bbde50ea5360 100644
--- a/deskutils/timer-applet/Makefile
+++ b/deskutils/timer-applet/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= timer-applet
-PORTVERSION= 0.4
+PORTVERSION= 0.5.1
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= timerapplet
@@ -18,6 +18,7 @@ RUN_DEPENDS= ${X11BASE}/share/gnome/sounds/gtk-events/clicked.wav:${PORTSDIR}/au
USE_GNOME= gnomehack gnomeprefix gnomepanel
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --bindir=${PREFIX}/libexec # applets belong to libexec
USE_X_PREFIX= yes
USE_REINPLACE= yes
@@ -27,7 +28,8 @@ post-patch:
's|/usr/share/pixmaps/||; \
s|location="timer-applet"|location="${PREFIX}/libexec/timer-applet"|' \
${WRKSRC}/timer-applet.server
- @${REINPLACE_CMD} -e 's|/usr/share/sounds|${X11BASE}/share/gnome/sounds|' \
- ${WRKSRC}/src/timer-applet.c
+ @${REINPLACE_CMD} -e \
+ 's|$$(datadir)/sounds|${X11BASE}/share/gnome/sounds|' \
+ ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>