summaryrefslogtreecommitdiff
path: root/deskutils/py-calendar_cli/Makefile
diff options
context:
space:
mode:
authorcos <cos>2024-03-19 15:25:02 +0100
committercos <cos>2024-03-19 15:25:02 +0100
commit6ec9afdc4a9fdfbe055dbc9c371b51d3d69db8dc (patch)
treea7186f6aa54e78ea530b649ff75f2c6ac3e8ee61 /deskutils/py-calendar_cli/Makefile
parentbf34d42c80b4d8be3e7f470ac203881fabea9ba1 (diff)
downloadfreebsd-ports-6ec9afdc4a9fdfbe055dbc9c371b51d3d69db8dc.zip
fixup! deskutils/py-calendar_cli: New port: Simple command-line CalDav client
Diffstat (limited to 'deskutils/py-calendar_cli/Makefile')
-rw-r--r--deskutils/py-calendar_cli/Makefile24
1 files changed, 17 insertions, 7 deletions
diff --git a/deskutils/py-calendar_cli/Makefile b/deskutils/py-calendar_cli/Makefile
index 4337cd47e50b..4a68970f2841 100644
--- a/deskutils/py-calendar_cli/Makefile
+++ b/deskutils/py-calendar_cli/Makefile
@@ -2,7 +2,15 @@ PORTNAME= calendar_cli
DISTVERSION= 1.0.1
CATEGORIES= deskutils python
MASTER_SITES= PYPI
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+# According to https://wiki.freebsd.org/Python/PortsPolicy#PKGNAMEPREFIX
+#
+# > Ports MUST use PKGNAMEPREFIX, unless there is a compelling case not to.
+#
+# PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+#
+# But this tool being an end-user application is hopefully a compelling reason
+# to skip the prefix. A typical user couldn't care less what its implementation
+# language is, or which version of python that.
MAINTAINER= cos
COMMENT= Simple command-line CalDav client
@@ -12,15 +20,17 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
PY_DEPENDS= icalendar:devel/py-icalendar@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}tzlocal>0,1:devel/py-tzlocal@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytz>0,1:devel/py-pytz@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tzlocal>0:devel/py-tzlocal@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}caldav>=0.12-dev0:www/py-caldav@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyyaml:devel/py-pyyaml@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}Click:devel/py-click@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}six:devel/py-six@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
+
+RUN_DEPENDS= ${PY_DEPENDS}
USES= python
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist distutils noflavors
NO_ARCH= yes
.include <bsd.port.mk>