summaryrefslogtreecommitdiff
path: root/deskutils/gimmie/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-02-07 12:17:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-02-07 12:17:32 +0000
commitbd85a9298d5dfecb5ad8816ce610fa176dbdfba0 (patch)
tree8e7911fee76540e0f8b19f4511811bffdd7f996c /deskutils/gimmie/Makefile
parent81f1c00d49eff01aea059db231c2560ffb5bd304 (diff)
downloadfreebsd-ports-bd85a9298d5dfecb5ad8816ce610fa176dbdfba0.zip
Gimmie is an elegant way to think about how you use your desktop computer.
What Gimmie Can Do: * Integrated display of: o Applications from the system menu o Recently used documents, applications, printers, network shares, etc o People you've recently chatted with o People currently logged in for IM o Your Gaim buddy list's group organization o All devices, printers, mapped network shares, and system settings * Show open conversations, opened documents, and running applications (both new and legacy) in the Gimmie Bar * Bookmark apps, documents, and people in the Gimmie Bar for quick access * Allow log out, shutdown, or switching to another user * Shows the current time, a desktop switcher, and a trashcan * Search for items with instantly displayed results * Zoom in and out on recently used items, from today, to this month and beyond WWW: http://www.beatniksoftware.com/gimmie/ PR: ports/108850 Submitted by: Phillip N. <pneumann at gmail.com>
Diffstat (limited to 'deskutils/gimmie/Makefile')
-rw-r--r--deskutils/gimmie/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/deskutils/gimmie/Makefile b/deskutils/gimmie/Makefile
new file mode 100644
index 000000000000..0921ffab6643
--- /dev/null
+++ b/deskutils/gimmie/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: gimmie
+# Date created: 28 06 2006
+# Whom: pneumann@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= gimmie
+PORTVERSION= 0.2.3
+CATEGORIES= deskutils
+MASTER_SITES= http://www.beatniksoftware.com/gimmie/releases/
+
+MAINTAINER= pneumann@gmail.com
+COMMENT= An elegant way to think about how you use your desktop computer
+
+RUN_DEPENDS= ${LOCALBASE}/lib/libgnomecups-1.0.a:${PORTSDIR}/print/libgnomecups \
+ ${PYTHON_SITELIBDIR}/dbus/_dbus.py:${PORTSDIR}/devel/py-dbus \
+ ${PYTHON_SITELIBDIR}/libgmail.py:${PORTSDIR}/mail/py-libgmail
+BUILD_DEPENDS= ${LOCALBASE}/lib/libgnomecups-1.0.a:${PORTSDIR}/print/libgnomecups \
+ ${PYTHON_SITELIBDIR}/dbus/_dbus.py:${PORTSDIR}/devel/py-dbus
+
+USE_GNOME= gnomehack gnometarget gnomeprefix pygnome2 pygnomedesktop pygnomeextras
+USE_GMAKE= yes
+USE_PYTHON= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+NO_PO= yes
+.endif
+
+.include <bsd.port.mk>