summaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2017-05-23 20:10:27 +0000
committerBernard Spil <brnrd@FreeBSD.org>2017-05-23 20:10:27 +0000
commit9478ccfb680c8d25be7f10b2a4fb62faf73063ba (patch)
treef05d5ee05bd5e3475b032fa2fee24a71f1c872c0 /databases
parented194a6a30186f2c8cd6ba7f8d7c0ae2165cd81a (diff)
downloadfreebsd-ports-9478ccfb680c8d25be7f10b2a4fb62faf73063ba.zip
databases/mariadb100-server: Update to 10.0.31
- Security and bug-fix update - Remove build fix (included upstream) - Fix-up CMakeLists patches Security: d9e01c35-2531-11e7-b291-b499baebfeaf
Diffstat (limited to 'databases')
-rw-r--r--databases/mariadb100-client/files/patch-CMakeLists.txt10
-rw-r--r--databases/mariadb100-client/files/patch-build-fail-MDEV-12261234
-rw-r--r--databases/mariadb100-server/Makefile4
-rw-r--r--databases/mariadb100-server/distinfo6
-rw-r--r--databases/mariadb100-server/files/patch-CMakeLists.txt10
5 files changed, 15 insertions, 249 deletions
diff --git a/databases/mariadb100-client/files/patch-CMakeLists.txt b/databases/mariadb100-client/files/patch-CMakeLists.txt
index ddd1ce8f2441..707584ed11dd 100644
--- a/databases/mariadb100-client/files/patch-CMakeLists.txt
+++ b/databases/mariadb100-client/files/patch-CMakeLists.txt
@@ -1,5 +1,5 @@
---- CMakeLists.txt.orig 2017-01-12 01:45:16 UTC
-+++ CMakeLists.txt
+--- CMakeLists.txt.orig 2017-05-20 01:04:09.000000000 +0200
++++ CMakeLists.txt 2017-05-23 20:47:01.403482000 +0200
@@ -405,9 +405,9 @@ ADD_SUBDIRECTORY(client)
ADD_SUBDIRECTORY(extra)
ADD_SUBDIRECTORY(libservices)
@@ -24,10 +24,10 @@
)
+IF(FALSE)
- INSTALL_DOCUMENTATION(README CREDITS COPYING COPYING.LESSER EXCEPTIONS-CLIENT
- COMPONENT Readme)
+ INSTALL_DOCUMENTATION(README CREDITS COPYING EXCEPTIONS-CLIENT COMPONENT Readme)
-@@ -490,6 +492,7 @@ INSTALL_DOCUMENTATION(README CREDITS COP
+ # MDEV-6526 these files are not installed anymore
+@@ -489,6 +491,7 @@ INSTALL_DOCUMENTATION(README CREDITS COP
IF(UNIX)
INSTALL_DOCUMENTATION(Docs/INSTALL-BINARY COMPONENT Readme)
ENDIF()
diff --git a/databases/mariadb100-client/files/patch-build-fail-MDEV-12261 b/databases/mariadb100-client/files/patch-build-fail-MDEV-12261
deleted file mode 100644
index 3498f2ae6656..000000000000
--- a/databases/mariadb100-client/files/patch-build-fail-MDEV-12261
+++ /dev/null
@@ -1,234 +0,0 @@
-From 2c2bd8c1556b081fccd0fc3e010dc3ea2c38fffb Mon Sep 17 00:00:00 2001
-From: Sergei Golubchik <serg@mariadb.org>
-Date: Wed, 15 Mar 2017 11:46:54 +0100
-Subject: [PATCH] MDEV-12261 build failure without P_S
-
-restore mysql_file_delete_with_symlink() but let it use
-new my_handler_delete_with_symlink() mysys helper.
----
- include/my_sys.h | 3 +--
- include/mysql/psi/mysql_file.h | 44 ++++++++++++++++++++++++++++++++++++++++
- mysys/my_symlink2.c | 14 ++++++-------
- sql/handler.cc | 2 +-
- sql/sql_db.cc | 6 +++---
- sql/table.cc | 2 +-
- storage/maria/ma_delete_table.c | 8 ++++----
- storage/myisam/mi_delete_table.c | 8 ++++----
- 8 files changed, 64 insertions(+), 23 deletions(-)
-
-diff --git a/include/my_sys.h b/include/my_sys.h
-index 4e129cc..5b0a114 100644
---- include/my_sys.h.orig
-+++ include/my_sys.h
-@@ -597,8 +597,7 @@ extern File my_create_with_symlink(const char *linkname, const char *filename,
- myf MyFlags);
- extern int my_rename_with_symlink(const char *from,const char *to,myf MyFlags);
- extern int my_symlink(const char *content, const char *linkname, myf MyFlags);
--extern int my_handler_delete_with_symlink(PSI_file_key key, const char *name,
-- const char *ext, myf sync_dir);
-+extern int my_handler_delete_with_symlink(const char *filename, myf sync_dir);
-
- extern size_t my_read(File Filedes,uchar *Buffer,size_t Count,myf MyFlags);
- extern size_t my_pread(File Filedes,uchar *Buffer,size_t Count,my_off_t offset,
-diff --git a/include/mysql/psi/mysql_file.h b/include/mysql/psi/mysql_file.h
-index aca66bd..df94603 100644
---- include/mysql/psi/mysql_file.h.orig
-+++ include/mysql/psi/mysql_file.h
-@@ -442,6 +442,20 @@
- #endif
-
- /**
-+ @def mysql_file_delete_with_symlink(K, P1, P2, P3)
-+ Instrumented delete with symbolic link.
-+ @c mysql_file_delete_with_symlink is a replacement
-+ for @c my_handler_delete_with_symlink.
-+*/
-+#ifdef HAVE_PSI_FILE_INTERFACE
-+ #define mysql_file_delete_with_symlink(K, P1, P2, P3) \
-+ inline_mysql_file_delete_with_symlink(K, __FILE__, __LINE__, P1, P2, P3)
-+#else
-+ #define mysql_file_delete_with_symlink(K, P1, P2, P3) \
-+ inline_mysql_file_delete_with_symlink(P1, P2, P3)
-+#endif
-+
-+/**
- @def mysql_file_rename_with_symlink(K, P1, P2, P3)
- Instrumented rename with symbolic link.
- @c mysql_file_rename_with_symlink is a replacement
-@@ -1294,6 +1308,7 @@ inline_mysql_file_rename(
- return result;
- }
-
-+
- static inline File
- inline_mysql_file_create_with_symlink(
- #ifdef HAVE_PSI_FILE_INTERFACE
-@@ -1325,6 +1340,35 @@ inline_mysql_file_create_with_symlink(
-
-
- static inline int
-+inline_mysql_file_delete_with_symlink(
-+#ifdef HAVE_PSI_FILE_INTERFACE
-+ PSI_file_key key, const char *src_file, uint src_line,
-+#endif
-+ const char *name, const char *ext, myf flags)
-+{
-+ int result;
-+ char fullname[FN_REFLEN];
-+ fn_format(fullname, name, "", ext, MY_UNPACK_FILENAME | MY_APPEND_EXT);
-+#ifdef HAVE_PSI_FILE_INTERFACE
-+ struct PSI_file_locker *locker;
-+ PSI_file_locker_state state;
-+ locker= PSI_FILE_CALL(get_thread_file_name_locker)
-+ (&state, key, PSI_FILE_DELETE, fullname, &locker);
-+ if (likely(locker != NULL))
-+ {
-+ PSI_FILE_CALL(start_file_close_wait)(locker, src_file, src_line);
-+ result= my_handler_delete_with_symlink(fullname, flags);
-+ PSI_FILE_CALL(end_file_close_wait)(locker, result);
-+ return result;
-+ }
-+#endif
-+
-+ result= my_handler_delete_with_symlink(fullname, flags);
-+ return result;
-+}
-+
-+
-+static inline int
- inline_mysql_file_rename_with_symlink(
- #ifdef HAVE_PSI_FILE_INTERFACE
- PSI_file_key key, const char *src_file, uint src_line,
-diff --git a/mysys/my_symlink2.c b/mysys/my_symlink2.c
-index defcb59..c851468 100644
---- mysys/my_symlink2.c.orig
-+++ mysys/my_symlink2.c
-@@ -170,22 +170,20 @@ int my_rename_with_symlink(const char *from, const char *to, myf MyFlags)
- in this case both the symlink and the symlinked file are deleted,
- but only if the symlinked file is not in the datadir.
- */
--int my_handler_delete_with_symlink(PSI_file_key key, const char *name,
-- const char *ext, myf sync_dir)
-+int my_handler_delete_with_symlink(const char *filename, myf sync_dir)
- {
-- char orig[FN_REFLEN], real[FN_REFLEN];
-+ char real[FN_REFLEN];
- int res= 0;
- DBUG_ENTER("my_handler_delete_with_symlink");
-
-- fn_format(orig, name, "", ext, MY_UNPACK_FILENAME | MY_APPEND_EXT);
-- if (my_is_symlink(orig))
-+ if (my_is_symlink(filename))
- {
- /*
- Delete the symlinked file only if the symlink is not
- pointing into datadir.
- */
-- if (!(my_realpath(real, orig, MYF(0)) || mysys_test_invalid_symlink(real)))
-- res= mysql_file_delete(key, real, MYF(MY_NOSYMLINKS | sync_dir));
-+ if (!(my_realpath(real, filename, MYF(0)) || mysys_test_invalid_symlink(real)))
-+ res= my_delete(real, MYF(MY_NOSYMLINKS | sync_dir));
- }
-- DBUG_RETURN(mysql_file_delete(key, orig, MYF(sync_dir)) || res);
-+ DBUG_RETURN(my_delete(filename, MYF(sync_dir)) || res);
- }
-diff --git a/sql/handler.cc b/sql/handler.cc
-index 7fa8afd..fc70ed5 100644
---- sql/handler.cc.orig
-+++ sql/handler.cc
-@@ -3850,7 +3850,7 @@ int handler::delete_table(const char *name)
-
- for (const char **ext=bas_ext(); *ext ; ext++)
- {
-- if (my_handler_delete_with_symlink(key_file_misc, name, *ext, 0))
-+ if (mysql_file_delete_with_symlink(key_file_misc, name, *ext, 0))
- {
- if (my_errno != ENOENT)
- {
-diff --git a/sql/sql_db.cc b/sql/sql_db.cc
-index 3f43a33..6c8c384 100644
---- sql/sql_db.cc.orig
-+++ sql/sql_db.cc
-@@ -815,7 +815,7 @@ bool mysql_rm_db(THD *thd,char *db,bool if_exists, bool silent)
- if there exists a table with the name 'db', so let's just do it
- separately. We know this file exists and needs to be deleted anyway.
- */
-- if (my_handler_delete_with_symlink(key_file_misc, path, "", MYF(0)) &&
-+ if (mysql_file_delete_with_symlink(key_file_misc, path, "", MYF(0)) &&
- my_errno != ENOENT)
- {
- my_error(EE_DELETE, MYF(0), path, my_errno);
-@@ -1119,7 +1119,7 @@ static bool find_db_tables_and_rm_known_files(THD *thd, MY_DIR *dirp,
- We ignore ENOENT error in order to skip files that was deleted
- by concurrently running statement like REPAIR TABLE ...
- */
-- if (my_handler_delete_with_symlink(key_file_misc, filePath, "", MYF(0)) &&
-+ if (mysql_file_delete_with_symlink(key_file_misc, filePath, "", MYF(0)) &&
- my_errno != ENOENT)
- {
- my_error(EE_DELETE, MYF(0), filePath, my_errno);
-@@ -1235,7 +1235,7 @@ long mysql_rm_arc_files(THD *thd, MY_DIR *dirp, const char *org_path)
- continue;
- }
- strxmov(filePath, org_path, "/", file->name, NullS);
-- if (my_handler_delete_with_symlink(key_file_misc, filePath, "", MYF(MY_WME)))
-+ if (mysql_file_delete_with_symlink(key_file_misc, filePath, "", MYF(MY_WME)))
- {
- goto err;
- }
-diff --git a/sql/table.cc b/sql/table.cc
-index 80d0e02..975d9d5 100644
---- sql/table.cc.orig
-+++ sql/table.cc
-@@ -569,7 +569,7 @@ enum open_frm_error open_table_def(THD *thd, TABLE_SHARE *share, uint flags)
- {
- DBUG_ASSERT(flags & GTS_TABLE);
- DBUG_ASSERT(flags & GTS_USE_DISCOVERY);
-- my_handler_delete_with_symlink(key_file_frm, path, "", MYF(0));
-+ mysql_file_delete_with_symlink(key_file_frm, path, "", MYF(0));
- file= -1;
- }
- else
-diff --git a/storage/maria/ma_delete_table.c b/storage/maria/ma_delete_table.c
-index a9ab8e5..186075d 100644
---- storage/maria/ma_delete_table.c.orig
-+++ storage/maria/ma_delete_table.c
-@@ -86,11 +86,11 @@ int maria_delete_table_files(const char *name, myf sync_dir)
- {
- DBUG_ENTER("maria_delete_table_files");
-
-- if (my_handler_delete_with_symlink(key_file_kfile, name, MARIA_NAME_IEXT, MYF(MY_WME | sync_dir)) ||
-- my_handler_delete_with_symlink(key_file_dfile, name, MARIA_NAME_DEXT, MYF(MY_WME | sync_dir)))
-+ if (mysql_file_delete_with_symlink(key_file_kfile, name, MARIA_NAME_IEXT, MYF(MY_WME | sync_dir)) ||
-+ mysql_file_delete_with_symlink(key_file_dfile, name, MARIA_NAME_DEXT, MYF(MY_WME | sync_dir)))
- DBUG_RETURN(my_errno);
-
-- my_handler_delete_with_symlink(key_file_dfile, name, ".TMD", MYF(0));
-- my_handler_delete_with_symlink(key_file_dfile, name, ".OLD", MYF(0));
-+ mysql_file_delete_with_symlink(key_file_dfile, name, ".TMD", MYF(0));
-+ mysql_file_delete_with_symlink(key_file_dfile, name, ".OLD", MYF(0));
- DBUG_RETURN(0);
- }
-diff --git a/storage/myisam/mi_delete_table.c b/storage/myisam/mi_delete_table.c
-index 3422e6b..d766fb2 100644
---- storage/myisam/mi_delete_table.c.orig
-+++ storage/myisam/mi_delete_table.c
-@@ -34,14 +34,14 @@ int mi_delete_table(const char *name)
- check_table_is_closed(name,"delete");
- #endif
-
-- if (my_handler_delete_with_symlink(mi_key_file_kfile, name, MI_NAME_IEXT, MYF(MY_WME)) ||
-- my_handler_delete_with_symlink(mi_key_file_dfile, name, MI_NAME_DEXT, MYF(MY_WME)))
-+ if (mysql_file_delete_with_symlink(mi_key_file_kfile, name, MI_NAME_IEXT, MYF(MY_WME)) ||
-+ mysql_file_delete_with_symlink(mi_key_file_dfile, name, MI_NAME_DEXT, MYF(MY_WME)))
- DBUG_RETURN(my_errno);
-
-
- // optionally present:
-- my_handler_delete_with_symlink(mi_key_file_dfile, name, ".OLD", MYF(0));
-- my_handler_delete_with_symlink(mi_key_file_dfile, name, ".TMD", MYF(0));
-+ mysql_file_delete_with_symlink(mi_key_file_dfile, name, ".OLD", MYF(0));
-+ mysql_file_delete_with_symlink(mi_key_file_dfile, name, ".TMD", MYF(0));
-
- DBUG_RETURN(0);
- }
diff --git a/databases/mariadb100-server/Makefile b/databases/mariadb100-server/Makefile
index 4af7eb28f225..1a6734be87fa 100644
--- a/databases/mariadb100-server/Makefile
+++ b/databases/mariadb100-server/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME?= mariadb
-PORTVERSION= 10.0.30
-PORTREVISION?= 2
+PORTVERSION= 10.0.31
+PORTREVISION?= 0
CATEGORIES= databases ipv6
MASTER_SITES= http://ftp.osuosl.org/pub/${SITESDIR}/ \
http://mirrors.supportex.net/${SITESDIR}/ \
diff --git a/databases/mariadb100-server/distinfo b/databases/mariadb100-server/distinfo
index 024893b11c5e..f829e51d8a69 100644
--- a/databases/mariadb100-server/distinfo
+++ b/databases/mariadb100-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1489029439
-SHA256 (mariadb-10.0.30.tar.gz) = 9a2cb7f06ecce1bb64dddc70c484e36507b50b756c110c1d37fa145a13a796bb
-SIZE (mariadb-10.0.30.tar.gz) = 63433598
+TIMESTAMP = 1495565124
+SHA256 (mariadb-10.0.31.tar.gz) = 371f2dae0b9e1a92939fba1efca77ac83ba15b6b6dcfd389ca5cbf79eb8b842a
+SIZE (mariadb-10.0.31.tar.gz) = 63461177
diff --git a/databases/mariadb100-server/files/patch-CMakeLists.txt b/databases/mariadb100-server/files/patch-CMakeLists.txt
index cc24e5b85fd7..b26684fa0622 100644
--- a/databases/mariadb100-server/files/patch-CMakeLists.txt
+++ b/databases/mariadb100-server/files/patch-CMakeLists.txt
@@ -1,14 +1,14 @@
---- CMakeLists.txt.orig 2015-08-05 18:11:27 UTC
-+++ CMakeLists.txt
+--- CMakeLists.txt.orig 2017-05-20 01:04:09.000000000 +0200
++++ CMakeLists.txt 2017-05-23 20:53:22.017238000 +0200
@@ -480,6 +480,7 @@ ADD_CUSTOM_TARGET(INFO_BIN ALL
WORKING_DIRECTORY ${CMAKE_BINARY_DIR}
)
+IF(FALSE)
- INSTALL_DOCUMENTATION(README CREDITS COPYING COPYING.LESSER EXCEPTIONS-CLIENT
- COMPONENT Readme)
+ INSTALL_DOCUMENTATION(README CREDITS COPYING EXCEPTIONS-CLIENT COMPONENT Readme)
-@@ -490,6 +491,7 @@ INSTALL_DOCUMENTATION(README CREDITS COP
+ # MDEV-6526 these files are not installed anymore
+@@ -489,6 +490,7 @@ INSTALL_DOCUMENTATION(README CREDITS COP
IF(UNIX)
INSTALL_DOCUMENTATION(Docs/INSTALL-BINARY COMPONENT Readme)
ENDIF()