summaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2022-12-03 18:43:44 +0000
committerMark Felder <feld@FreeBSD.org>2022-12-03 18:43:44 +0000
commitbb6b6ce9ef2e9df76f92896a9c5458176c42a586 (patch)
treedd0118a9dd2d822c6e41b9f756625356e4eee4a9 /databases
parent90586c77f6c11915db367c7890e30a1c24b5a7f8 (diff)
downloadfreebsd-ports-bb6b6ce9ef2e9df76f92896a9c5458176c42a586.zip
databases/postgresql-promscale: portlint fixes and defined ONLY_FOR_ARCHES
Diffstat (limited to 'databases')
-rw-r--r--databases/postgresql-promscale/Makefile17
-rw-r--r--databases/postgresql-promscale/pkg-descr3
2 files changed, 11 insertions, 9 deletions
diff --git a/databases/postgresql-promscale/Makefile b/databases/postgresql-promscale/Makefile
index 7b253b81d209..c38f25551ab8 100644
--- a/databases/postgresql-promscale/Makefile
+++ b/databases/postgresql-promscale/Makefile
@@ -10,17 +10,18 @@ WWW= https://www.timescale.com/promscale
LICENSE= PostgreSQL
+ONLY_FOR_ARCHS= aarch64 amd64
+
+RUN_DEPENDS= timescaledb>0:databases/timescaledb
+BUILD_DEPENDS= bash>0:shells/bash
+
+USES= cargo gmake pgsql:12+
+
# Depends on an unpublished crate. Can't use cargo.mk to fetch it.
PGX_REV= 96ece243
DISTFILES+= pgx-${PGX_REV}.tar.gz
SITES.pgx-${PGX_REV}.tar.gz+= ${MASTER_SITE_GITHUB:=timescale/}pgx/archive/${PGX_REV}.tar.gz
-USES= cargo gmake pgsql:12+
-
-BUILD_DEPENDS= bash>0:shells/bash
-
-RUN_DEPENDS= timescaledb>0:databases/timescaledb
-
USE_GITHUB= yes
GH_ACCOUNT= timescale timescale:pgx
GH_PROJECT= promscale_extension pgx:pgx
@@ -34,7 +35,7 @@ MAKE_ENV+= MAKE=gmake PATH=${PATH}:${WRKDIR}/.cargo/bin
.include "${.CURDIR}/crates.mk"
post-extract:
- mv ${WRKDIR}/pgx-* ${WRKDIR}/pgx
+ ${MV} ${WRKDIR}/pgx-* ${WRKDIR}/pgx
pre-configure:
@${PATCH} -d ${WRKDIR} ${PATCH_ARGS} < ${PATCHDIR}/pgx-include-patch
@@ -42,7 +43,7 @@ pre-configure:
pre-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} cargo install --offline --path ../pgx/cargo-pgx cargo-pgx
- mkdir -p ${WRKDIR}/.pgx
+ ${MKDIR} ${WRKDIR}/.pgx
${PRINTF} '[configs]\npg${PGSQL_VERSION}="${LOCALBASE}/bin/pg_config"\n' > ${WRKDIR}/.pgx/config.toml
do-build:
diff --git a/databases/postgresql-promscale/pkg-descr b/databases/postgresql-promscale/pkg-descr
index f6a986a1cea5..93e5ab388075 100644
--- a/databases/postgresql-promscale/pkg-descr
+++ b/databases/postgresql-promscale/pkg-descr
@@ -1 +1,2 @@
-PostgreSQL extension required for storing Prometheus metrics in PostgreSQL via TimescaleDB.
+PostgreSQL extension required for storing Prometheus metrics in
+PostgreSQL via TimescaleDB.