summaryrefslogtreecommitdiff
path: root/databases/postgresql15-pltcl
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2022-05-18 21:11:48 +0200
committerPalle Girgensohn <girgen@FreeBSD.org>2022-05-19 15:36:48 +0200
commit5b11f47f0d59c95f6dcf1ff75badede5ec84e72e (patch)
treeddbd6345593e54c390ac3b9b04b4403cae76366b /databases/postgresql15-pltcl
parentfd6622942cecb559358c5c44d4f9dddbf827ccb1 (diff)
downloadfreebsd-ports-5b11f47f0d59c95f6dcf1ff75badede5ec84e72e.zip
databases/postgresql??-*: add postgresql-15 to the ports tree
Introduce PostgreSQL-15 to the ports tree. Make version 15 the master port, and add plist parameter for the postgresql version. Release notes: https://www.postgresql.org/docs/devel/release.html
Diffstat (limited to 'databases/postgresql15-pltcl')
-rw-r--r--databases/postgresql15-pltcl/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/databases/postgresql15-pltcl/Makefile b/databases/postgresql15-pltcl/Makefile
new file mode 100644
index 000000000000..e9159b41ae96
--- /dev/null
+++ b/databases/postgresql15-pltcl/Makefile
@@ -0,0 +1,34 @@
+# Created by: Palle Girgensohn <girgen@partitur.se>
+
+PORTNAME= postgresql
+# Keep the ?=, it is used by the other pltcl ports.
+PORTREVISION?= 0
+CATEGORIES= databases tcl
+PKGNAMESUFFIX?= ${WANT_PGSQL_VER:S/.//}${COMPONENT}
+
+MAINTAINER= pgsql@FreeBSD.org
+COMMENT= Module for using Tcl to write SQL functions
+
+MASTERDIR= ${.CURDIR}/../../databases/postgresql${WANT_PGSQL_VER:S/.//}-server
+
+WANT_PGSQL_VER?=15
+
+USES+= tcl pgsql:${WANT_PGSQL_VER}
+WANT_PGSQL= server
+
+CONFIGURE_ARGS= --with-tcl --without-tk \
+ --with-tclconfig="${TCL_LIBDIR}" \
+ --with-includes="${TCL_INCLUDEDIR}"
+
+CONFIGURE_ENV+= TCLSH="${TCLSH}"
+MAKE_ENV+= TCL_INCDIR="${TCL_INCLUDEDIR}"
+
+BUILD_DIRS= src/backend src/pl/tcl
+INSTALL_DIRS= src/pl/tcl
+SLAVE_ONLY= yes
+COMPONENT= -pltcl
+
+# this port fails to build in parallel
+MAKE_JOBS_UNSAFE= yes
+
+.include "${MASTERDIR}/Makefile"