summaryrefslogtreecommitdiff
path: root/databases/p5-DBD-Oracle
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /databases/p5-DBD-Oracle
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadfreebsd-ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Diffstat (limited to 'databases/p5-DBD-Oracle')
-rw-r--r--databases/p5-DBD-Oracle/Makefile4
-rw-r--r--databases/p5-DBD-Oracle/pkg-plist21
2 files changed, 12 insertions, 13 deletions
diff --git a/databases/p5-DBD-Oracle/Makefile b/databases/p5-DBD-Oracle/Makefile
index 9191a5b47a99..1f7ae3679d44 100644
--- a/databases/p5-DBD-Oracle/Makefile
+++ b/databases/p5-DBD-Oracle/Makefile
@@ -3,7 +3,7 @@
PORTNAME= DBD-Oracle
PORTVERSION= 1.19
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= databases perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -52,7 +52,7 @@ post-patch:
${WRKSRC}/dbdimp.c ${WRKSRC}/Oracle.xs ${WRKSRC}/oci[78].c
post-install:
- ${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/DBD/Oracle/Oracle.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/DBD/Oracle/Oracle.so
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/Oracle.ex/Readme ${STAGEDIR}${EXAMPLESDIR}
diff --git a/databases/p5-DBD-Oracle/pkg-plist b/databases/p5-DBD-Oracle/pkg-plist
index 6b3e32436884..65587d887c28 100644
--- a/databases/p5-DBD-Oracle/pkg-plist
+++ b/databases/p5-DBD-Oracle/pkg-plist
@@ -1,15 +1,14 @@
bin/ora_explain
-%%SITE_PERL%%/%%PERL_ARCH%%/DBD/Oracle.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/DBD/Oracle/GetInfo.pm
-%%MKTA%%%%SITE_PERL%%/%%PERL_ARCH%%/DBD/mkta.pl
-%%SITE_PERL%%/%%PERL_ARCH%%/Oraperl.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/Oracle/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/Oracle/Oracle.h
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/Oracle/Oracle.so
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/Oracle/dbdimp.h
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/Oracle/mk.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/Oracle/ocitrace.h
-%%SITE_PERL%%/%%PERL_ARCH%%/oraperl.ph
+%%SITE_ARCH%%/DBD/Oracle.pm
+%%SITE_ARCH%%/DBD/Oracle/GetInfo.pm
+%%MKTA%%%%SITE_ARCH%%/DBD/mkta.pl
+%%SITE_ARCH%%/Oraperl.pm
+%%SITE_ARCH%%/auto/DBD/Oracle/Oracle.h
+%%SITE_ARCH%%/auto/DBD/Oracle/Oracle.so
+%%SITE_ARCH%%/auto/DBD/Oracle/dbdimp.h
+%%SITE_ARCH%%/auto/DBD/Oracle/mk.pm
+%%SITE_ARCH%%/auto/DBD/Oracle/ocitrace.h
+%%SITE_ARCH%%/oraperl.ph
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Readme
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bind.pl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/commit.pl