summaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2019-06-20 00:27:36 +0000
committerDiane Bruce <db@FreeBSD.org>2019-06-20 00:27:36 +0000
commit6d4b0a5e81e0838fedb1342aa700b0b1d7ad0ab6 (patch)
tree35377e537e8e30b27ca5d3247192b69e8d46314d /comms
parentbc633cff700907429f3af3141004871854fec2d5 (diff)
downloadfreebsd-ports-6d4b0a5e81e0838fedb1342aa700b0b1d7ad0ab6.zip
Update to 4.1.04
Simplify local patch 2019-06-07 Davide Gerhard IV3CVE <w1hkj@bellsouth.net> 51590b10b: MacOS high-DPI 33505fec3: timeops 2019-06-07 David Freese <w1hkj@bellsouth.net> c2dbea65b: log server 337aa4d2a: xmlrpc <vector> 2086bd1fe: LoTW delivery 2e0ba6d11: Apple kill button 6d9c80e3a: main dialog title 2ec197373: Warnings f63f8bc36: Contestia/Olivia ea39851b6: Log reports f7c376723: Documentation update 8d25f53d9: 7qp multi 867ded47b: n3fjp ebab17a2b: wfonly controls ef2d55e22: Read log debugging 2928a9b97: New Modem Macro 90b021222: DE QSO Party
Diffstat (limited to 'comms')
-rw-r--r--comms/fldigi/Makefile2
-rw-r--r--comms/fldigi/distinfo6
-rw-r--r--comms/fldigi/files/patch-src_soundcard_sound.cxx13
3 files changed, 10 insertions, 11 deletions
diff --git a/comms/fldigi/Makefile b/comms/fldigi/Makefile
index e80a9725b546..6bac3cfc3da2 100644
--- a/comms/fldigi/Makefile
+++ b/comms/fldigi/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= fldigi
-PORTVERSION= 4.1.03
+PORTVERSION= 4.1.04
CATEGORIES= comms hamradio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
diff --git a/comms/fldigi/distinfo b/comms/fldigi/distinfo
index 6c3c64c1876b..f920d5870982 100644
--- a/comms/fldigi/distinfo
+++ b/comms/fldigi/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1555867447
-SHA256 (fldigi-4.1.03.tar.gz) = 37d9404cd02ad0497fb369ab73ade4f6330e1f82bfce908c4fe89f21642775b4
-SIZE (fldigi-4.1.03.tar.gz) = 4682813
+TIMESTAMP = 1560983163
+SHA256 (fldigi-4.1.04.tar.gz) = 89c19c349eaf04cd3bab94df89cdaa9d4ad8b1bc50871d3f8be1175ab237bb45
+SIZE (fldigi-4.1.04.tar.gz) = 4689833
diff --git a/comms/fldigi/files/patch-src_soundcard_sound.cxx b/comms/fldigi/files/patch-src_soundcard_sound.cxx
index 3ad51c5922ed..3f11c59e17ac 100644
--- a/comms/fldigi/files/patch-src_soundcard_sound.cxx
+++ b/comms/fldigi/files/patch-src_soundcard_sound.cxx
@@ -1,6 +1,6 @@
---- src/soundcard/sound.cxx.orig 2018-12-06 14:41:46 UTC
+--- src/soundcard/sound.cxx.orig 2019-05-25 01:35:59 UTC
+++ src/soundcard/sound.cxx
-@@ -651,7 +651,27 @@ int SoundOSS::Open(int md, int freq)
+@@ -651,7 +651,26 @@ int SoundOSS::Open(int md, int freq)
oflags = oflags | O_CLOEXEC;
# endif
@@ -16,10 +16,9 @@
+ char *p;
+ /* Look for a '.' if found, blow it away */
+ fixed_name = strdup(device.c_str());
-+ p = fixed_name;
-+ while (*p++)
-+ if(*p == '.')
-+ *p = '\0';
++ p = strchr(fixed_name, '.');
++ if(p != NULL)
++ *p = '\0';
+ device_fd = fl_open(fixed_name, oflags, 0);
+ free(fixed_name);
+#else
@@ -28,7 +27,7 @@
if (device_fd == -1)
throw SndException(errno);
-@@ -677,12 +697,11 @@ void SoundOSS::Close(unsigned dir)
+@@ -677,12 +696,11 @@ void SoundOSS::Close(unsigned dir)
void SoundOSS::getVersion()
{
version = 0;