summaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2008-10-26 05:14:38 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2008-10-26 05:14:38 +0000
commit9d89fcf25c2e0aaf7fe4beb5b18fbc135ef8c329 (patch)
treed8c12ae1d98b94cb200ab6519a16592ff55c3a43 /comms
parentd000509e2752d07e789c701ee29ab9446150e258 (diff)
downloadfreebsd-ports-9d89fcf25c2e0aaf7fe4beb5b18fbc135ef8c329.zip
- Fix patch from previous commit
- Bump PORTREVISION PR: ports/128346 Submitted by: Jeff Blank <jfb@mr-happy.com> (maintainer)
Diffstat (limited to 'comms')
-rw-r--r--comms/qpage/Makefile2
-rw-r--r--comms/qpage/files/patch-srvrsnpp.c4
2 files changed, 3 insertions, 3 deletions
diff --git a/comms/qpage/Makefile b/comms/qpage/Makefile
index 45b141083d43..d8ba2793613f 100644
--- a/comms/qpage/Makefile
+++ b/comms/qpage/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qpage
PORTVERSION= 3.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= comms
MASTER_SITES= http://www.qpage.org/download/
EXTRACT_SUFX= .tar.Z
diff --git a/comms/qpage/files/patch-srvrsnpp.c b/comms/qpage/files/patch-srvrsnpp.c
index 95b27126e8ad..5e1cfee07a67 100644
--- a/comms/qpage/files/patch-srvrsnpp.c
+++ b/comms/qpage/files/patch-srvrsnpp.c
@@ -1,5 +1,5 @@
--- srvrsnpp.c.orig 1998-10-25 14:55:05.000000000 -0500
-+++ srvrsnpp.c 2008-10-18 18:09:44.175331511 -0400
++++ srvrsnpp.c 2008-10-24 11:00:36.226381386 -0400
@@ -523,6 +523,7 @@
char *errmsg;
char *a;
@@ -13,7 +13,7 @@
p->created = time(NULL);
(void)sprintf(buff, "%d", pagecount++);
- (void)strcat(p->messageid, buff);
-+ m = (void *)malloc(sizeof(*m) * strlen(p->messageid) + sizeof(*m) * strlen(buff));
++ m = (void *)malloc(sizeof(*m) * (strlen(p->messageid) + strlen(buff) + 1));
+ if ( m == NULL ) {
+ message("554 Message failed (out of memory)");
+ qpage_log(LOG_ERR, "snpp(): cannot allocate memory for p->messageid");