summaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-15 23:11:12 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-15 23:11:12 +0000
commit44eaadcb751194bcef34890a161d4bf9a873a2a4 (patch)
tree37076f8661cc0a667d6e54eab2728ecc665430a0 /comms
parent156cc72026ce25b8da3d604f4fb691e4d6413b5f (diff)
downloadfreebsd-ports-44eaadcb751194bcef34890a161d4bf9a873a2a4.zip
Add OPTIONS_DEFINE=DOCS for ports with %%PORTDOCS%% in the plist.
Where possible, correct a few instances where PORTDOCS was being used to flag stuff in EXAMPLESDIR. For some ports, mostly those owned by ruby@, PORTDOCS is applied to pretty much everything whether it's documentation or example.
Diffstat (limited to 'comms')
-rw-r--r--comms/aprsd/Makefile2
-rw-r--r--comms/aprsd/pkg-plist6
-rw-r--r--comms/chirp/Makefile2
-rw-r--r--comms/cwdaemon/Makefile2
-rw-r--r--comms/ebook2cw/Makefile2
-rw-r--r--comms/echolinux/Makefile2
-rw-r--r--comms/fldigi/Makefile2
-rw-r--r--comms/flwrap/Makefile2
-rw-r--r--comms/gkermit/Makefile2
-rw-r--r--comms/hamlib/Makefile2
-rw-r--r--comms/hf/Makefile2
-rw-r--r--comms/kb/Makefile2
-rw-r--r--comms/locator/Makefile2
-rw-r--r--comms/nasawash/Makefile2
-rw-r--r--comms/nec2c/Makefile2
-rw-r--r--comms/wspr/Makefile2
-rw-r--r--comms/xwota/Makefile2
-rw-r--r--comms/yagiuda/Makefile2
-rw-r--r--comms/yfklog/Makefile2
19 files changed, 37 insertions, 5 deletions
diff --git a/comms/aprsd/Makefile b/comms/aprsd/Makefile
index 4d476e7ea770..98cab1371e8a 100644
--- a/comms/aprsd/Makefile
+++ b/comms/aprsd/Makefile
@@ -13,6 +13,8 @@ COMMENT= Server daemon providing Internet access to APRS packet data
GNU_CONFIGURE= yes
SUB_FILES= pkg-message
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.pre.mk>
post-patch:
diff --git a/comms/aprsd/pkg-plist b/comms/aprsd/pkg-plist
index 7247ead9f7de..2fe0ddd51a63 100644
--- a/comms/aprsd/pkg-plist
+++ b/comms/aprsd/pkg-plist
@@ -6,12 +6,12 @@ etc/aprsd/aprsd.conf.samp
etc/aprsd/user.deny.samp
etc/aprsd/welcome.txt.samp
etc/rc.d/aprsd
-%%EXAMPLESDIR%%/chkaprsd
-%%EXAMPLESDIR%%/udp_example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chkaprsd
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/udp_example
%%PORTDOCS%%%%DOCSDIR%%/aprsddoc.html
%%PORTDOCS%%%%DOCSDIR%%/ports.html
%%PORTDOCS%%%%DOCSDIR%%/q.html
%%PORTDOCS%%%%DOCSDIR%%/qalgorithm.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrmtry etc/aprsd
diff --git a/comms/chirp/Makefile b/comms/chirp/Makefile
index 8db4fe7acea8..02bf01670783 100644
--- a/comms/chirp/Makefile
+++ b/comms/chirp/Makefile
@@ -19,6 +19,8 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/serial:${PORTSDIR}/comms/py-serial \
USE_PYTHON= YES
USE_PYDISTUTILS= YES
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
pre-configure:
diff --git a/comms/cwdaemon/Makefile b/comms/cwdaemon/Makefile
index 902acd695c62..be8268d9606c 100644
--- a/comms/cwdaemon/Makefile
+++ b/comms/cwdaemon/Makefile
@@ -19,4 +19,6 @@ CONFIGURE_ARGS+= --datadir=${PREFIX}/share/doc
GNU_CONFIGURE= yes
USES= pkgconfig
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/comms/ebook2cw/Makefile b/comms/ebook2cw/Makefile
index ebf3e0368541..f1243ef07e78 100644
--- a/comms/ebook2cw/Makefile
+++ b/comms/ebook2cw/Makefile
@@ -15,6 +15,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libmp3lame.so:${PORTSDIR}/audio/lame \
libvorbis.so:${PORTSDIR}/audio/libvorbis
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|'g \
${WRKSRC}/Makefile
diff --git a/comms/echolinux/Makefile b/comms/echolinux/Makefile
index 9f732ed40ea2..9bfcee164521 100644
--- a/comms/echolinux/Makefile
+++ b/comms/echolinux/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libforms.so:${PORTSDIR}/x11-toolkits/xforms \
libgsm.so:${PORTSDIR}/audio/gsm
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's|gcc|$${CC}|' -e 's|/usr/include/X11|$${LOCALBASE}/include|' \
diff --git a/comms/fldigi/Makefile b/comms/fldigi/Makefile
index 17d5a28d8984..febbd7015fd9 100644
--- a/comms/fldigi/Makefile
+++ b/comms/fldigi/Makefile
@@ -28,7 +28,7 @@ CONFIGURE_ENV= FLTK_CONFIG="${LOCALBASE}/bin/fltk-config" \
EXTRA_LIBS="-lexecinfo"
SHEBANG_FILES= scripts/fldigi-shell
-OPTIONS_DEFINE= NATIVE_OPT FLARQ OSS SNDFILE PORTAUDIO PULSEAUDIO HAMLIB NLS
+OPTIONS_DEFINE= NATIVE_OPT FLARQ OSS SNDFILE PORTAUDIO PULSEAUDIO HAMLIB NLS DOCS
NATIVE_OPT_DESC= Enable Native Optimizations
FLARQ_DESC= Compile flarq
diff --git a/comms/flwrap/Makefile b/comms/flwrap/Makefile
index 3df1bae33654..c88f91789331 100644
--- a/comms/flwrap/Makefile
+++ b/comms/flwrap/Makefile
@@ -19,6 +19,8 @@ USES= gmake dos2unix
GNU_CONFIGURE= yes
CONFIGURE_ENV= FLTK_CONFIG="${LOCALBASE}/bin/fltk-config"
+OPTIONS_DEFINE= DOCS
+
post-configure:
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|' \
-e 's|^CPPFLAGS|#CPPFLAGS|' \
diff --git a/comms/gkermit/Makefile b/comms/gkermit/Makefile
index 6e1769134e09..6a32a660fa71 100644
--- a/comms/gkermit/Makefile
+++ b/comms/gkermit/Makefile
@@ -14,6 +14,8 @@ NO_WRKSUBDIR= yes
ALL_TARGET= posix
+OPTIONS_DEFINE= DOCS
+
post-extract:
cd ${WRKSRC} && ${MV} makefile Makefile
diff --git a/comms/hamlib/Makefile b/comms/hamlib/Makefile
index b8384f9f4131..fca0fd41abb7 100644
--- a/comms/hamlib/Makefile
+++ b/comms/hamlib/Makefile
@@ -26,6 +26,8 @@ CONFIGURE_ARGS= --with-perl-binding \
--with-python-binding --without-rigmatrix
PLIST_SUB= VER=${PORTVERSION} TCL_VER=${TCL_VER}
+OPTIONS_DEFINE= DOCS
+
post-patch:
${REINPLACE_CMD} -e 's|%%PYTHON_SITELIBDIR%%|${PYTHON_SITELIBDIR}|g' \
-e 's|%%TCL_LIBDIR%%|${TCL_LIBDIR}/hamlib|g' \
diff --git a/comms/hf/Makefile b/comms/hf/Makefile
index 98005b88bce0..bc1488d78c92 100644
--- a/comms/hf/Makefile
+++ b/comms/hf/Makefile
@@ -24,6 +24,8 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
CONFLICTS= sysutils/lbl-hf-1.*
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-configure:
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|' \
${WRKSRC}/hfkernel/Makefile
diff --git a/comms/kb/Makefile b/comms/kb/Makefile
index f3e170a0c125..667e6b9b118a 100644
--- a/comms/kb/Makefile
+++ b/comms/kb/Makefile
@@ -23,6 +23,8 @@ DESKTOP_ENTRIES="KB" \
"" \
true
+OPTIONS_DEFINE= DOCS
+
pre-configure:
@${CP} ${FILESDIR}/Makefile ${WRKSRC}
diff --git a/comms/locator/Makefile b/comms/locator/Makefile
index 4f7a3e1459f8..484484a5ca4a 100644
--- a/comms/locator/Makefile
+++ b/comms/locator/Makefile
@@ -11,6 +11,8 @@ COMMENT= Grid square calculator program used in Amateur Radio and GPS work
CONFLICTS= wwl*
+OPTIONS_DEFINE= DOCS
+
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/locator ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/comms/nasawash/Makefile b/comms/nasawash/Makefile
index 63a1bc63ddd3..26280ae92209 100644
--- a/comms/nasawash/Makefile
+++ b/comms/nasawash/Makefile
@@ -17,6 +17,8 @@ WRKSRC= ${WRKDIR}/${DISTNAME}-${PORTVERSION}
PLIST_FILES= bin/nasawash
PORTDOCS= nasawash.txt nasawash.upd
+OPTIONS_DEFINE= DOCS
+
do-build:
${CC} ${CPPFLAGS} ${CFLAGS} -c -o ${WRKSRC}/nasawash.o ${WRKSRC}/nasawash.c
${CC} -o ${WRKSRC}/nasawash ${WRKSRC}/nasawash.o ${LIBS}
diff --git a/comms/nec2c/Makefile b/comms/nec2c/Makefile
index df2187b73e70..4b770cd5695c 100644
--- a/comms/nec2c/Makefile
+++ b/comms/nec2c/Makefile
@@ -14,6 +14,8 @@ COMMENT= Used to calculate antenna patterns useful to ham radio
LIB_DEPENDS= libccm.so:${PORTSDIR}/math/ccmath
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-patch:
${CP} ${FILESDIR}/carg.c ${WRKSRC}
diff --git a/comms/wspr/Makefile b/comms/wspr/Makefile
index ca5b9e5bbfb4..c648cada68b2 100644
--- a/comms/wspr/Makefile
+++ b/comms/wspr/Makefile
@@ -35,6 +35,8 @@ PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//} \
VERSION=${VERSION}
VERSION= 3.00
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
post-configure:
@${REINPLACE_CMD} -e 's|%%DESTDIR%%|${STAGEDIR}|' ${WRKSRC}/Makefile
diff --git a/comms/xwota/Makefile b/comms/xwota/Makefile
index b1c6ece65fb7..1b405b61ba65 100644
--- a/comms/xwota/Makefile
+++ b/comms/xwota/Makefile
@@ -18,6 +18,8 @@ USES= gmake pkgconfig libtool
USE_GNOME= gtk20
GNU_CONFIGURE= yes
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for d in ${WRKSRC}/README \
diff --git a/comms/yagiuda/Makefile b/comms/yagiuda/Makefile
index 5850b7497bd9..2058b36c1d4d 100644
--- a/comms/yagiuda/Makefile
+++ b/comms/yagiuda/Makefile
@@ -15,6 +15,8 @@ LICENSE= GPLv2
GNU_CONFIGURE= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
.for f in first optimise yagi dipole input output
${INSTALL_PROGRAM} ${WRKSRC}/src/${f} ${STAGEDIR}${PREFIX}/bin
diff --git a/comms/yfklog/Makefile b/comms/yfklog/Makefile
index 2b9ab61171c8..b8cb62e8a343 100644
--- a/comms/yfklog/Makefile
+++ b/comms/yfklog/Makefile
@@ -25,6 +25,8 @@ RUN_DEPENDS= p5-Curses>=0:${PORTSDIR}/devel/p5-Curses \
USES= perl5
NO_BUILD= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' \
${WRKSRC}/yfk ${WRKSRC}/yfksubs.pl